aboutsummaryrefslogtreecommitdiff
path: root/lang/dmd2
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2011-08-06 19:12:10 +0000
committerCy Schubert <cy@FreeBSD.org>2011-08-06 19:12:10 +0000
commitdb1521da6e2368b9071532db9346fa0e4fff4eb1 (patch)
treea652763b35f8d91147d5e7500415241f71a20a8f /lang/dmd2
parentcc34a8cdc40f31b02e2502fdc868c49241c351d1 (diff)
downloadports-db1521da6e2368b9071532db9346fa0e4fff4eb1.tar.gz
ports-db1521da6e2368b9071532db9346fa0e4fff4eb1.zip
Notes
Diffstat (limited to 'lang/dmd2')
-rw-r--r--lang/dmd2/Makefile14
-rw-r--r--lang/dmd2/distinfo4
-rw-r--r--lang/dmd2/files/patch-src-dmd-freebsd.mak39
-rw-r--r--lang/dmd2/files/patch-src-dmd-freebsd.mak.orig11
-rw-r--r--lang/dmd2/pkg-plist5
5 files changed, 64 insertions, 9 deletions
diff --git a/lang/dmd2/Makefile b/lang/dmd2/Makefile
index b5a0ec6d595d..c90c3755b758 100644
--- a/lang/dmd2/Makefile
+++ b/lang/dmd2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dmd
PKGNAMESUFFIX= 2
-PORTVERSION= 2.053
+PORTVERSION= 2.054
CATEGORIES= lang
MASTER_SITES= http://ftp.digitalmars.com/
DISTNAME= dmd.${PORTVERSION}
@@ -39,6 +39,10 @@ LICENSE_PERMS_DMD= no-dist-mirror no-dist-sell no-pkg-mirror no-pkg-sell auto-ac
BROKEN= does not compile
.endif
+.if ${ARCH} == "amd64"
+ARCH_ARGS+= "MODEL=64"
+.endif
+
MODULEDIR= ${PREFIX}/include/d/phobos2
post-patch:
@@ -60,9 +64,9 @@ post-patch:
post-build:
cd ${WRKSRC}/../druntime && \
- ${SETENV} PATH=${WRKSRC}:${PATH} ${GMAKE} ${MAKE_FLAGS} posix.mak
+ ${SETENV} PATH=${WRKSRC}:${PATH} ${GMAKE} ${MAKE_FLAGS} posix.mak ${ARCH_ARGS}
cd ${WRKSRC}/../phobos && \
- ${SETENV} PATH=${WRKSRC}:${PATH} ${GMAKE} ${MAKE_FLAGS} posix.mak
+ ${SETENV} PATH=${WRKSRC}:${PATH} ${GMAKE} ${MAKE_FLAGS} posix.mak ${ARCH_ARGS}
do-install:
${INSTALL_MAN} ${WRKDIR}/dmd2/man/man1/dmd.1 ${MANPREFIX}/man/man1/dmd2.1
@@ -71,7 +75,11 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/dmd2/linux/bin32/dmd.conf ${PREFIX}/etc/dmd2.conf
.endif
${INSTALL_PROGRAM} ${WRKSRC}/dmd ${PREFIX}/bin/dmd2
+.if ${ARCH} == "amd64"
+ ${INSTALL_DATA} ${WRKSRC}/../phobos/generated/freebsd/release/64/libphobos2.a ${PREFIX}/lib
+.else
${INSTALL_DATA} ${WRKSRC}/../phobos/generated/freebsd/release/32/libphobos2.a ${PREFIX}/lib
+.endif
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKDIR}/dmd2/linux/bin32/dmd.conf ${EXAMPLESDIR}/dmd2.conf
cd ${WRKDIR}/dmd2 && ${COPYTREE_SHARE} samples ${EXAMPLESDIR}
diff --git a/lang/dmd2/distinfo b/lang/dmd2/distinfo
index 25eb8a8ab32a..da462fbe93de 100644
--- a/lang/dmd2/distinfo
+++ b/lang/dmd2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dmd.2.053.zip) = 12df2090780d97ff2e0ebb8ed0867ba60b3a91aee9f8524a0149c17facda59b1
-SIZE (dmd.2.053.zip) = 15705351
+SHA256 (dmd.2.054.zip) = 3347dee91d8884b2f105666f085ba0b2c27b989967cf0001b284f3da922ca0c2
+SIZE (dmd.2.054.zip) = 16114301
diff --git a/lang/dmd2/files/patch-src-dmd-freebsd.mak b/lang/dmd2/files/patch-src-dmd-freebsd.mak
index a7e58e2831c7..32409f3232ed 100644
--- a/lang/dmd2/files/patch-src-dmd-freebsd.mak
+++ b/lang/dmd2/files/patch-src-dmd-freebsd.mak
@@ -1,5 +1,5 @@
---- freebsd.mak.orig 2011-06-24 17:02:51.938546700 -0700
-+++ freebsd.mak 2011-06-24 17:04:54.369335124 -0700
+--- freebsd.mak.orig
++++ freebsd.mak
@@ -3,7 +3,7 @@
TK=tk
ROOT=root
@@ -9,3 +9,38 @@
CC=c++ $(MODEL)
+@@ -40,7 +40,7 @@ DMD_OBJS = \
+ type.o typinf.o util.o var.o version.o strtold.o utf.o staticassert.o \
+ unialpha.o toobj.o toctype.o toelfdebug.o entity.o doc.o macro.o \
+ hdrgen.o delegatize.o aa.o ti_achar.o toir.o interpret.o traits.o \
+- builtin.o clone.o aliasthis.o \
++ builtin.o clone.o aliasthis.o intrange.o \
+ man.o arrayop.o port.o response.o async.o json.o speller.o aav.o unittests.o \
+ imphint.o argtypes.o ti_pvoid.o \
+ libelf.o elfobj.o
+@@ -53,7 +53,7 @@ SRC = win32.mak linux.mak osx.mak freebs
+ inifile.c iasm.c module.c scope.c dump.c init.h init.c attrib.h \
+ attrib.c opover.c class.c mangle.c bit.c tocsym.c func.c inline.c \
+ access.c complex_t.h irstate.h irstate.c glue.c msc.c ph.c tk.c \
+- s2ir.c todt.c e2ir.c util.c identifier.h parse.h \
++ s2ir.c todt.c e2ir.c util.c identifier.h parse.h intrange.h \
+ scope.h enum.h import.h mars.h module.h mtype.h dsymbol.h \
+ declaration.h lexer.h expression.h irstate.h statement.h eh.c \
+ utf.h utf.c staticassert.h staticassert.c unialpha.c \
+@@ -62,7 +62,7 @@ SRC = win32.mak linux.mak osx.mak freebs
+ delegatize.c toir.h toir.c interpret.c traits.c cppmangle.c \
+ builtin.c clone.c lib.h libomf.c libelf.c libmach.c arrayop.c \
+ aliasthis.h aliasthis.c json.h json.c unittests.c imphint.c \
+- argtypes.c \
++ argtypes.c intrange.c \
+ $C/cdef.h $C/cc.h $C/oper.h $C/ty.h $C/optabgen.c \
+ $C/global.h $C/parser.h $C/code.h $C/type.h $C/dt.h $C/cgcv.h \
+ $C/el.h $C/iasm.h $C/rtlsym.h $C/html.h \
+@@ -596,6 +596,7 @@ gcov:
+ gcov utf.c
+ gcov util.c
+ gcov version.c
++ gcov intrange.c
+
+ # gcov hdrgen.c
+ # gcov tocvdebug.c
diff --git a/lang/dmd2/files/patch-src-dmd-freebsd.mak.orig b/lang/dmd2/files/patch-src-dmd-freebsd.mak.orig
new file mode 100644
index 000000000000..a7e58e2831c7
--- /dev/null
+++ b/lang/dmd2/files/patch-src-dmd-freebsd.mak.orig
@@ -0,0 +1,11 @@
+--- freebsd.mak.orig 2011-06-24 17:02:51.938546700 -0700
++++ freebsd.mak 2011-06-24 17:04:54.369335124 -0700
+@@ -3,7 +3,7 @@
+ TK=tk
+ ROOT=root
+
+-MODEL=-m32
++MODEL=
+
+ CC=c++ $(MODEL)
+
diff --git a/lang/dmd2/pkg-plist b/lang/dmd2/pkg-plist
index e9926fcb39d6..2d0b00035c2d 100644
--- a/lang/dmd2/pkg-plist
+++ b/lang/dmd2/pkg-plist
@@ -8,6 +8,7 @@ lib/libphobos2.a
%%EXAMPLESDIR%%/samples/d/chello.d
%%EXAMPLESDIR%%/samples/d/clean.bat
%%EXAMPLESDIR%%/samples/d/d2html.d
+%%EXAMPLESDIR%%/samples/d/d2html.d.htm
%%EXAMPLESDIR%%/samples/d/d2html.kwd
%%EXAMPLESDIR%%/samples/d/dclient.d
%%EXAMPLESDIR%%/samples/d/dhry.d
@@ -76,6 +77,7 @@ include/d/druntime/import/core/sys/posix/inttypes.di
include/d/druntime/import/core/sys/posix/net/if_.di
include/d/druntime/import/core/sys/posix/netinet/in_.di
include/d/druntime/import/core/sys/posix/netinet/tcp.di
+include/d/druntime/import/core/sys/posix/netdb.di
include/d/druntime/import/core/sys/posix/poll.di
include/d/druntime/import/core/sys/posix/pthread.di
include/d/druntime/import/core/sys/posix/pwd.di
@@ -115,6 +117,7 @@ include/d/phobos2/index.d
include/d/phobos2/std/__fileinit.d
include/d/phobos2/std/algorithm.d
include/d/phobos2/std/array.d
+include/d/phobos2/std/ascii.d
include/d/phobos2/std/atomics.d
include/d/phobos2/std/base64.d
include/d/phobos2/std/bigint.d
@@ -181,7 +184,6 @@ include/d/phobos2/std/metastrings.d
include/d/phobos2/std/mmfile.d
include/d/phobos2/std/net/isemail.d
include/d/phobos2/std/numeric.d
-include/d/phobos2/std/openrj.d
include/d/phobos2/std/outbuffer.d
include/d/phobos2/std/parallelism.d
include/d/phobos2/std/path.d
@@ -234,7 +236,6 @@ include/d/phobos2/unittest.d
@dirrm include/d/phobos2/etc/c
@dirrm include/d/phobos2/etc
@dirrm include/d/phobos2
-@dirrm include/d/druntime/import/std
@dirrm include/d/druntime/import/core/sys/windows
@dirrm include/d/druntime/import/core/sys/posix/sys
@dirrm include/d/druntime/import/core/sys/posix/netinet