aboutsummaryrefslogtreecommitdiff
path: root/lang/duktape
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-10-11 02:19:45 +0000
committerSteve Wills <swills@FreeBSD.org>2018-10-11 02:19:45 +0000
commit45ecdfc44c92fe9038c879ec43da04147fbd5417 (patch)
treee10f5f74ad20c94acec7e9c15084cdae513e62c5 /lang/duktape
parent1e18211acba658345b78a979a1b606873edb4896 (diff)
downloadports-45ecdfc44c92fe9038c879ec43da04147fbd5417.tar.gz
ports-45ecdfc44c92fe9038c879ec43da04147fbd5417.zip
Notes
Diffstat (limited to 'lang/duktape')
-rw-r--r--lang/duktape/Makefile14
-rw-r--r--lang/duktape/distinfo6
-rw-r--r--lang/duktape/files/patch-Makefile.cmdline18
3 files changed, 19 insertions, 19 deletions
diff --git a/lang/duktape/Makefile b/lang/duktape/Makefile
index 5e71aca024a2..3115c15df918 100644
--- a/lang/duktape/Makefile
+++ b/lang/duktape/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= duktape
-PORTVERSION= 2.2.1
+PORTVERSION= 2.3.0
CATEGORIES= lang devel
MASTER_SITES= http://duktape.org/
@@ -11,18 +11,22 @@ COMMENT= Embeddable Javascript engine
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= libedit tar:xz
+USES= tar:xz
MAKEFILE= Makefile.cmdline
ALL_TARGET= duk
PLIST_FILES= bin/duk
-post-patch:
- @${REINPLACE_CMD} -e "/history\.h/d ; s,readline/,editline/,g " \
- ${WRKSRC}/examples/cmdline/duk_cmdline.c
+PORTDOCS= README.rst
+
+OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/duk ${STAGEDIR}${PREFIX}/bin
+post-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/lang/duktape/distinfo b/lang/duktape/distinfo
index 9ece2060d50c..4eb818b7b4a1 100644
--- a/lang/duktape/distinfo
+++ b/lang/duktape/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1524915777
-SHA256 (duktape-2.2.1.tar.xz) = 3abe2eed2553305262b892c98f550bb1a94cf4fd73b51dc5c176fe08e7ade7f2
-SIZE (duktape-2.2.1.tar.xz) = 966496
+TIMESTAMP = 1539010714
+SHA256 (duktape-2.3.0.tar.xz) = ed6e2f3ab2061628a7aeee27ccff16538ba6a151480cccf2e846bd061e45afe8
+SIZE (duktape-2.3.0.tar.xz) = 997572
diff --git a/lang/duktape/files/patch-Makefile.cmdline b/lang/duktape/files/patch-Makefile.cmdline
index 2b9ec10e5d88..a979fa87b679 100644
--- a/lang/duktape/files/patch-Makefile.cmdline
+++ b/lang/duktape/files/patch-Makefile.cmdline
@@ -1,15 +1,11 @@
---- Makefile.cmdline.orig 2017-09-23 01:06:08 UTC
+--- Makefile.cmdline.orig 2018-10-08 14:59:26 UTC
+++ Makefile.cmdline
-@@ -8,9 +8,9 @@ DUKTAPE_SOURCES = src/duktape.c
+@@ -8,7 +8,7 @@ DUKTAPE_SOURCES = src/duktape.c
CMDLINE_SOURCES = \
examples/cmdline/duk_cmdline.c
--CC = gcc
--CCOPTS = -Os -pedantic -std=c99 -Wall -fstrict-aliasing -fomit-frame-pointer
--CCOPTS += -I./examples/cmdline -I./src # duktape.h and duk_config.h must be in include path
-+CC ?= gcc
-+CCOPTS = ${CFLAGS} -pedantic -std=c99 -Wall -fstrict-aliasing -fomit-frame-pointer
-+CCOPTS += -I./examples/cmdline -I./src ${CPPFLAGS} # duktape.h and duk_config.h must be in include path
- CCLIBS = -lm
-
- # Enable print() and alert() for command line using an optional extra module.
+-CC = gcc
++CC = cc
+ CCOPTS = -Os -pedantic -std=c99 -Wall -fstrict-aliasing -fomit-frame-pointer
+ CCOPTS += -I./examples/cmdline -I./src # duktape.h and duk_config.h must be in include path
+ CCLIBS = -lm