aboutsummaryrefslogtreecommitdiff
path: root/lang/ecl
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:08:37 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:08:37 +0000
commita9dcad2fffcc27906b85c5a15fdb3e50fdc1e2e2 (patch)
tree23607acdfffe977946d3c7bb877bab60e64640e7 /lang/ecl
parent4e1b79a0a61f4973df8b4b0864d22086c769e219 (diff)
Notes
Diffstat (limited to 'lang/ecl')
-rw-r--r--lang/ecl/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/lang/ecl/Makefile b/lang/ecl/Makefile
index f570fc468396..a549efed6ca9 100644
--- a/lang/ecl/Makefile
+++ b/lang/ecl/Makefile
@@ -12,7 +12,7 @@ COMMENT= ANSI Common Lisp implementation
LICENSE= LGPL20
-LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
+LIB_DEPENDS= libgmp.so:math/gmp
MAKE_JOBS_UNSAFE= yes
USES= gmake perl5 tar:tgz
@@ -47,15 +47,15 @@ CLX_CONFIGURE_OFF= --with-clx=no
SOCKETS_CONFIGURE_ON= --with-tcp=yes
SOCKETS_CONFIGURE_OFF= --with-tcp=no
-DFFI_LIB_DEPENDS= libffi.so:${PORTSDIR}/devel/libffi
+DFFI_LIB_DEPENDS= libffi.so:devel/libffi
DFFI_CONFIGURE_ON= --with-dffi=system
DFFI_CONFIGURE_OFF= --with-dffi=no
THREADS_CONFIGURE_ON= --enable-threads=yes
THREADS_LDFLAGS= -lpthread
-THREADS_LIB_DEPENDS= libgc-threaded.so:${PORTSDIR}/devel/boehm-gc-threaded
+THREADS_LIB_DEPENDS= libgc-threaded.so:devel/boehm-gc-threaded
THREADS_CONFIGURE_OFF= --enable-threads=no
-THREADS_LIB_DEPENDS_OFF= libgc.so:${PORTSDIR}/devel/boehm-gc
+THREADS_LIB_DEPENDS_OFF= libgc.so:devel/boehm-gc
post-patch-THREADS-on:
@${REINPLACE_CMD} -e 's|-lgc|-lgc-threaded|' ${WRKSRC}/src/configure