aboutsummaryrefslogtreecommitdiff
path: root/lang/elk/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-06-17 09:36:30 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-06-17 09:36:30 +0000
commit492588f99be025e8fa213c689adf01af67a49cd2 (patch)
tree7a0d43888b25cac572c6e507f897c45034d3fb83 /lang/elk/Makefile
parentb821effca4d567404360791c88de0b321b318b3c (diff)
Notes
Diffstat (limited to 'lang/elk/Makefile')
-rw-r--r--lang/elk/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/lang/elk/Makefile b/lang/elk/Makefile
index ea74d7ef9f75..1a10f6d798ed 100644
--- a/lang/elk/Makefile
+++ b/lang/elk/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= elk
-PORTVERSION= 3.99.6
-PORTREVISION= 3
+PORTVERSION= 3.99.7
CATEGORIES= lang scheme
MASTER_SITES= http://sam.zoy.org/elk/
@@ -19,15 +18,16 @@ LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
USE_BZIP2= yes
USE_MOTIF= yes
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
MAN1= elk.1
-CPPFLAGS= -I${LOCALBASE}/include/libelf -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS= -I${LOCALBASE}/include/libelf -I${LOCALBASE}/include \
+ -I${X11BASE}/include
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
.include <bsd.port.pre.mk>
@@ -35,6 +35,9 @@ LDFLAGS= -L${LOCALBASE}/lib
CFLAGS= -O0
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s|doc examples||g' ${WRKSRC}/Makefile.in
+
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/man/elk.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)