aboutsummaryrefslogtreecommitdiff
path: root/lang/eperl/Makefile
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2009-01-29 19:04:46 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2009-01-29 19:04:46 +0000
commit139df60d141566036c6a4b6421bdaaab409a9b95 (patch)
tree2cd69f8c206db2d312aba4cc9d201dbd7a647ab5 /lang/eperl/Makefile
parentfc0323a3ddd97577f8c7fc65e493533614f68068 (diff)
downloadports-139df60d141566036c6a4b6421bdaaab409a9b95.tar.gz
ports-139df60d141566036c6a4b6421bdaaab409a9b95.zip
Notes
Diffstat (limited to 'lang/eperl/Makefile')
-rw-r--r--lang/eperl/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/lang/eperl/Makefile b/lang/eperl/Makefile
index 7ebc219c242d..3bc98670ba76 100644
--- a/lang/eperl/Makefile
+++ b/lang/eperl/Makefile
@@ -7,16 +7,14 @@
PORTNAME= eperl
PORTVERSION= 2.2.14
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang www perl5
MASTER_SITES= ${MASTER_SITE_OSSP}
MASTER_SITE_SUBDIR= tool/${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= glarkin@FreeBSD.org
COMMENT= Embedded Perl 5 Language
-BROKEN= does not compile
-
# User-controlled variables list
# INSTALL_ALSO_AS_SSSL
# install ePerl also as a Server-Side
@@ -38,6 +36,10 @@ MAN1= eperl.1
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} >= 500809
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-configure
+.endif
+
.if ${OSVERSION} >= 800058
BROKEN= does not build
.endif
@@ -53,16 +55,12 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/eperl ${PREFIX}/bin/eperl
${INSTALL_MAN} ${WRKSRC}/eperl.1 ${PREFIX}/man/man1/eperl.1
-.if !defined(NOPORTDOCS)
- @if [ ! -d ${EXAMPLESDIR} ]; then \
- ${MKDIR} ${EXAMPLESDIR}; \
- fi
+.if !defined(NOPORTEXAMPLES)
+ ${INSTALL} -d ${EXAMPLESDIR}
${CP} ${WRKSRC}/eg/* ${EXAMPLESDIR}/
.endif
.if defined(INSTALL_ALSO_AS_SSSL)
- @if [ ! -d ${PREFIX}/www/cgi-bin ]; then \
- ${MKDIR} ${PREFIX}/www/cgi-bin; \
- fi
+ ${INSTALL} -d ${PREFIX}/www/cgi-bin; \
${INSTALL_PROGRAM} ${WRKSRC}/eperl ${PREFIX}/www/cgi-bin/nph-eperl
@if [ ".`${GREP} x-httpd-eperl ${PREFIX}/etc/apache/srm.conf`" = . ]; then \
${ECHO_CMD} "AddType application/x-httpd-eperl .phtml .eperl .epl" \