aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang-runtime15
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2015-01-31 18:46:25 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2015-01-31 18:46:25 +0000
commit817b9f479c3f83c155951dce193229ba1c9f8253 (patch)
tree34fedd8bc0b5042f29ee4de5faaf89181eaa2973 /lang/erlang-runtime15
parent65353c07ba88e555c02d2d5b1747c9a695474b44 (diff)
downloadports-817b9f479c3f83c155951dce193229ba1c9f8253.tar.gz
ports-817b9f479c3f83c155951dce193229ba1c9f8253.zip
Notes
Diffstat (limited to 'lang/erlang-runtime15')
-rw-r--r--lang/erlang-runtime15/Makefile32
1 files changed, 29 insertions, 3 deletions
diff --git a/lang/erlang-runtime15/Makefile b/lang/erlang-runtime15/Makefile
index 8f7bec3f6410..2eada1c6a1af 100644
--- a/lang/erlang-runtime15/Makefile
+++ b/lang/erlang-runtime15/Makefile
@@ -3,7 +3,7 @@
PORTNAME= erlang
PORTVERSION= 15.b.03.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
http://erlang.stacken.kth.se/download/:erlangorg \
@@ -29,7 +29,7 @@ SUB_LIST= ERLANG_LIB=${ERLANG_LIB}
MAKE_JOBS_UNSAFE=yes
-OPTIONS_DEFINE= GCC DOCS GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX DTRACE
+OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX
GCC_DESC= Use current GCC
HIPE_DESC= Build native HiPE compiler
@@ -40,7 +40,7 @@ WX_DESC= Enable WX application
GS_DESC= Enable GS application (deprecated)
DTRACE_DESC= Enable DTrace support
-OPTIONS_DEFAULT=SMP OPENSSL THREADS SCTP KQUEUE
+OPTIONS_DEFAULT=KQUEUE OPENSSL SCTP SMP THREADS
ERL_RELEASE= R${PORTVERSION:S/.//g:tu:S/1$/-1/}
@@ -163,6 +163,14 @@ MAKE_ARGS+= ARCH=x86
# rest, not in share/doc/erlang as it should, because of relative
# links in the documentation.
+pre-configure:
+.if ! ${PORT_OPTIONS:MHIPE}
+ echo "disabled by port options" > ${WRKSRC}/lib/hipe/SKIP
+.endif
+.if ! ${PORT_OPTIONS:MWX}
+ echo "disabled by port options" > ${WRKSRC}/lib/wx/SKIP
+.endif
+
post-install:
for SECTION in 1 3 4 6; do \
${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_MAN} \
@@ -178,6 +186,24 @@ post-install:
${STAGEDIR}${PREFIX}/lib/${ERLANG_LIB}/lib/dialyzer-*/doc/
.endif
+.if ! ${PORT_OPTIONS:MGS}
+ ${RM} -r ${STAGEDIR}${PREFIX}/lib/erlang/lib/gs-*
+.endif
+.if ! ${PORT_OPTIONS:MJAVA}
+ ${RM} -r ${STAGEDIR}${PREFIX}/lib/erlang/lib/jinterface-*
+.endif
+.if ! ${PORT_OPTIONS:MODBC}
+ ${RM} -r ${STAGEDIR}${PREFIX}/lib/erlang/lib/odbc-*
+.endif
+.if ! ${PORT_OPTIONS:MOPENSSL}
+ ${RM} -r ${STAGEDIR}${PREFIX}/lib/erlang/lib/crypto-*
+ ${RM} -r ${STAGEDIR}${PREFIX}/lib/erlang/lib/ssh-*
+ ${RM} -r ${STAGEDIR}${PREFIX}/lib/erlang/lib/ssl-*
+.endif
+.if ! ${PORT_OPTIONS:MWX}
+ ${RM} -r ${STAGEDIR}${PREFIX}/lib/erlang/lib/wx-*
+.endif
+
@cd ${STAGEDIR}${PREFIX}; ${FIND} lib/${ERLANG_LIB}/* -type d -empty \
| ${SORT} \
| ${SED} -e 's#^#@dir #g' \