aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang-runtime17
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2018-11-05 23:20:17 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2018-11-05 23:20:17 +0000
commit88bd5a054acfb39c07f9af85dbf2f5f30f825214 (patch)
tree04d22ce1cfcbaa0c7df7e739c6c47549934a18ba /lang/erlang-runtime17
parentd186c9c3567b4a3179c6bda1b6d93f2c89eafe16 (diff)
Notes
Diffstat (limited to 'lang/erlang-runtime17')
-rw-r--r--lang/erlang-runtime17/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/lang/erlang-runtime17/Makefile b/lang/erlang-runtime17/Makefile
index 4aefa6eb9dd7..5f05e2a5f341 100644
--- a/lang/erlang-runtime17/Makefile
+++ b/lang/erlang-runtime17/Makefile
@@ -28,6 +28,9 @@ PATCHFILES= patch-otp-17.5.1 patch-otp-17.5.2 patch-otp-17.5.3 \
MAINTAINER= erlang@FreeBSD.org
COMMENT= Functional programming language from Ericsson
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= Does not support OpenSSL 1.1, use Erlang 19+
+
WRKSRC= ${WRKDIR}/otp_src_${ERLANG_REL}
ERLANG_LIB= ${PORTNAME}${PORTVERSION:C/\..*//}
@@ -64,7 +67,7 @@ OPTIONS_EXCLUDE_armv6= DTRACE
OPTIONS_EXCLUDE_armv7= DTRACE
OPTIONS_EXCLUDE_i386= DTRACE
-OPENSSL_VARS= BROKEN_SSL=openssl-devel
+OPENSSL_VARS= BROKEN_SSL=openssl-devel openssl111
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
@@ -98,6 +101,14 @@ WX_VARS= USE_WX=2.8+ WX_COMPS="wx contrib" USE_GL="gl glu"
.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD
+. if ${OSVERSION} >= 1200085 && ${SSL_DEFAULT} == base
+BROKEN= Does not support OpenSSL 1.1, use Erlang 19+
+. endif
+.endif
+
.if ${OPSYS} == FreeBSD
CFLAGS+= -DMAP_NORESERVE=0
.endif