aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang-runtime21
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2018-07-30 09:14:40 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2018-07-30 09:14:40 +0000
commit6b337ae478422e43ae64e6eac93a4270c3253ed7 (patch)
tree00a74303ae1d2d28b3f03185e24ad996401d6e57 /lang/erlang-runtime21
parent53bf8dcb20cb9bbe4b22bda89e8158a6f2272549 (diff)
Notes
Diffstat (limited to 'lang/erlang-runtime21')
-rw-r--r--lang/erlang-runtime21/Makefile1
-rw-r--r--lang/erlang-runtime21/files/patch-erts_emulator_beam_erl__alloc.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/lang/erlang-runtime21/Makefile b/lang/erlang-runtime21/Makefile
index d2b5e8cd3ecd..979f918d6296 100644
--- a/lang/erlang-runtime21/Makefile
+++ b/lang/erlang-runtime21/Makefile
@@ -3,6 +3,7 @@
PORTNAME= erlang
PORTVERSION= 21.0.4
+PORTREVISION= 1
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
http://erlang.stacken.kth.se/download/:erlangorg \
diff --git a/lang/erlang-runtime21/files/patch-erts_emulator_beam_erl__alloc.c b/lang/erlang-runtime21/files/patch-erts_emulator_beam_erl__alloc.c
new file mode 100644
index 000000000000..60bf07dcbef4
--- /dev/null
+++ b/lang/erlang-runtime21/files/patch-erts_emulator_beam_erl__alloc.c
@@ -0,0 +1,11 @@
+--- erts/emulator/beam/erl_alloc.c.orig 2018-06-19 07:07:55 UTC
++++ erts/emulator/beam/erl_alloc.c
+@@ -114,7 +114,7 @@ typedef union {
+ char align_afa[ERTS_ALC_CACHE_LINE_ALIGN_SIZE(sizeof(AFAllctr_t))];
+ AOFFAllctr_t aoffa;
+ char align_aoffa[ERTS_ALC_CACHE_LINE_ALIGN_SIZE(sizeof(AOFFAllctr_t))];
+-} ErtsAllocatorState_t;
++} ErtsAllocatorState_t erts_align_attribute(ERTS_CACHE_LINE_SIZE);
+
+ static ErtsAllocatorState_t std_alloc_state;
+ static ErtsAllocatorState_t ll_alloc_state;