aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang-wx
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2017-06-24 18:34:56 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2017-06-24 18:34:56 +0000
commit3e78d2942863bc7c9761c0894ccd6cd506e547e6 (patch)
treebc8deb1ef3293cdcb66f25ef27142a89138d1e8a /lang/erlang-wx
parenta868e64a6433fbed6018781e91a380fabedf20e9 (diff)
Notes
Diffstat (limited to 'lang/erlang-wx')
-rw-r--r--lang/erlang-wx/Makefile10
-rw-r--r--lang/erlang-wx/distinfo22
-rw-r--r--lang/erlang-wx/files/patch-lib_wx_c__src_wxe__impl.cpp20
3 files changed, 43 insertions, 9 deletions
diff --git a/lang/erlang-wx/Makefile b/lang/erlang-wx/Makefile
index f757425bd20c..0d28d9112c00 100644
--- a/lang/erlang-wx/Makefile
+++ b/lang/erlang-wx/Makefile
@@ -1,7 +1,8 @@
# $FreeBSD$
PORTNAME= erlang
-PORTVERSION= 20.0
+PORTVERSION= 19.3.6
+PORTEPOCH= 1
CATEGORIES= lang parallel
MASTER_SITES= http://www.erlang.org/download/:erlangorg \
http://erlang.stacken.kth.se/download/:erlangorg \
@@ -14,7 +15,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
PATCH_SITES= http://olgeni.olgeni.com/~olgeni/distfiles/ \
LOCAL/olgeni
-PATCHFILES=
+PATCHFILES= patch-otp-19.3.1 patch-otp-19.3.2 patch-otp-19.3.3 \
+ patch-otp-19.3.4 patch-otp-19.3.5 patch-otp-19.3.6
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Erlang bindings for wxWindows
@@ -32,14 +34,14 @@ MAKE_JOBS_UNSAFE=yes
OPTIONS_DEFINE= DOCS
-ERL_RELEASE= 20.0
+ERL_RELEASE= 19.3
USES= gmake
USE_GL= gl glu
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
-APP_VERSION= 1.8.1
+APP_VERSION= 1.8
APP_DIR= ${PREFIX}/lib/erlang/lib/wx-${APP_VERSION}
.include <bsd.port.options.mk>
diff --git a/lang/erlang-wx/distinfo b/lang/erlang-wx/distinfo
index a655e15e731c..f1b2554b7cdb 100644
--- a/lang/erlang-wx/distinfo
+++ b/lang/erlang-wx/distinfo
@@ -1,5 +1,17 @@
-TIMESTAMP = 1498166065
-SHA256 (erlang/otp_src_20.0.tar.gz) = fe80e1e14a2772901be717694bb30ac4e9a07eee0cc7a28988724cbd21476811
-SIZE (erlang/otp_src_20.0.tar.gz) = 87346046
-SHA256 (erlang/otp_doc_html_20.0.tar.gz) = 1ab25110b148ce263d6e68cd5a3b912299b6066cfcd9d2fce416a4e9b7d2543a
-SIZE (erlang/otp_doc_html_20.0.tar.gz) = 33948386
+TIMESTAMP = 1496937511
+SHA256 (erlang/otp_src_19.3.tar.gz) = fe4a00651db39b8542b04530a48d24b2f2e7e0b77cbe93d728c9f05325bdfe83
+SIZE (erlang/otp_src_19.3.tar.gz) = 68510871
+SHA256 (erlang/otp_doc_html_19.3.tar.gz) = dc3e3a82d1aba7f0deac1ddb81b7d6f8dee9a75e1d42b90c677a2b645f19a00c
+SIZE (erlang/otp_doc_html_19.3.tar.gz) = 35818689
+SHA256 (erlang/patch-otp-19.3.1) = 2373f890516b58ae006812ba5f15e4af1f8820be98230011b8cd8b345f51dedd
+SIZE (erlang/patch-otp-19.3.1) = 30225
+SHA256 (erlang/patch-otp-19.3.2) = 21c56ac188177985c9db11c7066dcee0f7370760da3e15a0d03c235bd2a2cb2a
+SIZE (erlang/patch-otp-19.3.2) = 6290
+SHA256 (erlang/patch-otp-19.3.3) = dbe1cab750a3339c3755db27b800e53232519c84a304bd562263ffb060afab55
+SIZE (erlang/patch-otp-19.3.3) = 12525
+SHA256 (erlang/patch-otp-19.3.4) = 02437ac753932f913209102e8cb249a264b774833bfda8c1532b338af60ff8af
+SIZE (erlang/patch-otp-19.3.4) = 13504
+SHA256 (erlang/patch-otp-19.3.5) = 5755da205004ae7e724390958db9ecc737d99ec14e0d14abcec8b8603ea6ece5
+SIZE (erlang/patch-otp-19.3.5) = 44563
+SHA256 (erlang/patch-otp-19.3.6) = ee1b5f0fd64db3322031c38722aee96a8ee35aaac454f430c829446a198f6534
+SIZE (erlang/patch-otp-19.3.6) = 13073
diff --git a/lang/erlang-wx/files/patch-lib_wx_c__src_wxe__impl.cpp b/lang/erlang-wx/files/patch-lib_wx_c__src_wxe__impl.cpp
new file mode 100644
index 000000000000..5b1e66586f2f
--- /dev/null
+++ b/lang/erlang-wx/files/patch-lib_wx_c__src_wxe__impl.cpp
@@ -0,0 +1,20 @@
+--- lib/wx/c_src/wxe_impl.cpp.orig 2017-01-30 23:13:25 UTC
++++ lib/wx/c_src/wxe_impl.cpp
+@@ -666,7 +666,7 @@ void * WxeApp::getPtr(char * bp, wxeMemE
+ throw wxe_badarg(index);
+ }
+ void * temp = memenv->ref2ptr[index];
+- if((index < memenv->next) && ((index == 0) || (temp > NULL)))
++ if((index < memenv->next) && ((index == 0) || (temp != NULL)))
+ return temp;
+ else {
+ throw wxe_badarg(index);
+@@ -678,7 +678,7 @@ void WxeApp::registerPid(char * bp, ErlD
+ if(!memenv)
+ throw wxe_badarg(index);
+ void * temp = memenv->ref2ptr[index];
+- if((index < memenv->next) && ((index == 0) || (temp > NULL))) {
++ if((index < memenv->next) && ((index == 0) || (temp != NULL))) {
+ ptrMap::iterator it;
+ it = ptr2ref.find(temp);
+ if(it != ptr2ref.end()) {