aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang14/files
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2004-12-22 15:31:14 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2004-12-22 15:31:14 +0000
commit14aa3719ef02a1564534296c7363d303397da4c6 (patch)
tree39a8b359e39304b2d696c81c1cd7b95506c56510 /lang/erlang14/files
parent9a85393dd6a2912d4752615136acd6b096c7a7be (diff)
downloadports-14aa3719ef02a1564534296c7363d303397da4c6.tar.gz
ports-14aa3719ef02a1564534296c7363d303397da4c6.zip
Notes
Diffstat (limited to 'lang/erlang14/files')
-rw-r--r--lang/erlang14/files/patch-Makefile.in19
-rw-r--r--lang/erlang14/files/patch-aj16
-rw-r--r--lang/erlang14/files/patch-erts_emulator_Makefile.in13
-rw-r--r--lang/erlang14/files/patch-lib_crypto_c__src_Makefile.in14
-rw-r--r--lang/erlang14/files/patch-lib_gs_src_tool__utils.erl73
-rw-r--r--lang/erlang14/files/patch-lib_kernel_src_inet__config.erl19
-rw-r--r--lang/erlang14/files/patch-lib_ssl_src_ssl__broker.erl14
-rw-r--r--lang/erlang14/files/patch-lib_stdlib_src_filelib.erl17
8 files changed, 58 insertions, 127 deletions
diff --git a/lang/erlang14/files/patch-Makefile.in b/lang/erlang14/files/patch-Makefile.in
index f3c31acac387..86bb7e10acf2 100644
--- a/lang/erlang14/files/patch-Makefile.in
+++ b/lang/erlang14/files/patch-Makefile.in
@@ -1,32 +1,21 @@
$FreeBSD$
---- Makefile.in.orig Fri Dec 19 13:55:58 2003
-+++ Makefile.in Sat Jun 26 20:25:23 2004
-@@ -534,14 +534,20 @@
+--- Makefile.in.orig Tue Sep 14 13:46:54 2004
++++ Makefile.in Thu Oct 7 14:36:38 2004
+@@ -528,14 +528,9 @@
# Erlang base public files
#
install.bin:
- rm -f $(BINDIR)/erl $(BINDIR)/erlc \
- $(BINDIR)/ecc $(BINDIR)/elink $(BINDIR)/ear $(BINDIR)/escript
-+ rm -f $(BINDIR)/erl $(BINDIR)/erlc $(BINDIR)/run_erl \
-+ $(BINDIR)/to_erl $(BINDIR)/beam_evm $(BINDIR)/ear \
-+ $(BINDIR)/ecc $(BINDIR)/elink $(BINDIR)/erlexec \
-+ $(BINDIR)/escript
++ rm -f $(BINDIR)/erl $(BINDIR)/erlc
${LN_S} $(ERLANG_BINDIR)/erl $(BINDIR)/erl
${LN_S} $(ERLANG_BINDIR)/erlc $(BINDIR)/erlc
- ${LN_S} $(ERLANG_BINDIR)/ecc $(BINDIR)/ecc
- ${LN_S} $(ERLANG_BINDIR)/elink $(BINDIR)/elink
- ${LN_S} $(ERLANG_BINDIR)/ear $(BINDIR)/ear
- ${LN_S} $(ERLANG_BINDIR)/escript $(BINDIR)/escript
-+ ${LN_S} $(ERLANG_BINDIR)/run_erl $(BINDIR)/run_erl
-+ ${LN_S} $(ERLANG_BINDIR)/to_erl $(BINDIR)/to_erl
-+ ${LN_S} $(ERLANG_ERTSBINDIR)/beam_evm $(BINDIR)/beam_evm
-+ ${LN_S} $(ERLANG_ERTSBINDIR)/ear $(BINDIR)/ear
-+ ${LN_S} $(ERLANG_ERTSBINDIR)/ecc $(BINDIR)/ecc
-+ ${LN_S} $(ERLANG_ERTSBINDIR)/elink $(BINDIR)/elink
-+ ${LN_S} $(ERLANG_ERTSBINDIR)/erlexec $(BINDIR)/erlexec
-+ ${LN_S} $(ERLANG_ERTSBINDIR)/escript $(BINDIR)/escript
#
# Directories needed before we can install
diff --git a/lang/erlang14/files/patch-aj b/lang/erlang14/files/patch-aj
index 6b8104ce7904..c3b2f87f73c6 100644
--- a/lang/erlang14/files/patch-aj
+++ b/lang/erlang14/files/patch-aj
@@ -1,19 +1,9 @@
$FreeBSD$
---- erts/etc/unix/Install.src.orig Wed Mar 5 17:20:07 2003
-+++ erts/etc/unix/Install.src Wed Mar 5 17:21:04 2003
-@@ -119,7 +119,8 @@
- sed -e "s;%EMU%;%EMULATOR%%EMULATOR_NUMBER%;" $ERL_ROOT/erts-%I_VSN%/bin/start_erl.src > start_erl
- chmod 755 start_erl
-
--if [ -d $ERL_ROOT/lib/sasl* ]
-+set $ERL_ROOT/lib/sasl*
-+if [ -d $1 ]
- then
- (cd $ERL_ROOT/releases
- echo %I_VSN% %I_SYSTEM_VSN% > start_erl.data)
-@@ -193,4 +194,4 @@
+--- erts/etc/unix/Install.src.orig Thu Oct 7 15:45:43 2004
++++ erts/etc/unix/Install.src Thu Oct 7 15:45:59 2004
+@@ -157,4 +157,4 @@
./misc/format_man_pages $ERL_ROOT
fi
diff --git a/lang/erlang14/files/patch-erts_emulator_Makefile.in b/lang/erlang14/files/patch-erts_emulator_Makefile.in
deleted file mode 100644
index cae12b839cda..000000000000
--- a/lang/erlang14/files/patch-erts_emulator_Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- erts/emulator/Makefile.in.orig Sat Jun 26 13:57:01 2004
-+++ erts/emulator/Makefile.in Sat Jun 26 13:57:39 2004
-@@ -220,6 +220,7 @@
- $(INSTALL_DATA) $(RELEASE_INCLUDES) $(RELSYSDIR)/src
- $(INSTALL_PROGRAM) $(BINDIR)/$(EMULATOR_EXECUTABLE) $(RELSYSDIR)/bin
- ifeq ($(ERLANG_OSTYPE), unix)
-+ $(INSTALL_PROGRAM) $(BINDIR)/$(EMULATOR_EXECUTABLE_SAE) $(RELSYSDIR)/bin
- $(INSTALL_PROGRAM) $(BINDIR)/$(EMULATOR_EXECUTABLE_ELIB) $(RELSYSDIR)/bin
- $(INSTALL_PROGRAM) $(BINDIR)/$(CS_EXECUTABLE) $(RELSYSDIR)/bin
- endif
diff --git a/lang/erlang14/files/patch-lib_crypto_c__src_Makefile.in b/lang/erlang14/files/patch-lib_crypto_c__src_Makefile.in
new file mode 100644
index 000000000000..81e0ce9e83b3
--- /dev/null
+++ b/lang/erlang14/files/patch-lib_crypto_c__src_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- lib/crypto/c_src/Makefile.in.orig Thu Oct 7 12:11:06 2004
++++ lib/crypto/c_src/Makefile.in Thu Oct 7 12:11:07 2004
+@@ -121,7 +121,7 @@
+ release_spec: opt
+ $(INSTALL_DIR) $(RELSYSDIR)/priv/obj
+ $(INSTALL_DIR) $(RELSYSDIR)/priv/lib
+- $(INSTALL_PROGRAM) $(DRV_MAKEFILE) $(RELSYSDIR)/priv/obj
++ $(INSTALL_DATA) $(DRV_MAKEFILE) $(RELSYSDIR)/priv/obj
+ $(INSTALL_PROGRAM) $(OBJS) $(RELSYSDIR)/priv/obj
+ $(INSTALL_PROGRAM) $(DYN_DRIVER) $(RELSYSDIR)/priv/lib
+
diff --git a/lang/erlang14/files/patch-lib_gs_src_tool__utils.erl b/lang/erlang14/files/patch-lib_gs_src_tool__utils.erl
index 4f4482bc45b1..883ff337892d 100644
--- a/lang/erlang14/files/patch-lib_gs_src_tool__utils.erl
+++ b/lang/erlang14/files/patch-lib_gs_src_tool__utils.erl
@@ -1,8 +1,8 @@
$FreeBSD$
---- lib/gs/src/tool_utils.erl.orig Thu Sep 4 23:01:37 2003
-+++ lib/gs/src/tool_utils.erl Fri Sep 5 00:16:20 2003
+--- lib/gs/src/tool_utils.erl.orig Tue Oct 12 22:14:23 2004
++++ lib/gs/src/tool_utils.erl Tue Oct 12 22:17:17 2004
@@ -27,6 +27,9 @@
-export([file_dialog/1]).
-export([notify/2, confirm/2, confirm_yesno/2, request/2]).
@@ -13,29 +13,31 @@ $FreeBSD$
%%----------------------------------------------------------------------
%% open_help(GS, File)
%% GS = gsobj() (GS root object returned by gs:start/0,1)
-@@ -51,7 +54,7 @@
- local ->
- Cmd = case os:type() of
+@@ -65,7 +68,8 @@
+ local ->
+ case os:type() of
{unix,_AnyType} ->
- "netscape -remote \"openURL(file:" ++ File ++ ")\"";
+ unix_url_command("file:" ++ File);
-
++
{win32,_AnyType} ->
- "start " ++ filename:nativename(File)
-@@ -62,7 +65,7 @@
- remote ->
- Cmd = case os:type() of
+ "start " ++ filename:nativename(File);
+
+@@ -77,7 +81,7 @@
+ remote ->
+ case os:type() of
{unix,_AnyType} ->
- "netscape -remote \"openURL(" ++ File ++ ")\"";
-+ unix_url_command(File);
++ unix_url_command("file:" ++ File);
{win32,_AnyType} ->
- "netscape.exe -h " ++ regexp:gsub(File,"\\\\","/")
-@@ -307,3 +310,54 @@
+ "netscape.exe -h " ++ regexp:gsub(File,"\\\\","/");
+@@ -337,3 +341,54 @@
[Last];
insert_newlines(Other) ->
Other.
+
++
+%% find_browser(BrowserList) => string() | false
+%% BrowserList - [string()]
+%% Given a list of basenames, find the first available executable.
@@ -61,28 +63,27 @@ $FreeBSD$
+ Template = "BROWSER -remote \"openURL(" ++ URL ++ ")\" || BROWSER " ++ URL ++ "&",
+
+ case os:getenv("BROWSER") of
-+ false ->
-+ %% look for a compatible browser
-+ case find_browser(?BROWSERS) of
-+ false ->
-+ "";
-+ Browser ->
-+ case regexp:gsub(Template, "BROWSER", Browser) of
-+ {ok, Command, 0} ->
-+ %% Template does not contain "BROWSER" placeholder
-+ "";
-+ {ok, Command, _} ->
-+ Command
-+ end
-+ end;
++ false ->
++ %% look for a compatible browser
++ case find_browser(?BROWSERS) of
++ false ->
++ "";
++ Browser ->
++ case regexp:gsub(Template, "BROWSER", Browser) of
++ {ok, Command, 0} ->
++ %% Template does not contain "BROWSER" placeholder
++ "";
++ {ok, Command, _} ->
++ Command
++ end
++ end;
+
-+ Value ->
-+ case regexp:gsub(Template, "BROWSER", Value) of
-+ {ok, Command2, 0} ->
-+ %% no placeholder
-+ "";
-+ {ok, Command2, _} ->
-+ Command2
-+ end
++ Value ->
++ case regexp:gsub(Template, "BROWSER", Value) of
++ {ok, Command2, 0} ->
++ %% no placeholder
++ "";
++ {ok, Command2, _} ->
++ Command2
++ end
+ end.
-+
diff --git a/lang/erlang14/files/patch-lib_kernel_src_inet__config.erl b/lang/erlang14/files/patch-lib_kernel_src_inet__config.erl
deleted file mode 100644
index 362a217ce495..000000000000
--- a/lang/erlang14/files/patch-lib_kernel_src_inet__config.erl
+++ /dev/null
@@ -1,19 +0,0 @@
-
-$FreeBSD$
-
---- lib/kernel/src/inet_config.erl.orig Mon Jul 7 14:06:28 2003
-+++ lib/kernel/src/inet_config.erl Fri Sep 19 14:21:14 2003
-@@ -78,7 +78,12 @@
- error("can't set lookup to native: ~p", [Reason])
- end;
- freebsd -> %% we may have to check version (2.2.2)
-- load_resolv(filename:join(Etc,"host.conf"), host_conf_freebsd);
-+ case os:version() of
-+ {Major,_,_} when Major >= 5 ->
-+ load_resolv(filename:join(Etc,"nsswitch.conf"), nsswitch_conf);
-+ _ ->
-+ load_resolv(filename:join(Etc,"host.conf"), host_conf_freebsd)
-+ end;
- 'bsd/os' ->
- load_resolv(filename:join(Etc,"irs.conf"), host_conf_bsdos);
- linux ->
diff --git a/lang/erlang14/files/patch-lib_ssl_src_ssl__broker.erl b/lang/erlang14/files/patch-lib_ssl_src_ssl__broker.erl
deleted file mode 100644
index e91c911ef98d..000000000000
--- a/lang/erlang14/files/patch-lib_ssl_src_ssl__broker.erl
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- lib/ssl/src/ssl_broker.erl.orig Thu Mar 11 17:58:12 2004
-+++ lib/ssl/src/ssl_broker.erl Thu Mar 11 18:00:07 2004
-@@ -330,6 +330,8 @@
- case gen_tcp:recv(St#st.proxysock, Length, Timeout) of
- {ok, Data} ->
- {reply, {ok, Data}, St};
-+ {error, timeout} ->
-+ {reply, {error, timeout}, St};
- {error, Reason} ->
- {reply, {error, Reason}, St#st{status = closing}}
- end
diff --git a/lang/erlang14/files/patch-lib_stdlib_src_filelib.erl b/lang/erlang14/files/patch-lib_stdlib_src_filelib.erl
deleted file mode 100644
index 2b26e8e6c039..000000000000
--- a/lang/erlang14/files/patch-lib_stdlib_src_filelib.erl
+++ /dev/null
@@ -1,17 +0,0 @@
-
-$FreeBSD$
-
---- lib/stdlib/src/filelib.erl.orig Thu Mar 11 21:05:33 2004
-+++ lib/stdlib/src/filelib.erl Thu Mar 11 21:06:40 2004
-@@ -84,7 +84,10 @@
- false ->
- fold_files(T, Dir, RegExp, Recursive, Fun, Acc0)
- end
-- end.
-+ end;
-+
-+fold_files([], _, _, _, _, Acc) ->
-+ Acc.
-
- last_modified(File) ->
- case file:read_file_info(File) of