aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang14/files
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2005-03-07 13:45:23 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2005-03-07 13:45:23 +0000
commitc211f52b68e38cfcbe4382393ad1cf2575403ef5 (patch)
tree69ba5edbb2ad28e8cb5ee1ca23e5fa741c69b8f9 /lang/erlang14/files
parent70d653d66046e89091ce2eb7797bdb428f935b27 (diff)
downloadports-c211f52b68e38cfcbe4382393ad1cf2575403ef5.tar.gz
ports-c211f52b68e38cfcbe4382393ad1cf2575403ef5.zip
Notes
Diffstat (limited to 'lang/erlang14/files')
-rw-r--r--lang/erlang14/files/patch-erts_etc_unix_run__erl.c14
-rw-r--r--lang/erlang14/files/patch-lib_gs_src_tool__utils.erl36
-rw-r--r--lang/erlang14/files/patch-lib_runtime__tools_c__src_Makefile.in25
-rw-r--r--lang/erlang14/files/patch-lib_sasl_src_rb.erl65
4 files changed, 17 insertions, 123 deletions
diff --git a/lang/erlang14/files/patch-erts_etc_unix_run__erl.c b/lang/erlang14/files/patch-erts_etc_unix_run__erl.c
deleted file mode 100644
index c43d701e001e..000000000000
--- a/lang/erlang14/files/patch-erts_etc_unix_run__erl.c
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- erts/etc/unix/run_erl.c.orig
-+++ erts/etc/unix/run_erl.c
-@@ -738,7 +738,7 @@
- */
- static int create_fifo(char *name, int perm)
- {
-- if ((mknod(name, S_IFIFO | perm, 0) < 0) && (errno != EEXIST))
-+ if ((mkfifo(name, perm) < 0) && (errno != EEXIST))
- return -1;
- return 0;
- }
diff --git a/lang/erlang14/files/patch-lib_gs_src_tool__utils.erl b/lang/erlang14/files/patch-lib_gs_src_tool__utils.erl
index 883ff337892d..ddc1ecb98b12 100644
--- a/lang/erlang14/files/patch-lib_gs_src_tool__utils.erl
+++ b/lang/erlang14/files/patch-lib_gs_src_tool__utils.erl
@@ -1,8 +1,8 @@
$FreeBSD$
---- lib/gs/src/tool_utils.erl.orig Tue Oct 12 22:14:23 2004
-+++ lib/gs/src/tool_utils.erl Tue Oct 12 22:17:17 2004
+--- lib/gs/src/tool_utils.erl.orig
++++ lib/gs/src/tool_utils.erl
@@ -27,6 +27,9 @@
-export([file_dialog/1]).
-export([notify/2, confirm/2, confirm_yesno/2, request/2]).
@@ -13,31 +13,29 @@ $FreeBSD$
%%----------------------------------------------------------------------
%% open_help(GS, File)
%% GS = gsobj() (GS root object returned by gs:start/0,1)
-@@ -65,7 +68,8 @@
- local ->
- case os:type() of
- {unix,_AnyType} ->
-- "netscape -remote \"openURL(file:" ++ File ++ ")\"";
-+ unix_url_command("file:" ++ File);
-+
+@@ -67,7 +70,7 @@
+ {unix,Type} ->
+ case Type of
+ darwin -> "open " ++ File;
+- _Else -> "netscape -remote \"openURL(file:" ++ File ++ ")\""
++ _Else -> unix_url_command("file:" ++ File)
+ end;
{win32,_AnyType} ->
"start " ++ filename:nativename(File);
-
-@@ -77,7 +81,7 @@
- remote ->
- case os:type() of
- {unix,_AnyType} ->
-- "netscape -remote \"openURL(" ++ File ++ ")\"";
-+ unix_url_command("file:" ++ File);
-
+@@ -82,7 +85,7 @@
+ {unix,Type} ->
+ case Type of
+ darwin -> "open " ++ File;
+- _Else -> "netscape -remote \"openURL(file:" ++ File ++ ")\""
++ _Else -> unix_url_command("file:" ++ File)
+ end;
{win32,_AnyType} ->
"netscape.exe -h " ++ regexp:gsub(File,"\\\\","/");
-@@ -337,3 +341,54 @@
+@@ -342,3 +345,53 @@
[Last];
insert_newlines(Other) ->
Other.
+
-+
+%% find_browser(BrowserList) => string() | false
+%% BrowserList - [string()]
+%% Given a list of basenames, find the first available executable.
diff --git a/lang/erlang14/files/patch-lib_runtime__tools_c__src_Makefile.in b/lang/erlang14/files/patch-lib_runtime__tools_c__src_Makefile.in
deleted file mode 100644
index bb88be4c3948..000000000000
--- a/lang/erlang14/files/patch-lib_runtime__tools_c__src_Makefile.in
+++ /dev/null
@@ -1,25 +0,0 @@
-
-$FreeBSD$
-
---- lib/runtime_tools/c_src/Makefile.in.orig Sun Aug 31 14:46:12 2003
-+++ lib/runtime_tools/c_src/Makefile.in Sun Aug 31 14:47:00 2003
-@@ -107,7 +107,8 @@
- ifdef soname
- $(LD) $(LDFLAGS) $(soname) trace_ip_drv.so -o $@ $^ -lc $(LIBS)
- else
-- $(LD) $(LDFLAGS) -o $@ $^ -lc $(LIBS)
-+ # $(LD) $(LDFLAGS) -o $@ $^ -lc $(LIBS)
-+ $(LD) $(LDFLAGS) -o $@ $^
- endif
-
- $(LIBDIR)/trace_file_drv.so: $(TRACE_FILE_DRV_OBJS)
-@@ -115,7 +116,8 @@
- ifdef soname
- $(LD) $(LDFLAGS) $(soname) trace_file_drv.so -o $@ $^ -lc $(LIBS)
- else
-- $(LD) $(LDFLAGS) -o $@ $^ -lc $(LIBS)
-+ # $(LD) $(LDFLAGS) -o $@ $^ -lc $(LIBS)
-+ $(LD) $(LDFLAGS) -o $@ $^
- endif
-
- $(LIBDIR)/trace_ip_drv.dll: $(TRACE_IP_DRV_OBJS)
diff --git a/lang/erlang14/files/patch-lib_sasl_src_rb.erl b/lang/erlang14/files/patch-lib_sasl_src_rb.erl
deleted file mode 100644
index 6fae0f417ac4..000000000000
--- a/lang/erlang14/files/patch-lib_sasl_src_rb.erl
+++ /dev/null
@@ -1,65 +0,0 @@
-
-$FreeBSD$
-
---- lib/sasl/src/rb.erl.orig
-+++ lib/sasl/src/rb.erl
-@@ -177,7 +177,7 @@
- {reply, ok, State#state{device = standard_io}};
- handle_call({show_number, Number}, _From, State) ->
- #state{dir = Dir, data = Data, device = Device, abort = Abort, log = Log} = State,
-- NewDevice = print_report(Dir, Data, Number, Device, Abort, Log),
-+ NewDevice = print_report_by_num(Dir, Data, Number, Device, Abort, Log),
- {reply, ok, State#state{device = NewDevice}};
- handle_call({show_type, Type}, _From, State) ->
- #state{dir = Dir, data = Data, device = Device, abort = Abort, log = Log} = State,
-@@ -541,6 +541,10 @@
- io_lib:format("~s", [ShortDescr]),
- Date]).
-
-+print_report_by_num(Dir, Data, Number, Device, Abort, Log) ->
-+ {_,Device1} = print_report(Dir, Data, Number, Device, Abort, Log),
-+ Device1.
-+
- print_typed_reports(_Dir, [], _Type, Device, _Abort, _Log) ->
- Device;
- print_typed_reports(Dir, Data, Type, Device, Abort, Log) ->
-@@ -569,23 +573,29 @@
- end.
-
- print_report(Dir, Data, Number, Device, Abort, Log) ->
-- {Fname, FilePosition} = find_report(Data, Number),
-- FileName = lists:concat([Dir, Fname]),
-- case file:open(FileName, read) of
-- {ok, Fd} ->
-- read_rep(Fd, FilePosition, Device, Abort, Log);
-- _ ->
-- io:format("rb: can't open file ~p~n", [Fname]),
-+ case find_report(Data, Number) of
-+ {Fname, FilePosition} ->
-+ FileName = lists:concat([Dir, Fname]),
-+ case file:open(FileName, read) of
-+ {ok, Fd} ->
-+ read_rep(Fd, FilePosition, Device, Abort, Log);
-+ _ ->
-+ io:format("rb: can't open file ~p~n", [Fname]),
-+ {proceed,Device}
-+ end;
-+ no_report ->
- {proceed,Device}
- end.
-
- find_report([{No, _Type, _Descr, _Date, Fname, FilePosition}|_T], No) ->
- {Fname, FilePosition};
--find_report([_H|T], No) -> find_report(T, No);
-+find_report([_H|T], No) ->
-+ find_report(T, No);
- find_report([], No) ->
-- io:format("There is no report with number ~p.~n", [No]).
-+ io:format("There is no report with number ~p.~n", [No]),
-+ no_report.
-
--print_grep_reports(_Dir, [], _RegExp, Device, Abort, Log) ->
-+print_grep_reports(_Dir, [], _RegExp, Device, _Abort, _Log) ->
- Device;
- print_grep_reports(Dir, Data, RegExp, Device, Abort, Log) ->
- {Next,Device1} = print_grep_report(Dir, Data, element(1, hd(Data)),