aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang14
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2005-10-28 19:51:49 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2005-10-28 19:51:49 +0000
commita5c7af90db5e6218019ae78e8e956612b999871d (patch)
treef684af22b84870f634c27c01376eaaa01df16adb /lang/erlang14
parent9466619af647e1c8f52e04ed7cd6aeef5f989a9c (diff)
downloadports-a5c7af90db5e6218019ae78e8e956612b999871d.tar.gz
ports-a5c7af90db5e6218019ae78e8e956612b999871d.zip
Notes
Diffstat (limited to 'lang/erlang14')
-rw-r--r--lang/erlang14/Makefile9
-rw-r--r--lang/erlang14/Makefile.lib35
-rw-r--r--lang/erlang14/Makefile.man26
-rw-r--r--lang/erlang14/distinfo12
-rw-r--r--lang/erlang14/files/patch-lib_sasl_src_rb.erl14
-rw-r--r--lang/erlang14/pkg-message2
-rw-r--r--lang/erlang14/pkg-plist2
7 files changed, 54 insertions, 46 deletions
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index 271f28e0c230..4c5dbd3c5964 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= erlang
-PORTVERSION= r10b7
-PORTREVISION= 1
+PORTVERSION= r10b8
PORTEPOCH= 1
CATEGORIES= lang parallel
MASTER_SITES= http://www.erlang.org/download/ \
@@ -15,7 +14,7 @@ MASTER_SITES= http://www.erlang.org/download/ \
http://www.erlang.org/download/ \
http://erlang.stacken.kth.se/download/ \
http://www.csd.uu.se/ftp/mirror/erlang/download/
-DISTNAME= otp_src_R10B-7
+DISTNAME= otp_src_R10B-8
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${ERLANG_MAN} ${ERLANG_DOCS}
DIST_SUBDIR= erlang
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -41,9 +40,9 @@ LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
JAVABINDIR?= ${LOCALBASE}/jdk1.4.2/bin
JAVAPORT?= ${JAVABINDIR}/javac:${PORTSDIR}/java/jdk14
-ERLANG_MAN= otp_doc_man_R10B-7.tar.gz
+ERLANG_MAN= otp_doc_man_R10B-8.tar.gz
.if !defined(NOPORTDOCS)
-ERLANG_DOCS= otp_doc_html_R10B-7.tar.gz
+ERLANG_DOCS= otp_doc_html_R10B-8.tar.gz
.endif
USE_GMAKE= yes
diff --git a/lang/erlang14/Makefile.lib b/lang/erlang14/Makefile.lib
index 732b98037fe2..4b90c5ccd98e 100644
--- a/lang/erlang14/Makefile.lib
+++ b/lang/erlang14/Makefile.lib
@@ -1,9 +1,9 @@
# $FreeBSD$
-ERTS_VSN= 5.4.9
+ERTS_VSN= 5.4.10
OTP_LIBS= appmon-2.1.5 \
- asn1-1.4.4.7 \
- compiler-4.3.9 \
+ asn1-1.4.4.8 \
+ compiler-4.3.10 \
cosEvent-2.1 \
cosEventDomain-1.1 \
cosFileTransfer-1.1.2 \
@@ -11,20 +11,20 @@ OTP_LIBS= appmon-2.1.5 \
cosProperty-1.1.1 \
cosTime-1.1 \
cosTransactions-1.2 \
- crypto-1.3 \
- debugger-2.3.3 \
- edoc-0.6.2 \
+ crypto-1.4 \
+ debugger-3.0 \
+ edoc-0.6.7 \
erl_interface-3.5.4 \
et-1.0 \
gs-1.5.4 \
- hipe-3.5.2 \
+ hipe-3.5.3 \
ic-4.2.9 \
- inets-4.5.3 \
+ inets-4.6.1 \
jinterface-1.3 \
- kernel-2.10.10 \
- megaco-3.0.1 \
- mnemosyne-1.2.5 \
- mnesia-4.2.2 \
+ kernel-2.10.11 \
+ megaco-3.2 \
+ mnemosyne-1.2.5.1 \
+ mnesia-4.2.3 \
mnesia_session-1.1.5 \
observer-0.9.6.2 \
odbc-2.0.4 \
@@ -34,13 +34,14 @@ OTP_LIBS= appmon-2.1.5 \
parsetools-1.3.2 \
pman-2.5.2 \
runtime_tools-1.5.1.1 \
- sasl-2.0.1 \
- snmp-4.3 \
- ssl-3.0.7 \
- stdlib-1.13.9 \
+ sasl-2.1 \
+ snmp-4.5 \
+ ssh-0.9 \
+ ssl-3.0.9 \
+ stdlib-1.13.10 \
syntax_tools-1.4.2 \
toolbar-1.2.1 \
- tools-2.4.5 \
+ tools-2.4.6 \
tv-2.1.2 \
webtool-0.8.2 \
xmerl-1.0.3
diff --git a/lang/erlang14/Makefile.man b/lang/erlang14/Makefile.man
index ca7780b50376..4b64f03ae781 100644
--- a/lang/erlang14/Makefile.man
+++ b/lang/erlang14/Makefile.man
@@ -169,7 +169,6 @@ MAN3= CosEventChannelAdmin.3 \
http_base_64.3 \
httpd.3 \
httpd_conf.3 \
- httpd_core.3 \
httpd_socket.3 \
httpd_util.3 \
i.3 \
@@ -205,23 +204,10 @@ MAN3= CosEventChannelAdmin.3 \
mnesia_frag_hash.3 \
mnesia_registry.3 \
mnesia_session.3 \
- mod_actions.3 \
mod_alias.3 \
mod_auth.3 \
- mod_browser.3 \
- mod_cgi.3 \
- mod_dir.3 \
- mod_disk_log.3 \
mod_esi.3 \
- mod_get.3 \
- mod_head.3 \
- mod_htaccess.3 \
- mod_include.3 \
- mod_log.3 \
- mod_range.3 \
- mod_responsecontrol.3 \
mod_security.3 \
- mod_trace.3 \
ms_transform.3 \
net_adm.3 \
net_kernel.3 \
@@ -287,6 +273,14 @@ MAN3= CosEventChannelAdmin.3 \
snmpm_network_interface.3 \
snmpm_user.3 \
sofs.3 \
+ ssh.3 \
+ ssh_cli.3 \
+ ssh_cm.3 \
+ ssh_sftp.3 \
+ ssh_sftpd.3 \
+ ssh_ssh.3 \
+ ssh_sshd.3 \
+ ssh_transport.3 \
ssl.3 \
ssl_pkix.3 \
string.3 \
@@ -309,7 +303,8 @@ MAN3= CosEventChannelAdmin.3 \
xmerl_xpath.3 \
xmerl_xs.3 \
xref.3 \
- yecc.3
+ yecc.3 \
+ zlib.3
MAN4= app.4 \
appup.4 \
@@ -325,4 +320,3 @@ MAN6= crypto.6 \
sasl.6 \
snmp.6 \
ssl.6
-
diff --git a/lang/erlang14/distinfo b/lang/erlang14/distinfo
index 15960de7e0a7..513d0489e69d 100644
--- a/lang/erlang14/distinfo
+++ b/lang/erlang14/distinfo
@@ -1,6 +1,6 @@
-MD5 (erlang/otp_src_R10B-7.tar.gz) = fc039c62862ebae141e27370401aaab0
-SIZE (erlang/otp_src_R10B-7.tar.gz) = 10058423
-MD5 (erlang/otp_doc_man_R10B-7.tar.gz) = 53b251d1a690d5a97434c6a5b0086921
-SIZE (erlang/otp_doc_man_R10B-7.tar.gz) = 601650
-MD5 (erlang/otp_doc_html_R10B-7.tar.gz) = c73010c3d6c929c4474b8b8b38a4925c
-SIZE (erlang/otp_doc_html_R10B-7.tar.gz) = 4601134
+MD5 (erlang/otp_src_R10B-8.tar.gz) = 75cd5ad53b66baad9ebc802b8a1f6043
+SIZE (erlang/otp_src_R10B-8.tar.gz) = 9941183
+MD5 (erlang/otp_doc_man_R10B-8.tar.gz) = c0760f24ae789fda248e978430aefe38
+SIZE (erlang/otp_doc_man_R10B-8.tar.gz) = 596195
+MD5 (erlang/otp_doc_html_R10B-8.tar.gz) = d4d3f448c311cd3fc3a44e06e4145bcb
+SIZE (erlang/otp_doc_html_R10B-8.tar.gz) = 4622925
diff --git a/lang/erlang14/files/patch-lib_sasl_src_rb.erl b/lang/erlang14/files/patch-lib_sasl_src_rb.erl
new file mode 100644
index 000000000000..79b3961b0f00
--- /dev/null
+++ b/lang/erlang14/files/patch-lib_sasl_src_rb.erl
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- lib/sasl/src/rb.erl.orig
++++ lib/sasl/src/rb.erl
+@@ -414,7 +414,7 @@
+ Ref = make_ref(),
+ case (catch {Ref,binary_to_term(Bin)}) of
+ {'EXIT',_} ->
+- {error, "Inclomplete erlang term in log"};
++ {error, "Incomplete erlang term in log"};
+ {Ref,Term} ->
+ {ok, Term}
+ end
diff --git a/lang/erlang14/pkg-message b/lang/erlang14/pkg-message
index 364140fad1f0..f69818d24d60 100644
--- a/lang/erlang14/pkg-message
+++ b/lang/erlang14/pkg-message
@@ -7,7 +7,7 @@ Installation tips:
You can find an emacs mode for Erlang here:
- ${LOCALBASE}/lib/erlang/lib/tools-2.4.5/emacs
+ ${LOCALBASE}/lib/erlang/lib/tools-2.4.6/emacs
You may wish to add the following line to /etc/manpath.config:
diff --git a/lang/erlang14/pkg-plist b/lang/erlang14/pkg-plist
index 64dca9bd773d..9d57499b83e4 100644
--- a/lang/erlang14/pkg-plist
+++ b/lang/erlang14/pkg-plist
@@ -4,7 +4,7 @@ bin/erlc
@comment Insert PLIST.lib-erlang here
@comment -=[ begin PLIST.lib-erlang ]=-
@comment -=[ end PLIST.lib-erlang ]=-
-@exec mkdir %D/lib/erlang/erts-5.4.3/man
+@exec mkdir %D/lib/erlang/erts-5.4.10/man
@exec mkdir %D/lib/erlang/usr/lib
@dirrm lib/erlang/man/man6
@dirrm lib/erlang/man/man4