aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang14
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2005-06-28 12:21:59 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2005-06-28 12:21:59 +0000
commitd10d6a25c4d0a960317c5a2166e62ad7b4c1a616 (patch)
treed00d49f1522d4a01cbf1f74dcaae289f72450717 /lang/erlang14
parent281977c23582bcbf45525cab7b00357025c0ac80 (diff)
downloadports-d10d6a25c4d0a960317c5a2166e62ad7b4c1a616.tar.gz
ports-d10d6a25c4d0a960317c5a2166e62ad7b4c1a616.zip
Notes
Diffstat (limited to 'lang/erlang14')
-rw-r--r--lang/erlang14/Makefile15
-rw-r--r--lang/erlang14/files/patch-lib_odbc_c_src_odbcserver.c10
-rw-r--r--lang/erlang14/files/patch-lib_odbc_configure11
3 files changed, 36 insertions, 0 deletions
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index 98fc962d986a..a75bc5ddee0a 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -7,6 +7,7 @@
PORTNAME= erlang
PORTVERSION= r10b6
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= lang parallel
MASTER_SITES= http://www.erlang.org/download/ \
@@ -26,6 +27,16 @@ COMMENT= A functional programming language from Ericsson
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
.endif
+.if !defined(WITHOUT_ODBC)
+DRIVER_MANAGER?= iodbc
+
+.if ${DRIVER_MANAGER} == "unixodbc"
+LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+.else # assume we're using iodbc
+LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
+.endif
+.endif
+
# Set JAVABINDIR to where you have javac, if different from below
JAVABINDIR?= ${LOCALBASE}/jdk1.4.2/bin
JAVAPORT?= ${JAVABINDIR}/javac:${PORTSDIR}/java/jdk14
@@ -46,6 +57,10 @@ CONFIGURE_TARGET= # Empty
CONFIGURE_ARGS+= --enable-threads --enable-hipe --enable-kernel-poll
NOPRECIOUSMAKEVARS= yes # Prevent exporting of "ARCH"
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
.include <bsd.port.pre.mk>
.if !exists(${JAVABINDIR}/java)
diff --git a/lang/erlang14/files/patch-lib_odbc_c_src_odbcserver.c b/lang/erlang14/files/patch-lib_odbc_c_src_odbcserver.c
new file mode 100644
index 000000000000..985785bd8e26
--- /dev/null
+++ b/lang/erlang14/files/patch-lib_odbc_c_src_odbcserver.c
@@ -0,0 +1,10 @@
+--- lib/odbc/c_src/odbcserver.c.orig Sat Jun 25 17:34:20 2005
++++ lib/odbc/c_src/odbcserver.c Sat Jun 25 17:34:33 2005
+@@ -107,6 +107,7 @@
+ #include <sys/socket.h>
+ #include <sys/uio.h>
+ #include <netdb.h>
++#include <netinet/in.h>
+ #endif
+
+ #include "ei.h"
diff --git a/lang/erlang14/files/patch-lib_odbc_configure b/lang/erlang14/files/patch-lib_odbc_configure
new file mode 100644
index 000000000000..fdb9d50eac0a
--- /dev/null
+++ b/lang/erlang14/files/patch-lib_odbc_configure
@@ -0,0 +1,11 @@
+--- lib/odbc/configure.orig Sat Jun 25 18:33:21 2005
++++ lib/odbc/configure Sat Jun 25 18:33:51 2005
+@@ -1096,7 +1096,7 @@
+ echo $ac_n "checking for odbc in standard locations""... $ac_c" 1>&6
+ echo "configure:1098: checking for odbc in standard locations" >&5
+ for dir in /opt/local/pgm/odbc /usr/local/odbc /usr/odbc \
+- /usr
++ /usr /usr/local
+ do
+ if test -f "$dir/include/sql.h"; then
+ is_odbc_std_location=yes