aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang14
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2009-11-27 13:21:58 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2009-11-27 13:21:58 +0000
commit5a830433de209b02c4bc205c1cfad16e826746f2 (patch)
treeb329456c87fcea7ba91766130bf796cf9903fda8 /lang/erlang14
parent15cad5856bd8d23861f8ecc75cfcf0a46bbe3578 (diff)
downloadports-5a830433de209b02c4bc205c1cfad16e826746f2.tar.gz
ports-5a830433de209b02c4bc205c1cfad16e826746f2.zip
Notes
Diffstat (limited to 'lang/erlang14')
-rw-r--r--lang/erlang14/Makefile16
-rw-r--r--lang/erlang14/Makefile.lib111
-rw-r--r--lang/erlang14/Makefile.man15
-rw-r--r--lang/erlang14/distinfo18
-rw-r--r--lang/erlang14/files/patch-lib_tools_emacs_erlang.el207
5 files changed, 87 insertions, 280 deletions
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index 38586689f07e..042dfaf75740 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= erlang
-PORTVERSION= r13b02
-PORTREVISION= 1
+PORTVERSION= r13b03
PORTEPOCH= 1
CATEGORIES= lang parallel java
MASTER_SITES= http://www.erlang.org/download/ \
@@ -15,7 +14,7 @@ MASTER_SITES= http://www.erlang.org/download/ \
http://www.erlang.org/download/ \
http://erlang.stacken.kth.se/download/ \
http://www.csd.uu.se/ftp/mirror/erlang/download/
-DISTNAME= otp_src_R13B02
+DISTNAME= otp_src_R13B03
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${ERLANG_MAN} ${ERLANG_DOCS}
DIST_SUBDIR= erlang
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
@@ -76,9 +75,9 @@ LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
.endif
.endif
-ERLANG_MAN= otp_doc_man_R13B02.tar.gz
+ERLANG_MAN= otp_doc_man_R13B03.tar.gz
.if !defined(NOPORTDOCS)
-ERLANG_DOCS= otp_doc_html_R13B02.tar.gz
+ERLANG_DOCS= otp_doc_html_R13B03.tar.gz
.endif
ERLANG_PLIST= ${WRKDIR}/pkg-plist
@@ -134,8 +133,11 @@ pre-configure:
# links in the documentation.
post-install:
@${LN} -sf ${LOCALBASE}/lib/erlang/lib/erl_interface-*/bin/erl_call ${LOCALBASE}/bin/erl_call
- @${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_MAN} \
- -C ${PREFIX}/lib/erlang
+ @for SECTION in 1 3 4 6; do \
+ ${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_MAN} \
+ -C ${PREFIX}/lib/erlang \
+ "man/man$${SECTION}/*.$${SECTION}" || ${TRUE}; \
+ done
@${RM} -rf ${PREFIX}/lib/erlang/man/cat?
.if !defined(NOPORTDOCS)
@${TAR} --unlink -xzpf ${DISTDIR}/${DIST_SUBDIR}/${ERLANG_DOCS} \
diff --git a/lang/erlang14/Makefile.lib b/lang/erlang14/Makefile.lib
index cef3a5765e83..f81304e71d5f 100644
--- a/lang/erlang14/Makefile.lib
+++ b/lang/erlang14/Makefile.lib
@@ -1,58 +1,59 @@
# $FreeBSD$
-ERTS_VSN= 5.7.3
-TOOLS_VSN= 2.6.4
-OTP_LIBS= appmon-2.1.10.1 \
- asn1-1.6.11 \
- common_test-1.4.5 \
- compiler-4.6.3 \
- cosEvent-2.1.6 \
- cosEventDomain-1.1.6 \
- cosFileTransfer-1.1.8 \
- cosNotification-1.1.11 \
- cosProperty-1.1.9 \
- cosTime-1.1.6 \
- cosTransactions-1.2.7 \
- crypto-1.6.1 \
- debugger-3.2 \
- dialyzer-2.0.0 \
- docbuilder-0.9.8.5 \
- edoc-0.7.6.4 \
- erl_interface-3.6.3 \
- erts-5.7.3 \
- et-1.3.2 \
- eunit-2.1.3 \
- gs-1.5.10 \
- hipe-3.7.3 \
- ic-4.2.22 \
- inets-5.1.3 \
- inviso-0.6 \
- jinterface-1.5.1 \
- kernel-2.13.3 \
- megaco-3.11.3 \
- mnesia-4.4.11 \
+ERTS_VSN= 5.7.4
+TOOLS_VSN= 2.6.5
+OTP_LIBS= appmon-2.1.10.2 \
+ asn1-1.6.12 \
+ common_test-1.4.6 \
+ compiler-4.6.4 \
+ cosEvent-2.1.7 \
+ cosEventDomain-1.1.7 \
+ cosFileTransfer-1.1.9 \
+ cosNotification-1.1.12 \
+ cosProperty-1.1.10 \
+ cosTime-1.1.7 \
+ cosTransactions-1.2.8 \
+ crypto-1.6.3 \
+ debugger-3.2.1 \
+ dialyzer-2.1.0 \
+ docbuilder-0.9.8.6 \
+ edoc-0.7.6.5 \
+ erl_docgen-0.1 \
+ erl_interface-3.6.4 \
+ erts-5.7.4 \
+ et-1.3.3 \
+ eunit-2.1.4 \
+ gs-1.5.11 \
+ hipe-3.7.4 \
+ ic-4.2.23 \
+ inets-5.2 \
+ inviso-0.6.1 \
+ jinterface-1.5.2 \
+ kernel-2.13.4 \
+ megaco-3.13 \
+ mnesia-4.4.12 \
observer-0.9.8.1 \
- odbc-2.10.5 \
- orber-3.6.13 \
- os_mon-2.2.3 \
- otp_mibs-1.0.5 \
- parsetools-2.0 \
- percept-0.8.2 \
- pman-2.7 \
- public_key-0.3 \
- reltool-0.5 \
- runtime_tools-1.8.1 \
- sasl-2.1.7 \
- snmp-4.13.5 \
- ssh-1.1.6 \
- ssl-3.10.4 \
- stdlib-1.16.3 \
- syntax_tools-1.6.3 \
- test_server-3.3.4 \
- toolbar-1.4 \
- tools-2.6.4 \
- tv-2.1.4.3 \
- typer-0.1.7.2 \
- webtool-0.8.4 \
- wx-0.98.3 \
- xmerl-1.2.1
+ odbc-2.10.6 \
+ orber-3.6.14 \
+ os_mon-2.2.4 \
+ otp_mibs-1.0.6 \
+ parsetools-2.0.1 \
+ percept-0.8.3 \
+ pman-2.7.1 \
+ public_key-0.4 \
+ reltool-0.5.2 \
+ runtime_tools-1.8.2 \
+ sasl-2.1.8 \
+ snmp-4.15 \
+ ssh-1.1.7 \
+ ssl-3.10.7 \
+ stdlib-1.16.4 \
+ syntax_tools-1.6.4 \
+ test_server-3.3.5 \
+ toolbar-1.4.1 \
+ tools-2.6.5 \
+ tv-2.1.4.4 \
+ typer-0.1.7.3 \
+ webtool-0.8.5 \
+ wx-0.98.4 \
+ xmerl-1.2.3
diff --git a/lang/erlang14/Makefile.man b/lang/erlang14/Makefile.man
index 8962d682659c..f1a997405d83 100644
--- a/lang/erlang14/Makefile.man
+++ b/lang/erlang14/Makefile.man
@@ -7,6 +7,7 @@ MAN1= epmd.1 \
erlsrv.1 \
escript.1 \
run_erl.1 \
+ run_test.1 \
start.1 \
start_erl.1 \
start_webtool.1 \
@@ -271,7 +272,6 @@ MAN3= CosEventChannelAdmin.3 \
orddict.3 \
ordsets.3 \
os.3 \
- os_mon.3 \
os_mon_mib.3 \
os_sup.3 \
otp_mib.3 \
@@ -332,6 +332,7 @@ MAN3= CosEventChannelAdmin.3 \
snmpm_conf.3 \
snmpm_mpd.3 \
snmpm_network_interface.3 \
+ snmpm_network_interface_filter.3 \
snmpm_user.3 \
sofs.3 \
ssh.3 \
@@ -440,8 +441,17 @@ MAN3= CosEventChannelAdmin.3 \
wxGrid.3 \
wxGridBagSizer.3 \
wxGridCellAttr.3 \
+ wxGridCellBoolEditor.3 \
+ wxGridCellBoolRenderer.3 \
+ wxGridCellChoiceEditor.3 \
wxGridCellEditor.3 \
+ wxGridCellFloatEditor.3 \
+ wxGridCellFloatRenderer.3 \
+ wxGridCellNumberEditor.3 \
+ wxGridCellNumberRenderer.3 \
wxGridCellRenderer.3 \
+ wxGridCellStringRenderer.3 \
+ wxGridCellTextEditor.3 \
wxGridEvent.3 \
wxGridSizer.3 \
wxHelpEvent.3 \
@@ -463,6 +473,7 @@ MAN3= CosEventChannelAdmin.3 \
wxListItem.3 \
wxListView.3 \
wxListbook.3 \
+ wxLogNull.3 \
wxMDIChildFrame.3 \
wxMDIClientWindow.3 \
wxMDIParentFrame.3 \
@@ -587,9 +598,9 @@ MAN6= common_test.6 \
docbuilder.6 \
kernel.6 \
observer.6 \
+ os_mon.6 \
runtime_tools.6 \
sasl.6 \
- snmp.6 \
ssl.6 \
stdlib.6 \
test_server.6
diff --git a/lang/erlang14/distinfo b/lang/erlang14/distinfo
index 537397009613..d0907d3d50e7 100644
--- a/lang/erlang14/distinfo
+++ b/lang/erlang14/distinfo
@@ -1,9 +1,9 @@
-MD5 (erlang/otp_src_R13B02.tar.gz) = d70bfba6935e52a7759168a35fbcabe7
-SHA256 (erlang/otp_src_R13B02.tar.gz) = 858922bc390da920365bb6845cadee9c57a347a731eaaeefa4925f027513fa7c
-SIZE (erlang/otp_src_R13B02.tar.gz) = 55077522
-MD5 (erlang/otp_doc_man_R13B02.tar.gz) = 975b2c8a1cc2fda017cb5cd3864e32ba
-SHA256 (erlang/otp_doc_man_R13B02.tar.gz) = 15514061f0ebddd40516c50769cc4b08c580d8a74b13717ac81a79c3d5b78674
-SIZE (erlang/otp_doc_man_R13B02.tar.gz) = 978685
-MD5 (erlang/otp_doc_html_R13B02.tar.gz) = 78fc0c139a0297e502a6008bd8166887
-SHA256 (erlang/otp_doc_html_R13B02.tar.gz) = fe50174a89160de1b31c14278732ecb78e73c0ed65bd09441a86a5cbefee6101
-SIZE (erlang/otp_doc_html_R13B02.tar.gz) = 6320796
+MD5 (erlang/otp_src_R13B03.tar.gz) = 411fcb29f0819973f71e28f6b56d9948
+SHA256 (erlang/otp_src_R13B03.tar.gz) = e7c46c8b2778f22064a3b369c1a1b572a1cc0e8a2198166858d4b9a1b488d662
+SIZE (erlang/otp_src_R13B03.tar.gz) = 57524485
+MD5 (erlang/otp_doc_man_R13B03.tar.gz) = 1fe80b110061ef73614824fb06d4d6eb
+SHA256 (erlang/otp_doc_man_R13B03.tar.gz) = c06967938826be25babaaecce8673738aef2093e8bbd66e5f66335455d5ae9f7
+SIZE (erlang/otp_doc_man_R13B03.tar.gz) = 1108822
+MD5 (erlang/otp_doc_html_R13B03.tar.gz) = ade1a4d5dcfe3732dc953f7cf9664b37
+SHA256 (erlang/otp_doc_html_R13B03.tar.gz) = 7be572da5856a659e747c79493980da0d88b285f3f56638aa46cb11f1fb8a0e0
+SIZE (erlang/otp_doc_html_R13B03.tar.gz) = 26682590
diff --git a/lang/erlang14/files/patch-lib_tools_emacs_erlang.el b/lang/erlang14/files/patch-lib_tools_emacs_erlang.el
deleted file mode 100644
index a2b8d9d1708b..000000000000
--- a/lang/erlang14/files/patch-lib_tools_emacs_erlang.el
+++ /dev/null
@@ -1,207 +0,0 @@
-
-$FreeBSD$
-
---- lib/tools/emacs/erlang.el.orig
-+++ lib/tools/emacs/erlang.el
-@@ -3361,7 +3361,7 @@
- (erlang-pop stack))
- (if (and stack (memq (car (car stack)) '(icr begin)))
- (erlang-pop stack))))
-- ((looking-at "catch[^,\n\\of]*\n")
-+ ((looking-at "\\bcatch[^,\n\\of]*\n")
- ;; Must pop top icr layer, `catch' in try/catch
- ;;will push a new layer next.
- (progn
-@@ -3378,10 +3378,10 @@
- ;; (if (and stack (memq (car (car stack)) '(icr begin)))
- ;; (erlang-pop stack))))
- )
-- (cond ((looking-at "\\(if\\|case\\|receive\\|try\\)[^_a-zA-Z0-9]")
-+ (cond ((looking-at "\\b\\(if\\|case\\|receive\\|try\\)\\b")
- ;; Must push a new icr (if/case/receive) layer.
- (erlang-push (list 'icr token (current-column)) stack))
-- ((looking-at "\\(fun\\)[^_a-zA-Z0-9]")
-+ ((looking-at "\\b\\(fun\\)\\b")
- ;; Push a new icr layer if we are defining a `fun'
- ;; expression, not when we are refering an existing
- ;; function.
-@@ -3390,7 +3390,7 @@
- (erlang-skip-blank to)
- (eq (following-char) ?\())
- (erlang-push (list 'icr token (current-column)) stack)))
-- ((looking-at "\\(begin\\|query\\)[^_a-zA-Z0-9]")
-+ ((looking-at "\\b\\(begin\\|query\\)\\b")
- (erlang-push (list 'begin token (current-column)) stack))
- ;; In test suites you may want to do something like
- ;; ?match(Mem when integer(Mem), mnesia:table_info(Tab,
-@@ -3399,22 +3399,22 @@
- ;; erlang mode to think the 'when' in the argument is a
- ;; "real" when. The following three clauses will avoid
- ;; this problem.
-- ((looking-at "when[^->\.]*if[^->\.]*->"))
-- ((looking-at "when[^->\.]*case[^->\.]*->"))
-- ((looking-at "when[^->\.]*receive[^->\.]*->"))
-+ ((looking-at "\\bwhen[^->\.]*if[^->\.]*->"))
-+ ((looking-at "\\bwhen[^->\.]*case[^->\.]*->"))
-+ ((looking-at "\\bwhen[^->\.]*receive[^->\.]*->"))
- ;; Normal when case
-- ((looking-at "when [^->\.]*->")
-+ ((looking-at "\\bwhen [^->\.]*->")
- (erlang-push (list 'when token (current-column)) stack))
-- ((looking-at "after[.]+->")
-+ ((looking-at "\\bafter[.]+->")
- (erlang-push (list 'icr token (current-column)) stack))
-- ((looking-at "after[^_a-zA-Z0-9->]")
-- ;; Probably in try-statment, fake "->" to get right
-+ ((looking-at "\\bafter\\b")
-+ ;; Probably in try-statement, fake "->" to get right
- ;; indentation in erlang-calculate-stack-indent. If it
- ;; was an ordinary catch without try, these entries will
- ;; be popped of the stack at a later ocaccion.
- (erlang-push (list 'icr token (current-column)) stack)
- (erlang-push (list '-> token (current-column)) stack))
-- ((looking-at "catch[^,\n\\of]*\n")
-+ ((looking-at "\\bcatch[^,\n\\of]*\n")
- (erlang-push (list 'icr token (current-column)) stack)
- (erlang-push (list '-> token (current-column)) stack))
- ;;((looking-at "^of$")
-@@ -3469,7 +3469,7 @@
- ((looking-at "->\\|:-")
- (save-excursion
- (back-to-indentation)
-- (cond ((looking-at "after[^_a-zA-Z0-9]")
-+ (cond ((looking-at "\\bafter\\b")
- (erlang-pop stack))))
- (if (and stack (eq (car (car stack)) 'when))
- (erlang-pop stack))
-@@ -3580,7 +3580,7 @@
- ;; Return nil or t.
- (eq (nth 3 state) 'comment))
- ((null stack)
-- (if (looking-at "when[^_a-zA-Z0-9]")
-+ (if (looking-at "\\bwhen\\b")
- erlang-indent-guard
- 0))
- ((eq (car stack-top) '\()
-@@ -3608,28 +3608,34 @@
- ;;
- ;; `after' should be indented to the save level as the
- ;; corresponding receive.
-- (if (looking-at "after[^_a-zA-Z0-9]")
-- (nth 2 stack-top)
-- (save-excursion
-- (goto-char (nth 1 stack-top))
-- (if (looking-at "case[^_a-zA-Z0-9]")
-- (+ (nth 2 stack-top) erlang-indent-level)
-- (skip-chars-forward "a-z")
-- (skip-chars-forward " \t")
-- (if (memq (following-char) '(?% ?\n))
-- (+ (nth 2 stack-top) erlang-indent-level)
-- (current-column)))))
-- (if (looking-at "catch[^_a-zA-Z0-9]")
-- (nth 2 stack-top)
-- (save-excursion
-- (goto-char (nth 1 stack-top))
-- (if (looking-at "case[^_a-zA-Z0-9]")
-- (+ (nth 2 stack-top) erlang-indent-level)
-- (skip-chars-forward "a-z")
-- (skip-chars-forward " \t")
-- (if (memq (following-char) '(?% ?\n))
-- (+ (nth 2 stack-top) erlang-indent-level)
-- (current-column)))))
-+ (let ((top-word (save-excursion
-+ (goto-char (nth 1 stack-top))
-+ (looking-at "\\b\\(\\w+\\)\\b")
-+ (match-string 0))))
-+ (if (and (looking-at "\\bafter\\b")
-+ (not (string= top-word "try")))
-+ (if (string= top-word "case")
-+ (+ (nth 2 stack-top) erlang-indent-level)
-+ (save-excursion
-+ (goto-char (nth 1 stack-top))
-+ (skip-chars-forward "a-z")
-+ (skip-chars-forward " \t")
-+ (if (memq (following-char) '(?% ?\n))
-+ (+ (nth 2 stack-top) erlang-indent-level)
-+ (current-column)))))
-+ (if (or (looking-at "\\bcatch\\b")
-+ (and (looking-at "\\bafter\\b")
-+ (string= top-word "try")))
-+ (nth 2 stack-top)
-+ (if (string= top-word "case")
-+ (+ (nth 2 stack-top) erlang-indent-level)
-+ (save-excursion
-+ (goto-char (nth 1 stack-top))
-+ (skip-chars-forward "a-z")
-+ (skip-chars-forward " \t")
-+ (if (memq (following-char) '(?% ?\n))
-+ (+ (nth 2 stack-top) erlang-indent-level)
-+ (current-column))))))
- )
- ;; Real indentation, where operators create extra indentation etc.
- ((memq (car stack-top) '(-> || begin))
-@@ -3638,7 +3644,8 @@
- ;; same line. If so use this indentation as base, else
- ;; use parent indentation + 2 * level as base.
- (let ((off erlang-indent-level)
-- (skip 2))
-+ (skip 2)
-+ (is-after (looking-at "\\bafter\\b")))
- (cond ((null (cdr stack))) ; Top level in function.
- ((eq (car stack-top) 'begin)
- (setq skip 5))
-@@ -3648,7 +3655,9 @@
- ;; Look at last thing to see how we are to move relative
- ;; to the base.
- (goto-char token)
-- (cond ((looking-at "||\\|,\\|->\\|:-")
-+ (cond ((and is-after (looking-at ","))
-+ off)
-+ ((looking-at "||\\|,\\|->\\|:-")
- base)
- ((erlang-at-keyword)
- (+ (current-column) erlang-indent-level))
-@@ -3665,7 +3674,7 @@
- ;; the block. (Here we have a choice: should
- ;; the user be forced to reindent continued
- ;; lines, or should the "end" be reindented?)
-- ((looking-at "\\(end\\|after\\|catch\\)[^_a-zA-Z0-9]\\|$")
-+ ((looking-at "\\b\\(end\\|after\\|catch\\)\\b\\|$")
- (if (eq (car (car stack)) '->)
- (erlang-pop stack))
- (if stack
-@@ -3680,7 +3689,7 @@
- )
- ((eq (car stack-top) 'when)
- (goto-char (nth 1 stack-top))
-- (if (looking-at "when\\s *\\($\\|%\\)")
-+ (if (looking-at "\\bwhen\\s *\\($\\|%\\)")
- (progn
- (erlang-pop stack)
- (if (and stack (eq (nth 0 (car stack)) 'icr))
-@@ -3757,13 +3766,13 @@
-
- (defun erlang-at-keyword ()
- "Are we looking at an Erlang keyword which will increase indentation?"
-- (looking-at (concat "\\(when\\|if\\|fun\\|case\\|begin\\|query\\|"
-- "of\\|receive\\|after\\|catch\\)[^_a-zA-Z0-9]")))
-+ (looking-at (concat "\\b\\(when\\|if\\|fun\\|case\\|begin\\|query\\|"
-+ "of\\|receive\\|after\\|catch\\)\\b")))
-
- (defun erlang-at-operator ()
- "Are we looking at an Erlang operator?"
- (looking-at
-- "\\(bnot\\|div\\|mod\\|band\\|bor\\|bxor\\|bsl\\|bsr\\)[^_a-zA-Z0-9]"))
-+ "\\b\\(bnot\\|div\\|mod\\|band\\|bor\\|bxor\\|bsl\\|bsr\\)\\b"))
-
- (defun erlang-comment-indent ()
- "Compute Erlang comment indentation.
-@@ -4813,7 +4822,7 @@
- This function is designed to be a member of a criteria list."
- (save-excursion
- (erlang-skip-blank)
-- (looking-at "end[^_a-zA-Z0-9]")))
-+ (looking-at "\\bend\\b")))
-
-
- ;; Erlang tags support which is aware of erlang modules.