aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2006-03-20 23:13:39 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2006-03-20 23:13:39 +0000
commit3b0a63a19113b439ac9f1cfc410702ae773247d6 (patch)
tree75d60dae12525d5edfc5f56078006a11d19f87e9 /lang/erlang
parent33396bffa296182c68933aa3c4d251de690435e8 (diff)
Notes
Diffstat (limited to 'lang/erlang')
-rw-r--r--lang/erlang/Makefile7
-rw-r--r--lang/erlang/files/patch-erts_configure24
2 files changed, 29 insertions, 2 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 980aca11e66b..711c0850e3b0 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -67,11 +67,14 @@ ERLANG_PLIST= ${WRKDIR}/pkg-plist
USE_GMAKE= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
REINPLACE_ARGS= -i
CONFIGURE_TARGET= # Empty
-CONFIGURE_ARGS+= --enable-threads --enable-hipe --enable-kernel-poll
+CONFIGURE_ARGS+= --enable-threads --enable-kernel-poll
+.if ${ARCH} == "i386"
+CONFIGURE_ARGS+= --enable-hipe
+.endif
NOPRECIOUSMAKEVARS= yes # Prevent exporting of "ARCH"
CFLAGS+= -I${LOCALBASE}/include
diff --git a/lang/erlang/files/patch-erts_configure b/lang/erlang/files/patch-erts_configure
new file mode 100644
index 000000000000..1b67a5a50324
--- /dev/null
+++ b/lang/erlang/files/patch-erts_configure
@@ -0,0 +1,24 @@
+
+$FreeBSD$
+
+--- erts/configure.orig
++++ erts/configure
+@@ -1283,6 +1283,7 @@
+ i586) ARCH=x86;;
+ i686) ARCH=x86;;
+ x86_64) ARCH=amd64;;
++amd64) ARCH=amd64;;
+ ppc) ARCH=ppc;;
+ ppc64) ARCH=ppc64;;
+ "Power Macintosh") ARCH=ppc;;
+@@ -5804,7 +5805,9 @@
+
+ echo $ac_n "checking for unreliable floating point execptions""... $ac_c" 1>&6
+ echo "configure:5807: checking for unreliable floating point execptions" >&5
+-if test "$cross_compiling" = yes; then
++if test "${ARCH}" = amd64; then
++ erl_ok=reliable
++elif test "$cross_compiling" = yes; then
+ erl_ok=unreliable
+ else
+ cat > conftest.$ac_ext <<EOF