aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2004-03-11 20:10:53 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2004-03-11 20:10:53 +0000
commit7bca6a4c5996316088ff873fa3d1f5dc9218f956 (patch)
tree40f1a893b8c52edf3bbdb95a380c136f791fe3cf /lang/erlang
parent544af71b8f3478670f377931087a0dbc9d0f8446 (diff)
downloadports-7bca6a4c5996316088ff873fa3d1f5dc9218f956.tar.gz
ports-7bca6a4c5996316088ff873fa3d1f5dc9218f956.zip
Notes
Diffstat (limited to 'lang/erlang')
-rw-r--r--lang/erlang/Makefile2
-rw-r--r--lang/erlang/files/patch-lib_stdlib_src_filelib.erl17
2 files changed, 18 insertions, 1 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 52e7fcaffee6..9f9eb56087fd 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -7,7 +7,7 @@
PORTNAME= erlang
PORTVERSION= r9c0
-PORTREVISION= 6
+PORTREVISION= 7
PORTEPOCH= 1
CATEGORIES= lang
MASTER_SITES= ftp://ftp.erlang.org/pub/download/ \
diff --git a/lang/erlang/files/patch-lib_stdlib_src_filelib.erl b/lang/erlang/files/patch-lib_stdlib_src_filelib.erl
new file mode 100644
index 000000000000..2b26e8e6c039
--- /dev/null
+++ b/lang/erlang/files/patch-lib_stdlib_src_filelib.erl
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- lib/stdlib/src/filelib.erl.orig Thu Mar 11 21:05:33 2004
++++ lib/stdlib/src/filelib.erl Thu Mar 11 21:06:40 2004
+@@ -84,7 +84,10 @@
+ false ->
+ fold_files(T, Dir, RegExp, Recursive, Fun, Acc0)
+ end
+- end.
++ end;
++
++fold_files([], _, _, _, _, Acc) ->
++ Acc.
+
+ last_modified(File) ->
+ case file:read_file_info(File) of