aboutsummaryrefslogtreecommitdiff
path: root/lang/etoile-io
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2011-04-21 05:03:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2011-04-21 05:03:28 +0000
commit01018c14f1316940417377291feb769c4164fd34 (patch)
tree1cc0399b52991581fb3e0d9314b6351d428e69e5 /lang/etoile-io
parent4484522d4c3c2564857ebdd50ccaf923044b3618 (diff)
downloadports-01018c14f1316940417377291feb769c4164fd34.tar.gz
ports-01018c14f1316940417377291feb769c4164fd34.zip
Notes
Diffstat (limited to 'lang/etoile-io')
-rw-r--r--lang/etoile-io/Makefile4
-rw-r--r--lang/etoile-io/files/patch-Runtime.m17
2 files changed, 21 insertions, 0 deletions
diff --git a/lang/etoile-io/Makefile b/lang/etoile-io/Makefile
index fd413d34dd96..b8274785fe67 100644
--- a/lang/etoile-io/Makefile
+++ b/lang/etoile-io/Makefile
@@ -31,4 +31,8 @@ PLIST_FILES= GNUstep/Local/Tools/ioobjc
DISTRIBUTEDVIEW_PORT?= deskutils/etoile-distributedview
+post-patch:
+ ${REINPLACE_CMD} -e 's|^inline|static inline|' \
+ ${WRKSRC}/Languages/Io/iovm/IoState_inline.h
+
.include <bsd.port.mk>
diff --git a/lang/etoile-io/files/patch-Runtime.m b/lang/etoile-io/files/patch-Runtime.m
new file mode 100644
index 000000000000..708b942932b2
--- /dev/null
+++ b/lang/etoile-io/files/patch-Runtime.m
@@ -0,0 +1,17 @@
+--- Languages/Io/ObjcBridge/Runtime.m.orig 2007-08-03 16:46:18.000000000 +0200
++++ Languages/Io/ObjcBridge/Runtime.m 2011-04-21 06:46:53.000000000 +0200
+@@ -11,11 +11,11 @@
+ while ((i < bufferLen) && (class = objc_next_class(&iterator))) buffer[i++]=class;
+ return classCount;
+ }
+-#else
++#endif
++#if 1
+ IMP __objc_get_forward_imp(SEL sel)
+ {
+- extern id _objc_msgForward(id self, SEL sel, ...);
+- return _objc_msgForward;
++ return __objc_msg_forward;
+ }
+ #endif
+