aboutsummaryrefslogtreecommitdiff
path: root/lang/expect
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-16 15:35:37 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-16 15:35:37 +0000
commit0e471544c840b77af6be49c457a4366b83eface8 (patch)
treeb2aae40f566730d5bd52431ffa142e604fd48321 /lang/expect
parent507462b6bf197ccce7f14fcaf352c1b7f3d2a466 (diff)
downloadports-0e471544c840b77af6be49c457a4366b83eface8.tar.gz
ports-0e471544c840b77af6be49c457a4366b83eface8.zip
Notes
Diffstat (limited to 'lang/expect')
-rw-r--r--lang/expect/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/lang/expect/Makefile b/lang/expect/Makefile
index 556d6f658c3e..a2ec6ce5accf 100644
--- a/lang/expect/Makefile
+++ b/lang/expect/Makefile
@@ -6,17 +6,17 @@
PORTNAME= expect
PORTVERSION= 5.38.0
-PORTREVISION= 1
-CATEGORIES= lang tcl83 tk83
+PORTREVISION= 2
+CATEGORIES= lang tcl84 tk84
MASTER_SITES= http://expect.nist.gov/src/
MAINTAINER= jerry@thehutt.org
COMMENT= A sophisticated scripter based on tcl/tk
.if !defined(WITHOUT_X11)
-LIB_DEPENDS?= tk83.1:${PORTSDIR}/x11-toolkits/tk83
+LIB_DEPENDS?= tk83.1:${PORTSDIR}/x11-toolkits/tk84
.else
-LIB_DEPENDS?= tcl83.1:${PORTSDIR}/lang/tcl83
+LIB_DEPENDS?= tcl83.1:${PORTSDIR}/lang/tcl84
.endif
EXPECT_VER= 5.38
@@ -33,14 +33,14 @@ PLIST_SUB+= LIBEXPECT_VER="${LIBEXPECT_VER}"
TK_CONFIG_ARGS=
PLIST_SUB+= XFILES="@comment "
.else
-TK_CONFIG_ARGS= --with-tkconfig=${LOCALBASE}/lib/tk8.3 \
- --with-tkinclude=${LOCALBASE}/include/tk8.3
+TK_CONFIG_ARGS= --with-tkconfig=${LOCALBASE}/lib/tk8.4 \
+ --with-tkinclude=${LOCALBASE}/include/tk8.4
PLIST_SUB+= XFILES=""
.endif
CONFIGURE_ARGS?=--enable-shared \
- --with-tclconfig=${LOCALBASE}/lib/tcl8.3 \
- --with-tclinclude=${LOCALBASE}/include/tcl8.3 \
+ --with-tclconfig=${LOCALBASE}/lib/tcl8.4 \
+ --with-tclinclude=${LOCALBASE}/include/tcl8.4 \
${TK_CONFIG_ARGS}
CONFIGURE_ENV= LDFLAGS="-lutil"