aboutsummaryrefslogtreecommitdiff
path: root/lang/ficl-devel/Makefile
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2003-12-08 19:00:36 +0000
committerBruce M Simpson <bms@FreeBSD.org>2003-12-08 19:00:36 +0000
commite82a2596420f8c56a242ec37b9d4112392fcf99f (patch)
treeb6867e78f685078bb79e6248046521a3f7f37c2e /lang/ficl-devel/Makefile
parent23ff83bf11155342b57e7d9ef216f15efa9f4952 (diff)
downloadports-e82a2596420f8c56a242ec37b9d4112392fcf99f.tar.gz
ports-e82a2596420f8c56a242ec37b9d4112392fcf99f.zip
Notes
Diffstat (limited to 'lang/ficl-devel/Makefile')
-rw-r--r--lang/ficl-devel/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/lang/ficl-devel/Makefile b/lang/ficl-devel/Makefile
new file mode 100644
index 000000000000..f6d229f4e94f
--- /dev/null
+++ b/lang/ficl-devel/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: ficl
+# Date created: 23 August 2002
+# Whom: Bruce M Simpson
+#
+# $FreeBSD$
+#
+
+PORTNAME= ficl
+PORTVERSION= 4.0.31
+CATEGORIES= lang devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= bms@spc.org
+COMMENT= Forth Inspired Command Language
+
+NO_WRKSUBDIR= defined
+NOMAN= defined
+
+ONLY_FOR_ARCHS= i386
+
+USE_GMAKE= yes
+
+ALL_TARGET= everything
+
+DOCS= releases.html parsesteps.html oop.html locals.html links.html \
+ license.html index.html api.html ficl.html favicon.ico dpans.html \
+ debugger.html upgrading.html
+
+DOCS_ARTICLES= sigplan9906.doc oo_in_c.html jwsforml.pdf ficlddj.pdf
+DOCS_GRAPHICS= sourceforge.jpg ficl_top.jpg ficl_oop.jpg ficl.4.96.jpg \
+ ficl.4.64.jpg ficl.4.128.jpg 4ring.gif
+DOCS_SOURCE= upgrading.ht releases.ht parsesteps.ht oop.ht locals.ht \
+ links.ht license.ht index.ht generate.py ficl.ht dpans.ht \
+ debugger.ht api.ht
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ficl ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/libficl.so.4 ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/libficl.a ${PREFIX}/lib
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/source ${DOCSDIR}/articles ${DOCSDIR}/graphics
+.for doc in ${DOCS}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${doc} ${DOCSDIR}
+.endfor
+.for doc in ${DOCS_ARTICLES}
+ ${INSTALL_MAN} ${WRKSRC}/doc/articles/${doc} ${DOCSDIR}/articles
+.endfor
+.for doc in ${DOCS_GRAPHICS}
+ ${INSTALL_MAN} ${WRKSRC}/doc/graphics/${doc} ${DOCSDIR}/graphics
+.endfor
+.for doc in ${DOCS_SOURCE}
+ ${INSTALL_MAN} ${WRKSRC}/doc/source/${doc} ${DOCSDIR}/source
+.endfor
+.endif
+
+.include <bsd.port.mk>