aboutsummaryrefslogtreecommitdiff
path: root/lang/forth/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-07-07 19:38:32 +0000
committerSteve Price <steve@FreeBSD.org>2000-07-07 19:38:32 +0000
commit3a839f493219b1b11927918d4a1ea61f0f3796fd (patch)
tree8329ef9aa682ae88ad575ce57dda2364e78170f1 /lang/forth/Makefile
parent50edf3201c5d67530ddcffb627450f335e1f3030 (diff)
downloadports-3a839f493219b1b11927918d4a1ea61f0f3796fd.tar.gz
ports-3a839f493219b1b11927918d4a1ea61f0f3796fd.zip
Notes
Diffstat (limited to 'lang/forth/Makefile')
-rw-r--r--lang/forth/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/lang/forth/Makefile b/lang/forth/Makefile
index f183fe1997c4..a4496a8c9384 100644
--- a/lang/forth/Makefile
+++ b/lang/forth/Makefile
@@ -6,20 +6,27 @@
#
PORTNAME= pfe
-PORTVERSION= 0.9.14
+PORTVERSION= 0.29.1
CATEGORIES= lang
-MASTER_SITES= ftp://ftp.taygeta.com/pub/Forth/Compilers/native/unix/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/${DISTNAME}/src
-HAS_CONFIGURE= yes
-CONFIGURE_SCRIPT= config.sh
-CONFIGURE_ARGS= ${OPSYS}
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --disable-float
+
MAN1= pfe.1
post-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pfe ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/../doc/pfe.1 ${PREFIX}/man/man1/pfe.1
+ ${INSTALL_MAN} ${WRKSRC}/../doc/pfe.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/pfe
+ ${INSTALL_DATA} ${WRKSRC}/../doc/*.html ${PREFIX}/share/doc/pfe
+.endif
.include <bsd.port.mk>