aboutsummaryrefslogtreecommitdiff
path: root/lang/fsharp/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2020-12-18 19:16:37 +0000
committerMark Linimon <linimon@FreeBSD.org>2020-12-18 19:16:37 +0000
commit4efe7bdc2b134fa5d608fb76de973c50b149f843 (patch)
treea50b69157728126f2254078cddc63890bf7631ff /lang/fsharp/Makefile
parent673adcde6c86eb814fe870b24d8e590e18330b9c (diff)
Mark various ports as BROKEN with Mono 5.20, and, in some other cases,
Mono 6.8. PR: 238089 Submitted by: cem Obtained from: lonesome.com build regression testing
Notes
Notes: svn path=/head/; revision=558398
Diffstat (limited to 'lang/fsharp/Makefile')
-rw-r--r--lang/fsharp/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/lang/fsharp/Makefile b/lang/fsharp/Makefile
index fac851321dae..e7e11b6e5f1e 100644
--- a/lang/fsharp/Makefile
+++ b/lang/fsharp/Makefile
@@ -32,4 +32,14 @@ do-test:
MONO_PATH=${WRKSRC}/Release/net40/bin \
./run-all.sh)
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(MONO_DEFAULT)
+.if ${MONO_DEFAULT} > 6
+BROKEN= fails to build with Mono version ${MONO_DEFAULT}: A unique overload for method 'GetFileNameWithoutExtension' could not be determined based on type information prior to this program point
+.elif ${MONO_DEFAULT} > 5.10
+BROKEN= fails to build with Mono version ${MONO_DEFAULT}: The type 'HashSet' is not defined
+.endif
+.endif
+
+.include <bsd.port.post.mk>