aboutsummaryrefslogtreecommitdiff
path: root/lang/gambas
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-11-08 06:09:30 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-11-08 06:09:30 +0000
commit341909db6b48c3f54aab5e121e58eb4a1fb02ea7 (patch)
tree53b4d319a3d4241916216e84699f6ebb9a773931 /lang/gambas
parent5a5df82e12227a54d5923f030e0be47ec1ac76aa (diff)
downloadports-341909db6b48c3f54aab5e121e58eb4a1fb02ea7.tar.gz
ports-341909db6b48c3f54aab5e121e58eb4a1fb02ea7.zip
Notes
Diffstat (limited to 'lang/gambas')
-rw-r--r--lang/gambas/Makefile6
-rw-r--r--lang/gambas/distinfo4
-rw-r--r--lang/gambas/files/patch-src_exec_Makefile.in11
-rw-r--r--lang/gambas/files/patch-src_exec_gbx_math.c13
4 files changed, 29 insertions, 5 deletions
diff --git a/lang/gambas/Makefile b/lang/gambas/Makefile
index e0c2d0407529..b390eaa108c8 100644
--- a/lang/gambas/Makefile
+++ b/lang/gambas/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= gambas
-PORTVERSION= 1.0.11
-PORTREVISION= 1
+PORTVERSION= 1.0.12
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,7 +13,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= thierry@FreeBSD.org
COMMENT= Gambas Almost Means BASic
-LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
+ ml.0:${PORTSDIR}/math/ldouble
USE_LIBLTDL= yes
USE_KDELIBS_VER= 3
diff --git a/lang/gambas/distinfo b/lang/gambas/distinfo
index ac925e5fe6c8..3fcc4f162bc7 100644
--- a/lang/gambas/distinfo
+++ b/lang/gambas/distinfo
@@ -1,2 +1,2 @@
-MD5 (gambas-1.0.11.tar.bz2) = 819eab8e69f71a76248c2679b3af9946
-SIZE (gambas-1.0.11.tar.bz2) = 4508090
+MD5 (gambas-1.0.12.tar.bz2) = cb035327ebc2734ddc485d594a5b3ded
+SIZE (gambas-1.0.12.tar.bz2) = 4518413
diff --git a/lang/gambas/files/patch-src_exec_Makefile.in b/lang/gambas/files/patch-src_exec_Makefile.in
new file mode 100644
index 000000000000..66bf741606d5
--- /dev/null
+++ b/lang/gambas/files/patch-src_exec_Makefile.in
@@ -0,0 +1,11 @@
+--- src/exec/Makefile.in.orig Mon Nov 7 19:30:39 2005
++++ src/exec/Makefile.in Mon Nov 7 22:57:31 2005
+@@ -206,7 +206,7 @@
+ LD_FLAGS = @LD_FLAGS@
+ LIBLTDL = @LIBLTDL@
+ LIBOBJS = @LIBOBJS@
+-LIBS = @LIBS@
++LIBS = @LIBS@ -lml
+ LIBTOOL = @LIBTOOL@
+ LIBXML_DIR = @LIBXML_DIR@
+ LIBXML_INC = @LIBXML_INC@
diff --git a/lang/gambas/files/patch-src_exec_gbx_math.c b/lang/gambas/files/patch-src_exec_gbx_math.c
new file mode 100644
index 000000000000..ec5833c9122e
--- /dev/null
+++ b/lang/gambas/files/patch-src_exec_gbx_math.c
@@ -0,0 +1,13 @@
+--- src/exec/gbx_math.c.orig Fri Oct 28 17:25:37 2005
++++ src/exec/gbx_math.c Mon Nov 7 23:35:25 2005
+@@ -27,6 +27,10 @@
+ #include <math.h>
+ #include <time.h>
+ #include <sys/time.h>
++#ifdef __FreeBSD__
++# include <mathl.h>
++# define modfl(a,b) modf(a,b)
++#endif
+
+ #include "gb_common.h"
+ #include "gbx_math.h"