aboutsummaryrefslogtreecommitdiff
path: root/lang/gauche
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2013-06-09 16:18:29 +0000
committerStefan Walter <stefan@FreeBSD.org>2013-06-09 16:18:29 +0000
commit79284f653ffeacd4449c830a201c632502f13107 (patch)
treef341b02ad38a042620a15862c43cac6ccff7f00a /lang/gauche
parent861ad53cbf94ecb581596eb10a287e108efb4ef4 (diff)
downloadports-79284f653ffeacd4449c830a201c632502f13107.tar.gz
ports-79284f653ffeacd4449c830a201c632502f13107.zip
Notes
Diffstat (limited to 'lang/gauche')
-rw-r--r--lang/gauche/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
index 1afb6fd9a91d..e4c28d9f77af 100644
--- a/lang/gauche/Makefile
+++ b/lang/gauche/Makefile
@@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= gauche
-PORTVERSION= 0.9.3.3 # Keep databases/gauche-gdbm in sync with this
+PORTVERSION= 0.9.3.3
+PORTREVISION= 1
CATEGORIES= lang scheme
MASTER_SITES= SF/${PORTNAME}/Gauche/
DISTNAME= Gauche-${PORTVERSION}
@@ -33,7 +34,7 @@ DATADIR?= ${PREFIX}/share/${PORTNAME}-0.9
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-tls=none \
- --with-iconv=${LOCALBASE}
+ --with-iconv=${LOCALBASE}
PLIST_SUB= VERSION="${PORTVERSION}" \
TARGET="${CONFIGURE_TARGET}"
USES= iconv
@@ -72,6 +73,12 @@ CONFIGURE_ARGS+=--with-slib=${WRKDIR}
PLIST_SUB+= SLIB="@comment "
.endif
+.if ${PORT_OPTIONS:MPTHREADS}
+CONFIGURE_ARGS+= --enable-threads=pthreads
+.else
+CONFIGURE_ARGS+= --enable-threads=no
+.endif
+
.if ${PORT_OPTIONS:MUTF8}
CONFIGURE_ARGS+= --enable-multibyte=utf-8
.elif ${PORT_OPTIONS:MEUCJP}
@@ -88,7 +95,7 @@ NOT_FOR_ARCHS= ia64 powerpc sparc64
NOT_FOR_ARCHS_REASON= Does not compile on ia64, powerpc, or sparc64
post-patch:
-.if defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e 's|all: info|all:|' ${WRKSRC}/doc/Makefile.in
.endif