aboutsummaryrefslogtreecommitdiff
path: root/lang/gauche
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-17 11:35:44 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-17 11:35:44 +0000
commit4feecef3c99b2bfbc9c7c8748979e27507a78a6b (patch)
treec57220f972a8d833f083db294784539ce433db08 /lang/gauche
parenta9851b49100a4d82a50bfd824e51d30a1f1aef6d (diff)
downloadports-4feecef3c99b2bfbc9c7c8748979e27507a78a6b.tar.gz
ports-4feecef3c99b2bfbc9c7c8748979e27507a78a6b.zip
Notes
Diffstat (limited to 'lang/gauche')
-rw-r--r--lang/gauche/Makefile13
-rw-r--r--lang/gauche/distinfo2
-rw-r--r--lang/gauche/pkg-plist9
3 files changed, 19 insertions, 5 deletions
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
index 31ac8bfddfd8..f886f0142d08 100644
--- a/lang/gauche/Makefile
+++ b/lang/gauche/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gauche
-PORTVERSION= 0.7.2 # Keep databases/gauche-gdbm in sync with this
+PORTVERSION= 0.7.3 # Keep databases/gauche-gdbm in sync with this
CATEGORIES= lang scheme
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,20 +22,27 @@ GAUCHE_THREADS?= no
# Choices are: "utf-8", "euc-jp", "shift-jis" and "no"
GAUCHE_ENCODING?= utf-8
+# breaks in ext/uvecor.c on some locales
+MAKE_ENV= LANG=C
+
INFOSECTION= The Algorithmic Language Scheme
MAN1= gosh.1 \
gauche-config.1
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-threads=${GAUCHE_THREADS} \
- --enable-multibyte=${GAUCHE_ENCODING}
+ --enable-multibyte=${GAUCHE_ENCODING} \
+ --with-slib=${PREFIX}/share/slib
PLIST_SUB= VERSION="${PORTVERSION}" \
TARGET="${CONFIGURE_TARGET}" \
INFOSECTION="${INFOSECTION}"
post-install:
${STRIP_CMD} ${PREFIX}/bin/gosh
- -${PREFIX}/bin/gosh -u slib -e "(require 'logical)" -e "(exit 0)"
+ ${RM} -f ${PREFIX}/share/gauche/${PORTVERSION}/lib/slibcat
+ ${TOUCH} ${PREFIX}/share/gauche/site/lib/.keepme
+ ${TOUCH} ${PREFIX}/lib/gauche/site/${PORTVERSION}/${CONFIGURE_TARGET}/.keepme
+
.if !defined(NOPORTDOCS)
${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${MANPREFIX}/man/man1/
${INSTALL_DATA} ${WRKSRC}/doc/*.info ${PREFIX}/info/
diff --git a/lang/gauche/distinfo b/lang/gauche/distinfo
index d2822c17ead5..4912f9ea5c0d 100644
--- a/lang/gauche/distinfo
+++ b/lang/gauche/distinfo
@@ -1 +1 @@
-MD5 (Gauche-0.7.2.tgz) = 20508314791c0897e088f90d7cba0d3b
+MD5 (Gauche-0.7.3.tgz) = 9ef0782cc06adf7d8dfcf8985f2e55a2
diff --git a/lang/gauche/pkg-plist b/lang/gauche/pkg-plist
index 76e0c5bbe02c..a9df168327b2 100644
--- a/lang/gauche/pkg-plist
+++ b/lang/gauche/pkg-plist
@@ -35,7 +35,10 @@ lib/gauche/%%VERSION%%/include/gauche/vminsn.h
lib/gauche/%%VERSION%%/include/gc.h
lib/gauche/%%VERSION%%/include/gc_config_macros.h
lib/gauche/%%VERSION%%/include/gc_pthread_redirects.h
+lib/gauche/site/%%VERSION%%/%%TARGET%%/.keepme
lib/libgauche.so
+lib/libgauche.so.0
+lib/libgauche.so.0.0.0
share/gauche/%%VERSION%%/aclocal.m4
share/gauche/%%VERSION%%/lib/binary/io.scm
share/gauche/%%VERSION%%/lib/binary/pack.scm
@@ -55,6 +58,7 @@ share/gauche/%%VERSION%%/lib/gauche/common-macros.scm
share/gauche/%%VERSION%%/lib/gauche/config.scm
share/gauche/%%VERSION%%/lib/gauche/defvalues.scm
share/gauche/%%VERSION%%/lib/gauche/fcntl.scm
+share/gauche/%%VERSION%%/lib/gauche/fileutil.scm
share/gauche/%%VERSION%%/lib/gauche/hashutil.scm
share/gauche/%%VERSION%%/lib/gauche/hook.scm
share/gauche/%%VERSION%%/lib/gauche/interactive.scm
@@ -67,6 +71,7 @@ share/gauche/%%VERSION%%/lib/gauche/listutil.scm
share/gauche/%%VERSION%%/lib/gauche/logger.scm
share/gauche/%%VERSION%%/lib/gauche/logical.scm
share/gauche/%%VERSION%%/lib/gauche/macroutil.scm
+share/gauche/%%VERSION%%/lib/gauche/modutil.scm
share/gauche/%%VERSION%%/lib/gauche/mop/instance-pool.scm
share/gauche/%%VERSION%%/lib/gauche/mop/propagate.scm
share/gauche/%%VERSION%%/lib/gauche/mop/singleton.scm
@@ -79,6 +84,7 @@ share/gauche/%%VERSION%%/lib/gauche/parseopt.scm
share/gauche/%%VERSION%%/lib/gauche/portutil.scm
share/gauche/%%VERSION%%/lib/gauche/procedure.scm
share/gauche/%%VERSION%%/lib/gauche/process.scm
+share/gauche/%%VERSION%%/lib/gauche/redefutil.scm
share/gauche/%%VERSION%%/lib/gauche/regexp.scm
share/gauche/%%VERSION%%/lib/gauche/reload.scm
share/gauche/%%VERSION%%/lib/gauche/selector.scm
@@ -109,6 +115,7 @@ share/gauche/%%VERSION%%/lib/rfc/cookie.scm
share/gauche/%%VERSION%%/lib/rfc/hmac.scm
share/gauche/%%VERSION%%/lib/rfc/http.scm
share/gauche/%%VERSION%%/lib/rfc/md5.scm
+share/gauche/%%VERSION%%/lib/rfc/mime.scm
share/gauche/%%VERSION%%/lib/rfc/quoted-printable.scm
share/gauche/%%VERSION%%/lib/rfc/sha1.scm
share/gauche/%%VERSION%%/lib/rfc/uri.scm
@@ -181,6 +188,7 @@ share/gauche/%%VERSION%%/lib/util/record.scm
share/gauche/%%VERSION%%/lib/util/toposort.scm
share/gauche/%%VERSION%%/lib/util/tree.scm
share/gauche/%%VERSION%%/lib/www/cgi.scm
+share/gauche/site/lib/.keepme
@dirrm share/gauche/site/lib
@dirrm share/gauche/site
@dirrm share/gauche/%%VERSION%%/lib/www
@@ -213,7 +221,6 @@ share/gauche/%%VERSION%%/lib/www/cgi.scm
@dirrm lib/gauche/%%VERSION%%/%%TARGET%%
@dirrm lib/gauche/%%VERSION%%
@dirrm lib/gauche
-@exec %D/bin/gosh -u slib -e "(require 'logical)" -e "(exit 0)" > /dev/null 2>&1 || true
%%PORTDOCS%%@unexec install-info --delete --section="%%INFOSECTION%%" %D/info/gauche-refe.info %D/info/dir
%%PORTDOCS%%@unexec install-info --delete --section="%%INFOSECTION%%" %D/info/gauche-refj.info %D/info/dir
%%PORTDOCS%%info/gauche-refe.info