aboutsummaryrefslogtreecommitdiff
path: root/lang/gauche
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-08-05 13:18:46 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-08-05 13:18:46 +0000
commit05f32954249779b0896df2b9e18297cfa8deb0f7 (patch)
treec1ecebce6cc510cef25dbf6f3a5eb165981297a1 /lang/gauche
parent04d898caf1dae98f26ab3b203926a8375e75312f (diff)
downloadports-05f32954249779b0896df2b9e18297cfa8deb0f7.tar.gz
ports-05f32954249779b0896df2b9e18297cfa8deb0f7.zip
- Update `lang/gauche' to version 0.9.6 and add TLS support
- Unfortunately, it now requires GNU make to build (pattern rules in doc/Makefile.in); also, regression tests fail with BSD make: https://github.com/shirok/Gauche/issues/367
Notes
Notes: svn path=/head/; revision=476412
Diffstat (limited to 'lang/gauche')
-rw-r--r--lang/gauche/Makefile21
-rw-r--r--lang/gauche/distinfo6
-rw-r--r--lang/gauche/files/patch-src_Makefile.in33
-rw-r--r--lang/gauche/pkg-plist65
4 files changed, 99 insertions, 26 deletions
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
index 96b67aa1be30..bfb9635d03a0 100644
--- a/lang/gauche/Makefile
+++ b/lang/gauche/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gauche
-PORTVERSION= 0.9.5
+PORTVERSION= 0.9.6
CATEGORIES= lang scheme
MASTER_SITES= SF/${PORTNAME}/Gauche
DISTNAME= Gauche-${PORTVERSION}
@@ -19,10 +19,9 @@ BROKEN_armv7= Fails to build: unknown attribute __alloc_size__; also fails in as
BROKEN_mips= Fails to build: redefinition of GC_register_dynamic_libraries
BROKEN_mips64= Fails to build: redefinition of GC_register_dynamic_libraries
-USES= iconv makeinfo tar:tgz
+USES= gmake iconv makeinfo tar:tgz
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-tls=none \
- ${ICONV_CONFIGURE_BASE:S/lib//}
+CONFIGURE_ARGS= --with-local=${LOCALBASE} ${ICONV_CONFIGURE_BASE:S/lib//}
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE=yes
TEST_TARGET= check
@@ -36,15 +35,19 @@ MAKE_ENV+= CCACHE_CPP2=1
INFO= gauche-refe gauche-refj
OPTIONS_DEFINE= GDBM THREADS SLIB
-OPTIONS_RADIO= MULTIBYTE
+OPTIONS_RADIO= MULTIBYTE TLS
OPTIONS_RADIO_MULTIBYTE= EUCJP SJIS UTF8
-OPTIONS_DEFAULT= THREADS UTF8
+OPTIONS_RADIO_TLS= AXTLS MBEDTLS
+OPTIONS_DEFAULT= AXTLS THREADS UTF8
OPTIONS_SUB= yes
+AXTLS_DESC= Cameron Rich's axTLS implementation (bundled)
+AXTLS_CONFIGURE_ON= --with-tls=axtls
EUCJP_DESC= EUC-JP encoding support
EUCJP_CONFIGURE_ON= --enable-multibyte=euc-jp
GDBM_LIB_DEPENDS= libgdbm.so:databases/gdbm
-GDBM_CONFIGURE_ON= --with-local=${LOCALBASE}
+MBEDTLS_LIB_DEPENDS= libmbedtls.so:security/mbedtls
+MBEDTLS_CONFIGURE_ON= --with-tls=mbedtls
SLIB_DESC= Create catalogue for SLIB port
SLIB_BUILD_DEPENDS= ${LOCALBASE}/share/slib/require.scm:lang/slib
SLIB_CONFIGURE_ON= --with-slib=${LOCALBASE}/share/slib
@@ -61,6 +64,10 @@ UTF8_CONFIGURE_ON= --enable-multibyte=utf-8
CONFIGURE_ARGS+= --enable-multibyte=none
.endif
+.if !${PORT_OPTIONS:MAXTLS} && !${PORT_OPTIONS:MMBEDTLS}
+CONFIGURE_ARGS+= --with-tls=none
+.endif
+
post-patch:
# required for sparc64, no-op elsewhere
@${REINPLACE_CMD} -e \
diff --git a/lang/gauche/distinfo b/lang/gauche/distinfo
index b53056634e42..c25606065610 100644
--- a/lang/gauche/distinfo
+++ b/lang/gauche/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1475925924
-SHA256 (Gauche-0.9.5.tgz) = 4c8a53213de112708bbda5fa9648c21497d43ebf809ed5b32b15f21266b4e73c
-SIZE (Gauche-0.9.5.tgz) = 6458675
+TIMESTAMP = 1530619386
+SHA256 (Gauche-0.9.6.tgz) = cd8928630d63b8043842a0526fbfb8f5f3c720b0d0ace81851e266ddfde69caf
+SIZE (Gauche-0.9.6.tgz) = 6927530
diff --git a/lang/gauche/files/patch-src_Makefile.in b/lang/gauche/files/patch-src_Makefile.in
index f518a1811764..276ebd04c956 100644
--- a/lang/gauche/files/patch-src_Makefile.in
+++ b/lang/gauche/files/patch-src_Makefile.in
@@ -1,6 +1,6 @@
---- src/Makefile.in.orig 2016-10-02 07:41:35 UTC
+--- src/Makefile.in.orig 2018-06-30 03:25:22 UTC
+++ src/Makefile.in
-@@ -248,7 +248,7 @@ test-extra$(EXEEXT) : $(LIBGAUCHE).$(SOEXT) $(test_ext
+@@ -259,7 +259,7 @@ test-extra$(EXEEXT) : $(LIBGAUCHE).$(SOEXT) $(test_ext
# need to relink gosh-noconsole.exe (windows no-console version).
relink :
$(RELINK) $(libgauche_LDFLAGS) $(LIBGAUCHE).$(SOEXT) $(libgauche_OBJECTS) $(libgc_pic_LIBRARY) $(GC_ATOMIC_OPS_LIBS) $(LIBS)
@@ -9,16 +9,25 @@
$(RELINK) -o gauche-config$(EXEEXT) gauche-config.$(OBJEXT) $(LIBS)
$(OBJECTS) : $(HEADERS)
-@@ -510,8 +510,10 @@ install-relink : install-aux
+@@ -417,7 +417,7 @@ $(LIBGAUCHE_STATIC).a : all $(STATICINIT_OBJS)
+ `if [ X$(libgc_pic_LIBRARY) != X ]; then echo $(libgc_pic_OBJECTS); fi` \
+ `if [ X$(libatomic_ops_pic_LIBRARY) != X ]; then echo $(libatomic_ops_pic_OBJECTS); fi` \
+ $(STATICINIT_OBJS) \
+- `"$(srcdir)/list-ext-objects.sh" "$(top_builddir)"`
++ `MAKE=$(MAKE) "$(srcdir)/list-ext-objects.sh" "$(top_builddir)"`
+
+ $(STATICINIT_SRCS) : all gen-staticinit.scm
+ $(STATIC_GOSH) $(srcdir)/gen-staticinit.scm $(top_srcdir) $(top_builddir)
+@@ -537,8 +537,10 @@ install-relink : install-aux
install-core : install-relink
- $(INSTALL) $(INSTALL_LIBS) $(DESTDIR)$(LIB_INSTALL_DIR)
- $(INSTALL) $(INSTALL_LIBS) $(DESTDIR)$(ARCH_INSTALL_DIR)
-- $(INSTALL) -m 555 $(INSTALL_BINS) $(DESTDIR)$(BIN_INSTALL_DIR)
-- $(INSTALL) -m 555 $(INSTALL_BINS) $(DESTDIR)$(ARCH_INSTALL_DIR)
-+ $(INSTALL) -m 555 $(INSTALL_BINS:Ngosh$(EXEEXT)) $(DESTDIR)$(BIN_INSTALL_DIR)
-+ $(INSTALL) -m 555 gosh-relinked$(EXEEXT) $(DESTDIR)$(BIN_INSTALL_DIR)/gosh$(EXEEXT)
-+ $(INSTALL) -m 555 $(INSTALL_BINS:Ngosh$(EXEEXT)) $(DESTDIR)$(ARCH_INSTALL_DIR)
-+ $(INSTALL) -m 555 gosh-relinked$(EXEEXT) $(DESTDIR)$(ARCH_INSTALL_DIR)/gosh$(EXEEXT)
+ $(INSTALL) $(INSTALL_LIBS) "$(DESTDIR)$(LIB_INSTALL_DIR)"
+ $(INSTALL) $(INSTALL_LIBS) "$(DESTDIR)$(ARCH_INSTALL_DIR)"
+- $(INSTALL) -m 555 $(INSTALL_BINS) "$(DESTDIR)$(BIN_INSTALL_DIR)"
+- $(INSTALL) -m 555 $(INSTALL_BINS) "$(DESTDIR)$(ARCH_INSTALL_DIR)"
++ $(INSTALL) -m 555 $(filter-out gosh$(EXEEXT),$(INSTALL_BINS)) "$(DESTDIR)$(BIN_INSTALL_DIR)"
++ $(INSTALL) -m 555 gosh-relinked$(EXEEXT) "$(DESTDIR)$(BIN_INSTALL_DIR)/gosh$(EXEEXT)"
++ $(INSTALL) -m 555 $(filter-out gosh$(EXEEXT),$(INSTALL_BINS)) "$(DESTDIR)$(ARCH_INSTALL_DIR)"
++ $(INSTALL) -m 555 gosh-relinked$(EXEEXT) "$(DESTDIR)$(ARCH_INSTALL_DIR)/gosh$(EXEEXT)"
@case `$(GAUCHE_CONFIG) --arch` in *-cygwin*|*-mingw*) \
- $(INSTALL) $(INSTALL_LIBS) $(DESTDIR)$(BIN_INSTALL_DIR);;\
+ $(INSTALL) $(INSTALL_LIBS) "$(DESTDIR)$(BIN_INSTALL_DIR)";;\
esac
diff --git a/lang/gauche/pkg-plist b/lang/gauche/pkg-plist
index 4080e15a3276..e2345bef5665 100644
--- a/lang/gauche/pkg-plist
+++ b/lang/gauche/pkg-plist
@@ -12,6 +12,7 @@ lib/gauche-0.9/%%VERSION%%/%%TARGET%%/dbm--ndbm.so
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/file--util.so
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/gauche--charconv.so
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/gauche--collection.so
+lib/gauche-0.9/%%VERSION%%/%%TARGET%%/gauche--dictionary.so
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/gauche--fcntl.so
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/gauche--generator.so
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/gauche--hook.so
@@ -31,6 +32,9 @@ lib/gauche-0.9/%%VERSION%%/%%TARGET%%/gauche-install
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/gauche-package
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/gosh
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/libgauche-0.9.so
+lib/gauche-0.9/%%VERSION%%/%%TARGET%%/libgauche-0.9.so.0
+lib/gauche-0.9/%%VERSION%%/%%TARGET%%/libgauche-0.9.so.0.6
+lib/gauche-0.9/%%VERSION%%/%%TARGET%%/libgauche-static-0.9.a
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/math--mt-random.so
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/os--windows.so
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/parser--peg.so
@@ -38,6 +42,7 @@ lib/gauche-0.9/%%VERSION%%/%%TARGET%%/rfc--822.so
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/rfc--md5.so
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/rfc--mime.so
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/rfc--sha.so
+lib/gauche-0.9/%%VERSION%%/%%TARGET%%/rfc--tls--mbed.so
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/rfc--tls.so
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/rfc--zlib.so
lib/gauche-0.9/%%VERSION%%/%%TARGET%%/srfi-1.so
@@ -113,7 +118,8 @@ lib/gauche-0.9/%%VERSION%%/include/gc_version.h
lib/gauche-0.9/site/%%TARGET%%/.keepme
lib/libgauche-0.9.so
lib/libgauche-0.9.so.0
-lib/libgauche-0.9.so.0.5
+lib/libgauche-0.9.so.0.6
+lib/libgauche-static-0.9.a
man/man1/gauche-cesconv.1.gz
man/man1/gauche-config.1.gz
man/man1/gauche-install.1.gz
@@ -134,6 +140,7 @@ share/gauche-0.9/%%VERSION%%/lib/check-script
share/gauche-0.9/%%VERSION%%/lib/compat/chibi-test.scm
share/gauche-0.9/%%VERSION%%/lib/compat/jfilter.scm
share/gauche-0.9/%%VERSION%%/lib/compat/norational.scm
+share/gauche-0.9/%%VERSION%%/lib/compat/r7rs-srfi-tests.scm
share/gauche-0.9/%%VERSION%%/lib/compat/stk.scm
share/gauche-0.9/%%VERSION%%/lib/control/job.scm
share/gauche-0.9/%%VERSION%%/lib/control/thread-pool.scm
@@ -218,7 +225,7 @@ share/gauche-0.9/%%VERSION%%/lib/gauche/parameter.scm
share/gauche-0.9/%%VERSION%%/lib/gauche/parseopt.scm
share/gauche-0.9/%%VERSION%%/lib/gauche/partcont.scm
share/gauche-0.9/%%VERSION%%/lib/gauche/portutil.scm
-share/gauche-0.9/%%VERSION%%/lib/gauche/pp.scm
+share/gauche-0.9/%%VERSION%%/lib/gauche/pputil.scm
share/gauche-0.9/%%VERSION%%/lib/gauche/procedure.scm
share/gauche-0.9/%%VERSION%%/lib/gauche/process.scm
share/gauche-0.9/%%VERSION%%/lib/gauche/record.scm
@@ -238,6 +245,7 @@ share/gauche-0.9/%%VERSION%%/lib/gauche/sysutil.scm
share/gauche-0.9/%%VERSION%%/lib/gauche/termios.scm
share/gauche-0.9/%%VERSION%%/lib/gauche/test.scm
share/gauche-0.9/%%VERSION%%/lib/gauche/test/generative.scm
+share/gauche-0.9/%%VERSION%%/lib/gauche/test/script.scm
share/gauche-0.9/%%VERSION%%/lib/gauche/threads.scm
share/gauche-0.9/%%VERSION%%/lib/gauche/time.scm
share/gauche-0.9/%%VERSION%%/lib/gauche/treeutil.scm
@@ -258,6 +266,7 @@ share/gauche-0.9/%%VERSION%%/lib/math/const.scm
share/gauche-0.9/%%VERSION%%/lib/math/mt-random.scm
share/gauche-0.9/%%VERSION%%/lib/math/prime.scm
share/gauche-0.9/%%VERSION%%/lib/os/windows.scm
+share/gauche-0.9/%%VERSION%%/lib/os/windows/console/codepage.scm
share/gauche-0.9/%%VERSION%%/lib/parser/peg.scm
share/gauche-0.9/%%VERSION%%/lib/precomp
share/gauche-0.9/%%VERSION%%/lib/r7rs.scm
@@ -277,23 +286,36 @@ share/gauche-0.9/%%VERSION%%/lib/rfc/quoted-printable.scm
share/gauche-0.9/%%VERSION%%/lib/rfc/sha.scm
share/gauche-0.9/%%VERSION%%/lib/rfc/sha1.scm
share/gauche-0.9/%%VERSION%%/lib/rfc/tls.scm
+share/gauche-0.9/%%VERSION%%/lib/rfc/tls/mbed.scm
share/gauche-0.9/%%VERSION%%/lib/rfc/uri.scm
share/gauche-0.9/%%VERSION%%/lib/rfc/zlib.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/base.scm
+share/gauche-0.9/%%VERSION%%/lib/scheme/box.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/case-lambda.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/char.scm
+share/gauche-0.9/%%VERSION%%/lib/scheme/charset.scm
+share/gauche-0.9/%%VERSION%%/lib/scheme/comparator.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/complex.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/cxr.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/eval.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/file.scm
+share/gauche-0.9/%%VERSION%%/lib/scheme/generator.scm
+share/gauche-0.9/%%VERSION%%/lib/scheme/hash-table.scm
+share/gauche-0.9/%%VERSION%%/lib/scheme/ideque.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/inexact.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/lazy.scm
+share/gauche-0.9/%%VERSION%%/lib/scheme/list-queue.scm
+share/gauche-0.9/%%VERSION%%/lib/scheme/list.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/load.scm
+share/gauche-0.9/%%VERSION%%/lib/scheme/lseq.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/process-context.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/r5rs.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/read.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/repl.scm
+share/gauche-0.9/%%VERSION%%/lib/scheme/set.scm
+share/gauche-0.9/%%VERSION%%/lib/scheme/sort.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/time.scm
+share/gauche-0.9/%%VERSION%%/lib/scheme/vector.scm
share/gauche-0.9/%%VERSION%%/lib/scheme/write.scm
share/gauche-0.9/%%VERSION%%/lib/slib.scm
%%SLIB%%share/gauche-0.9/%%VERSION%%/lib/slibcat
@@ -307,14 +329,27 @@ share/gauche-0.9/%%VERSION%%/lib/srfi-114.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-117.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-118.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-121.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-125.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-127.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-128.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-129.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-13.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-131.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-132.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-133.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-134.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-14.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-14/query.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-14/set.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-141.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-143.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-146.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-146/hash.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-151.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-152.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-154.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-155.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-158.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-18.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-19.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-25.scm
@@ -332,10 +367,14 @@ share/gauche-0.9/%%VERSION%%/lib/srfi-43.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-5.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-55.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-60.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-64.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-66.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-69.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-7.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-74.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-78.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-9.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi-96.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-98.scm
share/gauche-0.9/%%VERSION%%/lib/srfi-99.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/0.scm
@@ -350,12 +389,24 @@ share/gauche-0.9/%%VERSION%%/lib/srfi/114.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/117.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/118.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/121.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/125.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/127.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/128.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/129.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/13.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/131.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/132.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/133.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/134.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/14.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/141.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/143.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/145.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/146.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/149.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/151.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/152.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/158.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/16.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/17.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/18.scm
@@ -388,13 +439,17 @@ share/gauche-0.9/%%VERSION%%/lib/srfi/6.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/60.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/61.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/62.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/64.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/66.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/69.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/7.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/74.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/78.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/8.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/87.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/9.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/95.scm
+share/gauche-0.9/%%VERSION%%/lib/srfi/96.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/98.scm
share/gauche-0.9/%%VERSION%%/lib/srfi/99.scm
share/gauche-0.9/%%VERSION%%/lib/sxml/adaptor.scm
@@ -404,8 +459,9 @@ share/gauche-0.9/%%VERSION%%/lib/sxml/sxpath.scm
share/gauche-0.9/%%VERSION%%/lib/sxml/to-html.scm
share/gauche-0.9/%%VERSION%%/lib/sxml/tools.scm
share/gauche-0.9/%%VERSION%%/lib/sxml/tree-trans.scm
-share/gauche-0.9/%%VERSION%%/lib/text/console/windows.scm
share/gauche-0.9/%%VERSION%%/lib/text/console.scm
+share/gauche-0.9/%%VERSION%%/lib/text/console/generic.scm
+share/gauche-0.9/%%VERSION%%/lib/text/console/windows.scm
share/gauche-0.9/%%VERSION%%/lib/text/csv.scm
share/gauche-0.9/%%VERSION%%/lib/text/diff.scm
share/gauche-0.9/%%VERSION%%/lib/text/gap-buffer.scm
@@ -416,10 +472,11 @@ share/gauche-0.9/%%VERSION%%/lib/text/line-edit.scm
share/gauche-0.9/%%VERSION%%/lib/text/parse.scm
share/gauche-0.9/%%VERSION%%/lib/text/progress.scm
share/gauche-0.9/%%VERSION%%/lib/text/sql.scm
+share/gauche-0.9/%%VERSION%%/lib/text/template.scm
share/gauche-0.9/%%VERSION%%/lib/text/tr.scm
share/gauche-0.9/%%VERSION%%/lib/text/tree.scm
-share/gauche-0.9/%%VERSION%%/lib/text/unicode/ucd.scm
share/gauche-0.9/%%VERSION%%/lib/text/unicode.scm
+share/gauche-0.9/%%VERSION%%/lib/text/unicode/ucd.scm
share/gauche-0.9/%%VERSION%%/lib/util/combinations.scm
share/gauche-0.9/%%VERSION%%/lib/util/digest.scm
share/gauche-0.9/%%VERSION%%/lib/util/dominator.scm