aboutsummaryrefslogtreecommitdiff
path: root/lang/gauche
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2002-09-23 15:33:46 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2002-09-23 15:33:46 +0000
commit5da49701ce2304e561156c4144aeda904e9f8373 (patch)
treed7d5c2bcb5733c9fd27cfcd84337c08474bae29e /lang/gauche
parent1aed634ee4d8ea1fe74b23ce7f6538e5958789d2 (diff)
downloadports-5da49701ce2304e561156c4144aeda904e9f8373.tar.gz
ports-5da49701ce2304e561156c4144aeda904e9f8373.zip
Notes
Diffstat (limited to 'lang/gauche')
-rw-r--r--lang/gauche/Makefile2
-rw-r--r--lang/gauche/distinfo2
-rw-r--r--lang/gauche/files/patch-doc-Makefile.in33
-rw-r--r--lang/gauche/files/patch-src-gauche-arith_i386.h20
-rw-r--r--lang/gauche/pkg-plist2
5 files changed, 34 insertions, 25 deletions
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
index 576cc6076297..08618cec61d5 100644
--- a/lang/gauche/Makefile
+++ b/lang/gauche/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gauche
-PORTVERSION= 0.6.2
+PORTVERSION= 0.6.3
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/lang/gauche/distinfo b/lang/gauche/distinfo
index bb5698158a44..f74bd97f63d5 100644
--- a/lang/gauche/distinfo
+++ b/lang/gauche/distinfo
@@ -1 +1 @@
-MD5 (Gauche-0.6.2.tgz) = 2d0778497ecab8be68b3c1926432b3b3
+MD5 (Gauche-0.6.3.tgz) = 8f04e7905208f6b73aa93380af62cfa8
diff --git a/lang/gauche/files/patch-doc-Makefile.in b/lang/gauche/files/patch-doc-Makefile.in
index 1086a1715b14..0aad1151667b 100644
--- a/lang/gauche/files/patch-doc-Makefile.in
+++ b/lang/gauche/files/patch-doc-Makefile.in
@@ -1,27 +1,14 @@
---- doc/Makefile.in.orig Fri Jul 19 14:47:53 2002
-+++ doc/Makefile.in Mon Sep 9 23:36:04 2002
-@@ -11,8 +11,8 @@
- # make mandir=wherever
- prefix = @prefix@
- datadir = @datadir@
--mandir = $(datadir)/man/man1
--infodir = $(datadir)/info
-+mandir = $(prefix)/man/man1
-+infodir = $(prefix)/info
-
- all: info
-
-@@ -22,8 +22,8 @@
+--- doc/Makefile.in.orig Sun Sep 8 12:25:49 2002
++++ doc/Makefile.in Mon Sep 23 23:24:03 2002
+@@ -22,7 +22,7 @@
$(INSTALL) -m 444 $$m $(mandir)/; \
done
if test ! -d $(infodir); then $(INSTALL) -d $(infodir); fi
- if test -f gauche-refe.info.gz -o -f gauche-refj.info.gz; then \
-- for info in *.info*; do \
+ if test -f gauche-refe.info -o -f gauche-refj.info; then \
-+ for info in *.info; do \
+ for info in *.info*; do \
$(INSTALL) -m 444 $$info $(infodir)/; \
done; \
- fi
@@ -48,7 +48,7 @@
pdf : gauche-refe.pdf
@@ -36,12 +23,12 @@
gosh ./extract -en -o gauche-refe.texi gauche-ref.texi
-gauche-refe.info.gz : gauche-refe.texi
-- if test X$(MAKEINFO) != X -a X$(GZIP) != X; then \
+- if test X$(MAKEINFO) != X -a X$(GZIP_PROGRAM) != X; then \
- $(MAKEINFO) --no-warn gauche-refe.texi; \
- rm -rf gauche-refe.info*.gz; \
-- $(GZIP) gauche-refe.info gauche-refe.info-[0-9]*; \
+- $(GZIP_PROGRAM) gauche-refe.info gauche-refe.info-[0-9]*; \
+gauche-refe.info : gauche-refe.texi
-+ if test X$(MAKEINFO) != X; then \
++ if test X$(MAKEINFO) != X ; then \
+ $(MAKEINFO) --no-split --no-warn gauche-refe.texi; \
fi
@@ -51,12 +38,12 @@
gosh ./extract -jp -o gauche-refj.texi gauche-ref.texi
-gauche-refj.info.gz : gauche-refj.texi
-- if test X$(MAKEINFO) != X -a X$(GZIP) != X; then \
+- if test X$(MAKEINFO) != X -a X$(GZIP_PROGRAM) != X; then \
- $(MAKEINFO) --no-warn gauche-refj.texi; \
- rm -rf gauche-refj.info*.gz; \
-- $(GZIP) gauche-refj.info gauche-refj.info-[0-9]*; \
+- $(GZIP_PROGRAM) gauche-refj.info gauche-refj.info-[0-9]*; \
+gauche-refj.info : gauche-refj.texi
-+ if test X$(MAKEINFO) != X; then \
++ if test X$(MAKEINFO) != X ; then \
+ $(MAKEINFO) --no-split --no-warn gauche-refj.texi; \
fi
diff --git a/lang/gauche/files/patch-src-gauche-arith_i386.h b/lang/gauche/files/patch-src-gauche-arith_i386.h
new file mode 100644
index 000000000000..020d0040dc67
--- /dev/null
+++ b/lang/gauche/files/patch-src-gauche-arith_i386.h
@@ -0,0 +1,20 @@
+--- src/gauche/arith_i386.h.orig Sun Sep 22 19:48:19 2002
++++ src/gauche/arith_i386.h Sun Sep 22 19:49:05 2002
+@@ -23,6 +23,8 @@
+ * r <- x + y + c mod wordsize
+ * c <- 1 if carry, 0 otherwise
+ */
++/* bad register voodoo... let the 'portable' version catch this.
++ fails on both 4.2-release and 5.0-current
+
+ #define UADD(r, c, x, y) \
+ asm("shrl $1, %2;" \
+@@ -32,7 +34,7 @@
+ "rcll $1, %1;" \
+ :"=&r" (r), "=&r" (c) \
+ :"1" (c), "g"(x), "g"(y))
+-
++*/
+ /*-----------------------------------------------------------------
+ * UADDOV(r, v, x, y) unsigned word add with overflow check
+ * u_long : r, v, x, y;
diff --git a/lang/gauche/pkg-plist b/lang/gauche/pkg-plist
index 55a9f964b181..c69b7d20945e 100644
--- a/lang/gauche/pkg-plist
+++ b/lang/gauche/pkg-plist
@@ -11,6 +11,7 @@ lib/gauche/%%VERSION%%/%%TARGET%%/libnet.so
lib/gauche/%%VERSION%%/%%TARGET%%/libuvector.so
lib/gauche/%%VERSION%%/%%TARGET%%/mt-random.so
lib/gauche/%%VERSION%%/%%TARGET%%/ndbm.so
+lib/gauche/%%VERSION%%/%%TARGET%%/syslog.so
lib/gauche/%%VERSION%%/%%TARGET%%/termios.so
lib/gauche/%%VERSION%%/%%TARGET%%/threads.so
lib/gauche/%%VERSION%%/include/gauche.h
@@ -80,6 +81,7 @@ share/gauche/%%VERSION%%/lib/gauche/serializer.scm
share/gauche/%%VERSION%%/lib/gauche/serializer/aserializer.scm
share/gauche/%%VERSION%%/lib/gauche/signal.scm
share/gauche/%%VERSION%%/lib/gauche/singleton.scm
+share/gauche/%%VERSION%%/lib/gauche/syslog.scm
share/gauche/%%VERSION%%/lib/gauche/termios.scm
share/gauche/%%VERSION%%/lib/gauche/test.scm
share/gauche/%%VERSION%%/lib/gauche/threads.scm