aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc-objc
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-09-10 03:56:45 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-09-10 03:56:45 +0000
commit99090e8684a0f35776654dad79f4df5f60ed8adb (patch)
treef0e4bf188dbb573d0f54ef92a8bdfa99a82dc439 /lang/gcc-objc
parent3b6e943450311a54052196244f4ef1c07a50214f (diff)
downloadports-99090e8684a0f35776654dad79f4df5f60ed8adb.tar.gz
ports-99090e8684a0f35776654dad79f4df5f60ed8adb.zip
Notes
Diffstat (limited to 'lang/gcc-objc')
-rw-r--r--lang/gcc-objc/Makefile33
1 files changed, 18 insertions, 15 deletions
diff --git a/lang/gcc-objc/Makefile b/lang/gcc-objc/Makefile
index f748bbc86dc1..f5ed6db169d6 100644
--- a/lang/gcc-objc/Makefile
+++ b/lang/gcc-objc/Makefile
@@ -9,36 +9,39 @@ CATEGORIES= lang
PKGNAMESUFFIX= -objc
MAINTAINER= dinoex@FreeBSD.org
-.if defined(GNUSTEP_WITH_GCC32)
-COMMENT= GNU Compiler Collection 3.2.3 with threads and shared libs
-.else
-COMMENT= GNU Compiler Collection 3.3 with threads and shared libs
-.endif
+COMMENT= GNU Compiler Collection ${COMMENT2} with threads and shared libs
WANT_SHAREDLIBS= yes
WANT_THREADS_SUPPORT= yes
WITHOUT_LIBJAVA= yes
-.if defined(GNUSTEP_WITH_GCC32)
-MASTERDIR?= ${.CURDIR}/../gcc32
-.else
-MASTERDIR?= ${.CURDIR}/../gcc33
-.endif
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib ${TARGLIB}
LDFLAGS+= -L${LOCALBASE}/lib
+.if !defined(GNUSTEP_WITH_GCC32) && !defined(GNUSTEP_WITH_GCC33) && !defined(GNUSTEP_WITH_GCC34)
+GNUSTEP_WITH_GCC33= yes
+.endif
+
.if defined(GNUSTEP_WITH_GCC32)
+MASTERDIR?= ${.CURDIR}/../gcc32
CONFLICTS?= gcc-3.2*
-.else
+COMMENT2= 3.2.x
+.endif
+.if defined(GNUSTEP_WITH_GCC33)
+MASTERDIR?= ${.CURDIR}/../gcc33
CONFLICTS?= gcc-3.3*
+COMMENT2= 3.3.x
+.endif
+.if defined(GNUSTEP_WITH_GCC34)
+MASTERDIR?= ${.CURDIR}/../gcc34
+CONFLICTS?= gcc-3.4*
+COMMENT2= 3.4.x
.endif
.if exists(${.CURDIR}/Makefile.local)
.include "${.CURDIR}/Makefile.local"
.endif
-.include "${MASTERDIR}/Makefile"
+MAKE_ENV+= LD_LIBRARY_PATH=.:${WRKSRC}/gcc
-.if ${OSVERSION} >= 502122
-BROKEN= new ld: linker refuses to find shared libs
-.endif
+.include "${MASTERDIR}/Makefile"