aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc-objc
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-04-13 11:26:47 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-04-13 11:26:47 +0000
commit08f231f091ac65769e58c109a4b1a405acc1909a (patch)
tree1d0828ad024249593174271e6b0faeafeb72df4c /lang/gcc-objc
parent5cd8ee4b962cdd072d3994b007a2d4fa664f498c (diff)
downloadports-08f231f091ac65769e58c109a4b1a405acc1909a.tar.gz
ports-08f231f091ac65769e58c109a4b1a405acc1909a.zip
Notes
Diffstat (limited to 'lang/gcc-objc')
-rw-r--r--lang/gcc-objc/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/lang/gcc-objc/Makefile b/lang/gcc-objc/Makefile
new file mode 100644
index 000000000000..d32230ec2515
--- /dev/null
+++ b/lang/gcc-objc/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: gnustep-objc
+# Date created: 28.Mar.2003
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+CATEGORIES= lang
+PKGNAMESUFFIX= -objc
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= GNU Compiler Collection 3.2.3 with threads and shared libs
+
+WANT_SHAREDLIBS= yes
+WANT_THREADS_SUPPORT= yes
+MASTERDIR?= ${.CURDIR}/../gcc32
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= %%PREFIX%%/lib ${TARGLIB}
+LDFLAGS+= -L${LOCALBASE}/lib
+
+# does not build on:
+NOT_FOR_ARCHS= amd64
+
+CONFLICTS?= gcc-3.2*
+
+.if exists(${.CURDIR}/Makefile.local)
+.include "${.CURDIR}/Makefile.local"
+.endif
+
+.include "${MASTERDIR}/Makefile"