aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc11-devel
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2020-06-25 07:07:27 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2020-06-25 07:07:27 +0000
commit97fbf28a11f3554460cb4af248aade231f2e2bc0 (patch)
tree44fed494f9807c9eb615660a3bafdc9b32866be1 /lang/gcc11-devel
parent0b4fbde59f31fcb08f37e66a57157e512b5230cb (diff)
downloadports-97fbf28a11f3554460cb4af248aade231f2e2bc0.tar.gz
ports-97fbf28a11f3554460cb4af248aade231f2e2bc0.zip
Notes
Diffstat (limited to 'lang/gcc11-devel')
-rw-r--r--lang/gcc11-devel/Makefile2
-rw-r--r--lang/gcc11-devel/distinfo6
-rw-r--r--lang/gcc11-devel/files/patch-PR9580547
3 files changed, 51 insertions, 4 deletions
diff --git a/lang/gcc11-devel/Makefile b/lang/gcc11-devel/Makefile
index a765eccadc10..621437eb13b8 100644
--- a/lang/gcc11-devel/Makefile
+++ b/lang/gcc11-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 11.0.0.s20200614
+PORTVERSION= 11.0.0.s20200621
CATEGORIES= lang
MASTER_SITES= GCC/snapshots/${DIST_VERSION}
PKGNAMESUFFIX= ${SUFFIX}-devel
diff --git a/lang/gcc11-devel/distinfo b/lang/gcc11-devel/distinfo
index 247f17e305ab..54ca28320b52 100644
--- a/lang/gcc11-devel/distinfo
+++ b/lang/gcc11-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1592293522
-SHA256 (gcc-11-20200614.tar.xz) = 40635ce0e16ad628ea195270923b2bcbbcb6e1e552e0a18dfc1a9c49f286a741
-SIZE (gcc-11-20200614.tar.xz) = 71538232
+TIMESTAMP = 1592784068
+SHA256 (gcc-11-20200621.tar.xz) = ac7566828cba717b23e0a954ac72dff9fa39cddbaa9beb03a3dedf72bccec75c
+SIZE (gcc-11-20200621.tar.xz) = 71629184
diff --git a/lang/gcc11-devel/files/patch-PR95805 b/lang/gcc11-devel/files/patch-PR95805
new file mode 100644
index 000000000000..b75149fe1b89
--- /dev/null
+++ b/lang/gcc11-devel/files/patch-PR95805
@@ -0,0 +1,47 @@
+This should be properly fixed upstream by the next snapshot.
+
+Revert commit 4e49b994de060d4a6c9318d0ed52ef038153426e
+Author: Richard Sandiford <richard.sandiford@arm.com>
+Date: Wed Jun 17 17:45:29 2020 +0100
+
+ recog: Tweak insn_gen_fn::operator() definition
+
+ Fixes a “left operand of comma has no effect” warning that some were
+ seeing. Also fixes a spurious ellipsis that Jonathan Wakely pointed
+ out.
+
+ 2020-06-17 Richard Sandiford <richard.sandiford@arm.com>
+
+ gcc/
+ * coretypes.h (first_type): New alias template.
+ * recog.h (insn_gen_fn::operator()): Use it instead of a decltype.
+ Remove spurious “...” and split the function type out into a typedef.
+
+--- gcc/coretypes.h 2020-06-21 22:32:12.000000000 +0000
++++ gcc/coretypes.h 2020-06-23 18:56:41.074951000 +0000
+@@ -359,10 +359,6 @@
+ const ValueType value; /* the value of the name */
+ };
+
+-/* Alias of the first type, ignoring the second. */
+-template<typename T1, typename T2>
+-using first_type = T1;
+-
+ /* Iterator pair used for a collection iteration with range-based loops. */
+
+ template<typename T>
+--- gcc/recog.h
++++ gcc/recog.h
+@@ -295,10 +295,9 @@ struct insn_gen_fn
+ typedef void (*stored_funcptr) (void);
+
+ template<typename ...Ts>
+- rtx_insn *operator() (Ts... args) const
++ rtx_insn *operator() (Ts... args...) const
+ {
+- typedef rtx_insn *(*funcptr) (first_type<rtx, Ts>...);
+- return ((funcptr) func) (args...);
++ return ((rtx_insn *(*) (decltype(args, NULL_RTX)...)) func) (args...);
+ }
+
+ // This is for compatibility of code that invokes functions like