aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc28
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2003-04-27 12:59:04 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2003-04-27 12:59:04 +0000
commit353f2c7af838bc88636ddd9fcb3ef46610e202ba (patch)
treed4e5a7871afa6dc19c9a759c5eaf2d063c661726 /lang/gcc28
parent59a1dc1968c31140b47fccba60a45008f5a36145 (diff)
downloadports-353f2c7af838bc88636ddd9fcb3ef46610e202ba.tar.gz
ports-353f2c7af838bc88636ddd9fcb3ef46610e202ba.zip
Notes
Diffstat (limited to 'lang/gcc28')
-rw-r--r--lang/gcc28/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/gcc28/Makefile b/lang/gcc28/Makefile
index 8db267b88183..173f0d3dabc5 100644
--- a/lang/gcc28/Makefile
+++ b/lang/gcc28/Makefile
@@ -36,6 +36,7 @@ PLIST_SUB= GNUHOST=${CONFIGURE_TARGET}
CONFIGURE_ARGS= --with-gxx-include-dir=${PREFIX}/lib/gcc-lib/${CONFIGURE_TARGET}/2.8.1/include/g++
GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
ALL_TARGET= bootstrap
MAN1= cccp28.1 g++28.1 gcc28.1
@@ -46,6 +47,11 @@ pre-patch:
@${MV} ${WRKSRC}/config/i386/freebsd.h ${WRKSRC}/config/i386/freebsd-aout.h
@${MV} ${WRKSRC}/config/i386/freebsd-elf.h ${WRKSRC}/config/i386/freebsd.h
+post-patch:
+.if ${OSVERSION} >= 500000
+ @${REINPLACE_CMD} -e 's|elf_i386|elf_i386_fbsd|' ${WRKSRC}/config/i386/freebsd.h
+.endif
+
pre-configure:
@# Keep from running `autoconf' and `autoheader' since we modified
@# configure.in by patching it.