aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc295/files
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1999-02-09 18:24:50 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1999-02-09 18:24:50 +0000
commit9740802749731bb28d0e38b06023350192e85a09 (patch)
tree773743b9fd0f78392da8f7652ec57cf0f6eea8b8 /lang/gcc295/files
parentf21b34b03975545024b342ad9c0f70852e66a09a (diff)
Notes
Diffstat (limited to 'lang/gcc295/files')
-rw-r--r--lang/gcc295/files/patch-ad4
-rw-r--r--lang/gcc295/files/patch-af4
-rw-r--r--lang/gcc295/files/patch-aj6
-rw-r--r--lang/gcc295/files/patch-ak30
-rw-r--r--lang/gcc295/files/patch-al29
5 files changed, 61 insertions, 12 deletions
diff --git a/lang/gcc295/files/patch-ad b/lang/gcc295/files/patch-ad
index 7b42a720728b..3fa37c95418b 100644
--- a/lang/gcc295/files/patch-ad
+++ b/lang/gcc295/files/patch-ad
@@ -1,5 +1,5 @@
---- gcc/config/i386/freebsd.h.orig Tue Jun 30 15:52:18 1998
-+++ gcc/config/i386/freebsd.h Fri Jan 22 04:08:44 1999
+--- gcc/config/i386/freebsd-aout.h.orig Tue Jun 30 15:52:18 1998
++++ gcc/config/i386/freebsd-aout.h Fri Jan 22 04:08:44 1999
@@ -89,6 +89,10 @@
/* Don't default to pcc-struct-return, because gcc is the only compiler, and
we want to retain compatibility with older gcc versions. */
diff --git a/lang/gcc295/files/patch-af b/lang/gcc295/files/patch-af
index b342bb4a6b4a..e9d23249070c 100644
--- a/lang/gcc295/files/patch-af
+++ b/lang/gcc295/files/patch-af
@@ -1,5 +1,5 @@
---- gcc/config/i386/freebsd-elf.h.orig Mon Jul 13 15:38:36 1998
-+++ gcc/config/i386/freebsd-elf.h Fri Jan 22 04:11:03 1999
+--- gcc/config/i386/freebsd.h.orig Mon Jul 13 15:38:36 1998
++++ gcc/config/i386/freebsd.h Fri Jan 22 04:11:03 1999
@@ -26,8 +26,13 @@
/* The svr4 ABI for the i386 says that records and unions are returned
diff --git a/lang/gcc295/files/patch-aj b/lang/gcc295/files/patch-aj
index 4f4d9f994ec7..cf2236003f39 100644
--- a/lang/gcc295/files/patch-aj
+++ b/lang/gcc295/files/patch-aj
@@ -1,14 +1,14 @@
--- config.guess.orig Fri Oct 23 14:26:33 1998
-+++ config.guess Thu Dec 3 20:56:57 1998
++++ config.guess Mon Feb 8 12:13:06 1999
@@ -474,7 +474,11 @@
echo ${UNAME_MACHINE}-pc-bsdi${UNAME_RELEASE}
exit 0 ;;
*:FreeBSD:*:*)
- echo ${UNAME_MACHINE}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`
+ if test -x /usr/bin/objformat -a "elf" = "`/usr/bin/objformat`"; then
-+ echo ${UNAME_MACHINE}-unknown-freebsdelf`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`
-+ else
+ echo ${UNAME_MACHINE}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`
++ else
++ echo ${UNAME_MACHINE}-unknown-freebsdaout`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`
+ fi
exit 0 ;;
*:NetBSD:*:*)
diff --git a/lang/gcc295/files/patch-ak b/lang/gcc295/files/patch-ak
index f2c8058c74ca..817e789e8f53 100644
--- a/lang/gcc295/files/patch-ak
+++ b/lang/gcc295/files/patch-ak
@@ -1,10 +1,30 @@
--- gcc/configure.orig Wed Dec 2 11:22:52 1998
-+++ gcc/configure Fri Dec 25 00:35:40 1998
-@@ -2752,6 +2752,7 @@
- tm_file="i386/i386.h i386/att.h linux.h i386/freebsd-elf.h i386/perform.h"
++++ gcc/configure Tue Feb 9 02:21:19 1999
+@@ -2748,20 +2748,21 @@
+ # Next line turned off because both 386BSD and BSD/386 use GNU ld.
+ # use_collect2=yes
+ ;;
+- i[34567]86-*-freebsdelf*)
+- tm_file="i386/i386.h i386/att.h linux.h i386/freebsd-elf.h i386/perform.h"
++ i[34567]86-*-freebsdaout*)
++ tm_file=i386/freebsd.h
+ # On FreeBSD, the headers are already ok, except for math.h.
+ fixincludes=fixinc.wrap
+ tmake_file=i386/t-freebsd
+- gas=yes
+- gnu_ld=yes
+- stabs=yes
+ ;;
+ i[34567]86-*-freebsd*)
+- tm_file=i386/freebsd.h
++ tm_file="i386/i386.h i386/att.h linux.h i386/freebsd.h i386/perform.h"
# On FreeBSD, the headers are already ok, except for math.h.
fixincludes=fixinc.wrap
+ extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
tmake_file=i386/t-freebsd
- gas=yes
- gnu_ld=yes
++ gas=yes
++ gnu_ld=yes
++ stabs=yes
+ ;;
+ i[34567]86-*-netbsd*)
+ tm_file=i386/netbsd.h
diff --git a/lang/gcc295/files/patch-al b/lang/gcc295/files/patch-al
new file mode 100644
index 000000000000..5630ff63f6d5
--- /dev/null
+++ b/lang/gcc295/files/patch-al
@@ -0,0 +1,29 @@
+--- gcc/configure.in.orig Thu Aug 27 17:19:04 1998
++++ gcc/configure.in Tue Feb 9 02:22:10 1999
+@@ -846,20 +846,20 @@
+ # Next line turned off because both 386BSD and BSD/386 use GNU ld.
+ # use_collect2=yes
+ ;;
+- i[[34567]]86-*-freebsdelf*)
+- tm_file="i386/i386.h i386/att.h linux.h i386/freebsd-elf.h i386/perform.h"
++ i[[34567]]86-*-freebsdaout*)
++ tm_file=i386/freebsd.h
+ # On FreeBSD, the headers are already ok, except for math.h.
+ fixincludes=fixinc.wrap
+ tmake_file=i386/t-freebsd
+- gas=yes
+- gnu_ld=yes
+- stabs=yes
+ ;;
+ i[[34567]]86-*-freebsd*)
+- tm_file=i386/freebsd.h
++ tm_file="i386/i386.h i386/att.h linux.h i386/freebsd.h i386/perform.h"
+ # On FreeBSD, the headers are already ok, except for math.h.
+ fixincludes=fixinc.wrap
+ tmake_file=i386/t-freebsd
++ gas=yes
++ gnu_ld=yes
++ stabs=yes
+ ;;
+ i[[34567]]86-*-netbsd*)
+ tm_file=i386/netbsd.h