aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc33/Makefile
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2005-07-10 17:13:19 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2005-07-10 17:13:19 +0000
commitfd34e8ad87491bf4414d282e8b4bc963999a127d (patch)
tree024931d5a27e8497995bb82ca0bc956b7468e1c3 /lang/gcc33/Makefile
parent9e8c730a6641412c1aa7aaaca0f76b3198ed20b8 (diff)
Notes
Diffstat (limited to 'lang/gcc33/Makefile')
-rw-r--r--lang/gcc33/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/lang/gcc33/Makefile b/lang/gcc33/Makefile
index fb4052bd7d72..f79f84210b64 100644
--- a/lang/gcc33/Makefile
+++ b/lang/gcc33/Makefile
@@ -8,11 +8,11 @@
PORTNAME= gcc
PORTVERSION= 3.3.6
-PORTREVISION= 20050511
+PORTEPOCH= 1
CATEGORIES= lang
-VERSIONSTRING= 3.3-${PORTREVISION}
+VERSIONSTRING= ${PORTVERSION}
MASTER_SITES= ${MASTER_SITE_GCC}
-MASTER_SITE_SUBDIR= snapshots/${VERSIONSTRING}
+MASTER_SITE_SUBDIR= releases/gcc-${VERSIONSTRING}
DISTFILES= \
gcc-core-${VERSIONSTRING}${EXTRACT_SUFX} \
gcc-g++-${VERSIONSTRING}${EXTRACT_SUFX} \
@@ -74,7 +74,6 @@ INFO= cpp cppinternals g77 gcc gccint
pre-everything::
@${ECHO_MSG} "Making GCC ${DISTNAME:S/^gcc-//} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
- @${ECHO_MSG} "(without Java)"
post-patch:
@${REINPLACE_CMD} -e 's|\(const char version_string.*\)";|\1 [FreeBSD]";|' \
@@ -94,8 +93,8 @@ check: build
cd ${WRKSRC}; export RUNTESTFLAGS='--target_board ''unix{-pthread}'''; ${GMAKE} -sk check
post-install:
- # man pages can only be generated if Perl >= 5.6 is installed, so
- # fake them on 4.x systems.
+ # man pages can only be generated if Perl >= 5.6 is installed;
+ # fake them otherwise.
for mp in ${_MANPAGES}; do \
${TEST} -e $${mp} || ${TOUCH} ${TOUCH_FLAGS} $${mp}; \
done