aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc34/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2000-01-17 12:27:59 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2000-01-17 12:27:59 +0000
commit19b929d5e31f6f44304094cb836ef24292d4fe4e (patch)
treee9fad16c54a6f5f2de3a5b79d53ecc9723c4298f /lang/gcc34/Makefile
parent467b3f375a706bfaecd0af1bc398694b483c9aaf (diff)
Upgrade to the 2000-01-10 GCC 2.96 development snapshot.
Notes
Notes: svn path=/head/; revision=24793
Diffstat (limited to 'lang/gcc34/Makefile')
-rw-r--r--lang/gcc34/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/lang/gcc34/Makefile b/lang/gcc34/Makefile
index efee67e57ea1..7e19127dbee8 100644
--- a/lang/gcc34/Makefile
+++ b/lang/gcc34/Makefile
@@ -7,7 +7,7 @@
# $FreeBSD$
#
-SNAPDATE= 1999-11-10
+SNAPDATE= 2000-01-10
SNAPVER= ${SNAPDATE:S/-//g}
DISTNAME= gcc-2.96
@@ -62,12 +62,11 @@ MAN1= cccp.1 eg++.1 eg77.1 egcc.1
pre-patch:
@${MV} ${WRKSRC}/gcc/config/i386/freebsd.h ${WRKSRC}/gcc/config/i386/freebsd-aout.h
@${MV} ${WRKSRC}/gcc/config/i386/freebsd-elf.h ${WRKSRC}/gcc/config/i386/freebsd.h
- @${CP} ${WRKSRC}/gcc/config/t-openbsd-thread ${WRKSRC}/gcc/config/t-freebsd-thread
pre-configure:
@(MAJ=`sysctl -n kern.osreldate | ${SED} -e '/.....$$/s///'` ; \
- ${SED} -e "s:__FreeBSD__:__FreeBSD__=$${MAJ}:" ${FILESDIR}/freebsd.h \
- >${WRKSRC}/gcc/config/freebsd.h )
+ ${PERL} -pi.orig -e "s:__FreeBSD__:__FreeBSD__=$${MAJ}:" \
+ ${WRKSRC}/gcc/config/freebsd.h )
@${CP} ${FILESDIR}/alpha-freebsd.h ${WRKSRC}/gcc/config/alpha/freebsd.h
.if ${PORTOBJFORMAT} == "elf" && ${MACHINE_ARCH} == "i386"
@${SED} -e 's/^@comment ELF-only://' ${PKGDIR}/PLIST >${PLIST}