aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc34
diff options
context:
space:
mode:
authorMarius Strobl <marius@FreeBSD.org>2008-02-26 19:28:41 +0000
committerMarius Strobl <marius@FreeBSD.org>2008-02-26 19:28:41 +0000
commit13266eb0f5f62cadea650f41ed69c11ab99bab6e (patch)
tree6dea2c7ff0e808b59c1de91fa24539c177e25663 /lang/gcc34
parent429181ee8319aba1b0792b8a16118bf06563306b (diff)
downloadports-13266eb0f5f62cadea650f41ed69c11ab99bab6e.tar.gz
ports-13266eb0f5f62cadea650f41ed69c11ab99bab6e.zip
Notes
Diffstat (limited to 'lang/gcc34')
-rw-r--r--lang/gcc34/Makefile2
-rw-r--r--lang/gcc34/files/patch-config-sparc-freebsd.h28
2 files changed, 29 insertions, 1 deletions
diff --git a/lang/gcc34/Makefile b/lang/gcc34/Makefile
index 543379abfb51..85dda4afe07a 100644
--- a/lang/gcc34/Makefile
+++ b/lang/gcc34/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gcc
PORTVERSION= 3.4.6
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= lang
VERSIONSTRING= ${PORTVERSION}
diff --git a/lang/gcc34/files/patch-config-sparc-freebsd.h b/lang/gcc34/files/patch-config-sparc-freebsd.h
new file mode 100644
index 000000000000..8b8ae0de92e5
--- /dev/null
+++ b/lang/gcc34/files/patch-config-sparc-freebsd.h
@@ -0,0 +1,28 @@
+--- gcc/config/sparc/freebsd.h.orig 2004-07-17 21:18:58.000000000 +0000
++++ gcc/config/sparc/freebsd.h 2008-02-15 21:04:17.000000000 +0000
+@@ -24,11 +24,21 @@
+ { "fbsd_dynamic_linker", FBSD_DYNAMIC_LINKER }
+
+ /* FreeBSD needs the platform name (sparc64) defined.
+- Emacs needs to know if the arch is 64 or 32-bits. */
++ Emacs needs to know if the arch is 64 or 32-bits.
++ This also selects which targets are available via -mcpu. */
+
+-#undef CPP_CPU64_DEFAULT_SPEC
+-#define CPP_CPU64_DEFAULT_SPEC \
+- "-D__sparc64__ -D__sparc_v9__ -D__sparcv9 -D__arch64__"
++#undef FBSD_TARGET_CPU_CPP_BUILTINS
++#define FBSD_TARGET_CPU_CPP_BUILTINS() \
++ do \
++ { \
++ builtin_define ("__LP64__"); \
++ builtin_define ("__sparc64__"); \
++ builtin_define ("__sparc_v9__"); \
++ builtin_define ("__sparcv9"); \
++ builtin_define ("__sparc__"); \
++ builtin_define ("__arch64__"); \
++ } \
++ while (0)
+
+ #define LINK_SPEC "%(link_arch) \
+ %{!mno-relax:%{!r:-relax}} \