aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc41/files
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2000-01-17 12:27:59 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2000-01-17 12:27:59 +0000
commit19b929d5e31f6f44304094cb836ef24292d4fe4e (patch)
treee9fad16c54a6f5f2de3a5b79d53ecc9723c4298f /lang/gcc41/files
parent467b3f375a706bfaecd0af1bc398694b483c9aaf (diff)
downloadports-19b929d5e31f6f44304094cb836ef24292d4fe4e.tar.gz
ports-19b929d5e31f6f44304094cb836ef24292d4fe4e.zip
Notes
Diffstat (limited to 'lang/gcc41/files')
-rw-r--r--lang/gcc41/files/patch-ad11
-rw-r--r--lang/gcc41/files/patch-af45
-rw-r--r--lang/gcc41/files/patch-ak31
-rw-r--r--lang/gcc41/files/patch-al35
-rw-r--r--lang/gcc41/files/patch-ar29
5 files changed, 74 insertions, 77 deletions
diff --git a/lang/gcc41/files/patch-ad b/lang/gcc41/files/patch-ad
index f8a3b90fdb1a..b838666b14fa 100644
--- a/lang/gcc41/files/patch-ad
+++ b/lang/gcc41/files/patch-ad
@@ -1,16 +1,5 @@
--- gcc/config/i386/freebsd-aout.h.orig Tue Jun 1 17:02:37 1999
+++ gcc/config/i386/freebsd-aout.h Mon Jun 14 14:11:20 1999
-@@ -20,6 +20,10 @@
- the Free Software Foundation, 59 Temple Place - Suite 330,
- Boston, MA 02111-1307, USA. */
-
-+
-+/* Get generic FreeBSD definitions. */
-+#include <freebsd.h>
-+
- /* This is tested by i386gas.h. */
- #define YES_UNDERSCORES
-
@@ -32,12 +36,10 @@
#include "i386/perform.h"
diff --git a/lang/gcc41/files/patch-af b/lang/gcc41/files/patch-af
index 533a35a95584..c1fbd05ffed6 100644
--- a/lang/gcc41/files/patch-af
+++ b/lang/gcc41/files/patch-af
@@ -1,6 +1,6 @@
---- gcc/config/i386/freebsd.h.orig Thu Jun 17 05:33:32 1999
-+++ gcc/config/i386/freebsd.h Sat Jul 24 17:59:06 1999
-@@ -135,6 +135,10 @@
+--- gcc/config/i386/freebsd.h.orig Mon Nov 22 22:17:32 1999
++++ gcc/config/i386/freebsd.h Wed Dec 15 02:32:20 1999
+@@ -117,6 +117,10 @@
: ((n) >= FIRST_STACK_REG && (n) <= LAST_STACK_REG) ? (n)+3 \
: (-1))
@@ -11,51 +11,24 @@
/* Tell final.c that we don't need a label passed to mcount. */
#undef FUNCTION_PROFILER
-@@ -162,22 +166,30 @@
+@@ -140,7 +144,15 @@
#define WCHAR_TYPE_SIZE BITS_PER_WORD
#undef CPP_PREDEFINES
-#define CPP_PREDEFINES "-Di386 -Dunix -D__ELF__ -D__FreeBSD__ -Asystem(unix) -Asystem(FreeBSD) -Acpu(i386) -Amachine(i386)"
+#define CPP_PREDEFINES "-Di386 -Acpu(i386) -Amachine(i386)" CPP_FBSD_PREDEFINES
-
- #undef CPP_SPEC
--#define CPP_SPEC "%(cpp_cpu) %{fPIC:-D__PIC__ -D__pic__} %{fpic:-D__PIC__ -D__pic__} %{posix:-D_POSIX_SOURCE}"
-+#if TARGET_CPU_DEFAULT == 2
-+#define CPP_SPEC "\
-+ %{!maout: -D__ELF__} \
-+ %{munderscores: -D__UNDERSCORES__} \
-+ %{maout: %{!mno-underscores: -D__UNDERSCORES__}} \
-+ %{fPIC:-D__PIC__ -D__pic__} %{fpic:-D__PIC__ -D__pic__} %{!m386:-D__i486__}"
-+#else
-+#define CPP_SPEC "\
-+ %{!maout: -D__ELF__} \
-+ %{munderscores: -D__UNDERSCORES__} \
-+ %{maout: %{!mno-underscores: -D__UNDERSCORES__}} \
-+ %{fPIC:-D__PIC__ -D__pic__} %{fpic:-D__PIC__ -D__pic__} %{m486:-D__i486__}"
-+#endif
+
+#undef CC1_SPEC
+#define CC1_SPEC "\
+ %{gline:%{!g:%{!g0:%{!g1:%{!g2: -g1}}}}} \
+ %{maout: %{!mno-underscores: %{!munderscores: -munderscores }}}"
-
--/* This defines which switch letters take arguments. On FreeBSD, most of
-- the normal cases (defined in gcc.c) apply, and we also have -h* and
-- -z* options (for the linker) (comming from svr4).
-- We also have -R (alias --rpath), no -z, --soname (-h), --assert etc. */
--
--#undef SWITCH_TAKES_ARG
--#define SWITCH_TAKES_ARG(CHAR) \
-- (DEFAULT_SWITCH_TAKES_ARG (CHAR) \
-- || (CHAR) == 'h' \
-- || (CHAR) == 'z' \
-- || (CHAR) == 'R')
++
+#undef ASM_SPEC
+#define ASM_SPEC "%{v*: -v} %{maout: %{fpic:-k} %{fPIC:-k}}"
/* Provide a STARTFILE_SPEC appropriate for FreeBSD. Here we add
the magical crtbegin.o file (see crtstuff.c) which provides part
-@@ -186,11 +198,11 @@
+@@ -149,11 +161,11 @@
#undef STARTFILE_SPEC
#define STARTFILE_SPEC \
@@ -72,12 +45,12 @@
/* Provide a ENDFILE_SPEC appropriate for FreeBSD. Here we tack on
the magical crtend.o file (see crtstuff.c) which provides part of
-@@ -200,7 +212,7 @@
+@@ -163,7 +175,7 @@
#undef ENDFILE_SPEC
#define ENDFILE_SPEC \
- "%{!shared:crtend.o%s} %{shared:crtendS.o%s} crtn.o%s"
+ "%{!maout: %{!shared:crtend.o%s} %{shared:crtendS.o%s} crtn.o%s}"
- /* Provide a LIB_SPEC appropriate for FreeBSD. Just select the appropriate
- libc, depending on whether we're doing profiling or need threads support.
+ /* Provide a LINK_SPEC appropriate for FreeBSD. Here we provide support
+ for the special GCC options -static and -shared, which allow us to
diff --git a/lang/gcc41/files/patch-ak b/lang/gcc41/files/patch-ak
index 81bf09754e07..e1804f119d0d 100644
--- a/lang/gcc41/files/patch-ak
+++ b/lang/gcc41/files/patch-ak
@@ -1,6 +1,6 @@
---- gcc/configure.orig Mon Sep 20 02:59:34 1999
-+++ gcc/configure Sat Sep 25 10:51:55 1999
-@@ -3167,6 +3167,15 @@
+--- gcc/configure.orig Wed Dec 8 04:30:22 1999
++++ gcc/configure Fri Dec 10 09:44:30 1999
+@@ -3440,6 +3440,22 @@
thread_file='posix'
fi
;;
@@ -11,19 +11,26 @@
+ tmake_file="t-freebsd alpha/t-crtbe"
+ xmake_file=none
+ fixincludes=fixinc.wrap
-+ gas=yes gnu_ld=yes
++ gas=yes
++ gnu_ld=yes
++ case x${enable_threads} in
++ xyes | xpthreads | xposix)
++ thread_file='posix'
++ tmake_file="${tmake_file} t-freebsd-thread"
++ ;;
++ esac
+ ;;
alpha*-*-netbsd*)
tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"
target_cpu_default="MASK_GAS"
-@@ -3772,8 +3781,12 @@
+@@ -4050,8 +4066,12 @@
# Next line turned off because both 386BSD and BSD/386 use GNU ld.
# use_collect2=yes
;;
- i[34567]86-*-freebsdelf*)
-- tm_file="i386/i386.h i386/att.h svr4.h i386/freebsd-elf.h i386/perform.h"
+- tm_file="i386/i386.h i386/att.h svr4.h freebsd.h i386/freebsd-elf.h i386/perform.h"
+ i[34567]86-*-freebsd[12].* | i[34567]86-*-freebsd[12] | i[34567]86-*-freebsdaout* | i[34567]86-*-freebsd-aout)
-+ tm_file=i386/freebsd-aout.h
++ tm_file="freebsd.h i386/freebsd-aout.h"
+ tmake_file=t-freebsd
+ ;;
+ i[34567]86-*-freebsd[3-9].* | i[34567]86-*-freebsd[3-9] | i[34567]86-*-freebsd* | i[34567]86-*-freebsdelf*)
@@ -31,17 +38,13 @@
extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
tmake_file=t-freebsd
gas=yes
-@@ -3782,13 +3795,9 @@
- case x${enable_threads} in
- xyes | xpthreads | xposix)
- thread_file='posix'
-- tmake_file="${tmake_file} t-openbsd-thread"
-+ tmake_file="${tmake_file} t-freebsd-thread"
+@@ -4063,10 +4083,6 @@
+ tmake_file="${tmake_file} t-freebsd-thread"
;;
esac
- ;;
- i[34567]86-*-freebsd*)
-- tm_file=i386/freebsd.h
+- tm_file="i386/freebsd.h i386/perform.h"
- tmake_file=t-freebsd
;;
i[34567]86-*-netbsd*)
diff --git a/lang/gcc41/files/patch-al b/lang/gcc41/files/patch-al
index 1c81b9a57bd2..3da58f53a512 100644
--- a/lang/gcc41/files/patch-al
+++ b/lang/gcc41/files/patch-al
@@ -1,6 +1,6 @@
---- gcc/configure.in.orig Mon Sep 20 02:59:33 1999
-+++ gcc/configure.in Sat Sep 25 10:56:01 1999
-@@ -634,6 +634,15 @@
+--- gcc/configure.in.orig Wed Dec 8 04:30:22 1999
++++ gcc/configure.in Fri Dec 10 09:44:08 1999
+@@ -626,6 +626,22 @@
thread_file='posix'
fi
;;
@@ -11,42 +11,45 @@
+ tmake_file="t-freebsd alpha/t-crtbe"
+ xmake_file=none
+ fixincludes=fixinc.wrap
-+ gas=yes gnu_ld=yes
++ gas=yes
++ gnu_ld=yes
++ case x${enable_threads} in
++ xyes | xpthreads | xposix)
++ thread_file='posix'
++ tmake_file="${tmake_file} t-freebsd-thread"
++ ;;
++ esac
+ ;;
alpha*-*-netbsd*)
tm_file="${tm_file} alpha/elf.h alpha/netbsd.h alpha/netbsd-elf.h"
target_cpu_default="MASK_GAS"
-@@ -1274,9 +1283,15 @@
+@@ -1271,9 +1287,15 @@
# use_collect2=yes
;;
changequote(,)dnl
- i[34567]86-*-freebsdelf*)
+ i[34567]86-*-freebsd[12].* | i[34567]86-*-freebsd[12] | i[34567]86-*-freebsdaout* | i[34567]86-*-freebsd-aout*)
-+changequote([,])dnl
-+ tm_file=i386/freebsd-aout.h
+ changequote([,])dnl
+- tm_file="i386/i386.h i386/att.h svr4.h freebsd.h i386/freebsd-elf.h i386/perform.h"
++ tm_file="freebsd.h i386/freebsd-aout.h"
+ tmake_file=t-freebsd
+ ;;
+changequote(,)dnl
+ i[34567]86-*-freebsd[3-9].* | i[34567]86-*-freebsd[3-9] | i[34567]86-*-freebsd* | i[34567]86-*-freebsdelf* | i[34567]86-*-freebsd*)
- changequote([,])dnl
-- tm_file="i386/i386.h i386/att.h svr4.h i386/freebsd-elf.h i386/perform.h"
++ changequote([,])dnl
+ tm_file="i386/i386.h i386/att.h svr4.h freebsd.h i386/freebsd.h i386/perform.h"
extra_parts="crtbegin.o crtbeginS.o crtend.o crtendS.o"
tmake_file=t-freebsd
gas=yes
-@@ -1285,15 +1300,9 @@
- case x${enable_threads} in
- xyes | xpthreads | xposix)
- thread_file='posix'
-- tmake_file="${tmake_file} t-openbsd-thread"
-+ tmake_file="${tmake_file} t-freebsd-thread"
+@@ -1285,12 +1307,6 @@
+ tmake_file="${tmake_file} t-freebsd-thread"
;;
esac
- ;;
-changequote(,)dnl
- i[34567]86-*-freebsd*)
-changequote([,])dnl
-- tm_file=i386/freebsd.h
+- tm_file="i386/freebsd.h i386/perform.h"
- tmake_file=t-freebsd
;;
changequote(,)dnl
diff --git a/lang/gcc41/files/patch-ar b/lang/gcc41/files/patch-ar
new file mode 100644
index 000000000000..f2200f115da8
--- /dev/null
+++ b/lang/gcc41/files/patch-ar
@@ -0,0 +1,29 @@
+--- gcc/config/freebsd.h.orig Mon Nov 22 22:17:32 1999
++++ gcc/config/freebsd.h Sat Dec 18 14:42:03 1999
+@@ -48,13 +48,23 @@
+ #undef WORD_SWITCH_TAKES_ARG
+ #define WORD_SWITCH_TAKES_ARG(STR) (FBSD_WORD_SWITCH_TAKES_ARG(STR))
+
++/* Place spaces around this string. We depend on string splicing to produce
++ the final CPP_PREDEFINES value. */
++#define CPP_FBSD_PREDEFINES " -Dunix -D__FreeBSD__ -Asystem(unix) -Asystem(FreeBSD) "
++
+ /* Provide a CPP_SPEC appropriate for FreeBSD. We just deal with the GCC
+ option `-posix', and PIC issues. */
+
+-#undef CPP_SPEC
+-#define CPP_SPEC "%(cpp_cpu) \
++#define FBSD_CPP_SPEC " \
++ %(cpp_cpu) \
+ %{fPIC:-D__PIC__ -D__pic__} %{fpic:-D__PIC__ -D__pic__} \
+- %{posix:-D_POSIX_SOURCE}"
++ %{posix:-D_POSIX_SOURCE} \
++ %{!maout: -D__ELF__} \
++ %{munderscores: -D__UNDERSCORES__} \
++ %{maout: %{!mno-underscores: -D__UNDERSCORES__}}"
++
++#undef CPP_SPEC
++#define CPP_SPEC FBSD_CPP_SPEC
+
+ /* Provide a LIB_SPEC appropriate for FreeBSD. Just select the appropriate
+ libc, depending on whether we're doing profiling or need threads support.