aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc42-withgcjawt
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2006-07-21 21:05:41 +0000
committerMaho Nakata <maho@FreeBSD.org>2006-07-21 21:05:41 +0000
commit7556ce58aebad0a281cc18df6df65571ed79bf75 (patch)
tree8c5266f40f292326fb9d810155817dfa502a283d /lang/gcc42-withgcjawt
parent3a962d6f4702bbc7b783f96dd7d58e213a1da246 (diff)
downloadports-7556ce58aebad0a281cc18df6df65571ed79bf75.tar.gz
ports-7556ce58aebad0a281cc18df6df65571ed79bf75.zip
Notes
Diffstat (limited to 'lang/gcc42-withgcjawt')
-rw-r--r--lang/gcc42-withgcjawt/Makefile8
-rw-r--r--lang/gcc42-withgcjawt/files/patch-configure65
2 files changed, 73 insertions, 0 deletions
diff --git a/lang/gcc42-withgcjawt/Makefile b/lang/gcc42-withgcjawt/Makefile
index 35d88224a21a..b158c61900d0 100644
--- a/lang/gcc42-withgcjawt/Makefile
+++ b/lang/gcc42-withgcjawt/Makefile
@@ -16,4 +16,12 @@ DESCR= ${.CURDIR}/pkg-descr
WITH_JAVA_AWT= yes
+#weird libtool issue http://gcc.gnu.org/bugzilla/show_bug.cgi?id=28442
+EXTRA_PATCHES+= ${.CURDIR}/files/patch-configure
+USE_AUTOTOOLS= libtool:15
+
+pre-build:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${SRCDIR}/libjava/configure
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${SRCDIR}/libjava/classpath/configure
+
.include "${MASTERDIR}/Makefile"
diff --git a/lang/gcc42-withgcjawt/files/patch-configure b/lang/gcc42-withgcjawt/files/patch-configure
new file mode 100644
index 000000000000..74b10d9d3628
--- /dev/null
+++ b/lang/gcc42-withgcjawt/files/patch-configure
@@ -0,0 +1,65 @@
+Real tweaks for http://gcc.gnu.org/bugzilla/show_bug.cgi?id=28442
+never be upstreamed. correct solution might be upgrading libtool(?)
+
+--- libjava/configure.orig Sat Jul 15 07:34:33 2006
++++ libjava/configure Fri Jul 21 16:37:48 2006
+@@ -5867,6 +5867,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh $ac_aux_dir/ltcf-c.sh"
++cp %%LOCALBASE%%/bin/libtool .
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+--- libjava/classpath/configure~ Wed Jun 14 22:46:33 2006
++++ libjava/classpath/configure Fri Jul 21 16:38:43 2006
+@@ -5449,6 +5449,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltconfig $ac_aux_dir/ltmain.sh $ac_aux_dir/ltcf-c.sh"
++cp %%LOCALBASE%%/bin/libtool .
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+
+--- ltconfig~ Wed Jul 5 05:30:34 2006
++++ ltconfig Fri Jul 21 19:59:52 2006
+@@ -2236,7 +2236,7 @@
+ EOF
+ else
+ echo "appending configuration tag \"$tagname\" to $ofile"
+- echo "### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
++ echo "# ### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
+ fi
+ cfgfile="$ofile"
+ ;;
+@@ -2266,7 +2266,7 @@
+ EOF
+ else
+ echo "appending to $cfgfile"
+- echo "### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
++ echo "# ### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
+ fi
+ ;;
+ esac
+--- libjava/classpath/ltconfig~ Wed Jul 5 05:30:34 2006
++++ libjava/classpath/ltconfig Fri Jul 21 20:00:44 2006
+@@ -2236,7 +2236,7 @@
+ EOF
+ else
+ echo "appending configuration tag \"$tagname\" to $ofile"
+- echo "### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
++ echo "# ### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
+ fi
+ cfgfile="$ofile"
+ ;;
+@@ -2266,7 +2266,7 @@
+ EOF
+ else
+ echo "appending to $cfgfile"
+- echo "### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
++ echo "# ### BEGIN LIBTOOL TAG CONFIG: $tagname" >> "$ofile"
+ fi
+ ;;
+ esac
+