aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc42
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2007-04-10 22:15:05 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2007-04-10 22:15:05 +0000
commit4e5abb02f5bfb9b85a158d706a0329e7660bef36 (patch)
tree89f4bb5ec638de200c7a9010df9b0f70b6f8a943 /lang/gcc42
parent9b6107a66cd2052e6a73404591c7014f9d416e5b (diff)
Move everything related to the WITH_JAVA_AWT knob into a single block
and make this a subset of the general Java-specific section.[1] Submitted by: alepulver[1]
Notes
Notes: svn path=/head/; revision=189726
Diffstat (limited to 'lang/gcc42')
-rw-r--r--lang/gcc42/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index ee71600ab975..9552b9d7de59 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -24,9 +24,6 @@ COMMENT?= GNU Compiler Collection 4.2
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4 \
mpfr.1:${PORTSDIR}/math/mpfr
-.if defined(WITH_JAVA_AWT)
-LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
-.endif
SUFFIX= 42
LATEST_LINK?= gcc${SUFFIX}${PKGNAMESUFFIX}
@@ -36,9 +33,6 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_PERL5_BUILD=yes
-.if defined(WITH_JAVA_AWT)
-USE_GNOME= gtk20 libartlgpl2
-.endif
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
@@ -46,10 +40,6 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502102
-CONFIGURE_ARGS+= --disable-libgomp
-.endif
-
.if ${ARCH} != i386
WITHOUT_JAVA= yes
.endif
@@ -60,6 +50,10 @@ CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
+.if ${OSVERSION} < 502102
+CONFIGURE_ARGS+= --disable-libgomp
+.endif
+
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
TARGLIB= ${PREFIX}/lib/gcc-${PORTVERSION}
@@ -72,10 +66,6 @@ CONFIGURE_ARGS+= --disable-nls \
--libdir=${TARGLIB} \
--with-gxx-include-dir=${TARGLIB}/include/c++/ \
--infodir=${PREFIX}/${INFO_PATH}/gcc${SUFFIX}
-.if defined(WITH_JAVA_AWT)
-CONFIGURE_ARGS+= --enable-java-awt=gtk,xlib \
- --enable-gtk-cairo
-.endif
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}
@@ -121,6 +111,14 @@ PLIST_SUB+= JAVA=""
.else
CONFIGURE_ARGS+=--disable-libgcj
PLIST_SUB+= JAVA="@comment "
+
+.if defined(WITH_JAVA_AWT)
+LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
+USE_GNOME= gtk20 libartlgpl2
+CONFIGURE_ARGS+= --enable-java-awt=gtk,xlib \
+ --enable-gtk-cairo
+.endif
+
.endif
pre-everything::