aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc45/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2005-03-02 08:46:01 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2005-03-02 08:46:01 +0000
commitcc7e4202b5af0d0b836f99a134f4f209a40be2a0 (patch)
treee80b6674f9da871a14321a1064053d7a9e47e8ca /lang/gcc45/Makefile
parent046adb5f9a1a12523585ce7fbc8dd737e7cdc7c2 (diff)
downloadports-cc7e4202b5af0d0b836f99a134f4f209a40be2a0.tar.gz
ports-cc7e4202b5af0d0b836f99a134f4f209a40be2a0.zip
Notes
Diffstat (limited to 'lang/gcc45/Makefile')
-rw-r--r--lang/gcc45/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index 544b78565bed..e4e3d62eb9aa 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -22,11 +22,16 @@ DISTFILES= \
.if defined(WITH_FORTRAN)
DISTFILES+= gcc-fortran-${VERSIONSTRING}${EXTRACT_SUFX}
.endif
+
MAINTAINER?= gerald@FreeBSD.org
COMMENT?= GNU Compiler Collection 4.0
LATEST_LINK?= gcc40${PKGNAMESUFFIX}
+.if defined(WITH_FORTRAN)
+LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
+.endif
+
USE_BISON= yes
USE_BZIP2= yes
USE_GMAKE= yes
@@ -61,6 +66,9 @@ CONFIGURE_ARGS= --disable-nls \
--with-libiconv-prefix=${LOCALBASE} \
--program-suffix=${SUFFIX} \
--with-gxx-include-dir=${TARGLIB}/include/c++/
+.if defined(WITH_FORTRAN)
+CONFIGURE_ARGS+= --with-gmp=${LOCALBASE}
+.endif
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
.if defined(WANT_SHAREDLIBS)
CONFIGURE_ARGS+= --enable-shared
@@ -99,8 +107,6 @@ PLIST_SUB+= LIBJAVA=""
.endif
.if defined(WITH_FORTRAN)
-LIB_DEPENDS+= gmp.6:${PORTSDIR}/math/libgmp4
-CONFIGURE_ARGS+= --with-gmp=${LOCALBASE}
MAN1+= gfortran${SUFFIX}.1
INFO+= gfortran
PLIST_SUB+= FORTRAN=""