aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc48
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2017-04-30 21:40:23 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2017-04-30 21:40:23 +0000
commitb45d26c4d2398de422d0df637c467c46ca5ec637 (patch)
tree81acf2e2bb14aacd95a520337d4797ece9527e3a /lang/gcc48
parent5e42698490321b5b437ca2d877e2342c425984b0 (diff)
Notes
Diffstat (limited to 'lang/gcc48')
-rw-r--r--lang/gcc48/Makefile9
-rw-r--r--lang/gcc48/files/patch-unwind-ia64.h21
2 files changed, 3 insertions, 27 deletions
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index f8a6b7b61a64..7ca0a9b3ecca 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -107,12 +107,9 @@ INFO= gcc${SUFFIX}/cpp \
gcc${SUFFIX}/gccinstall \
gcc${SUFFIX}/gccint \
gcc${SUFFIX}/gfortran \
- gcc${SUFFIX}/libgomp
-# Release tarballs (as opposed to snapshots) always carry this.
-#.if ${ARCH} == "i386" || ${ARCH} == "amd64"
-INFO+= gcc${SUFFIX}/libquadmath \
- gcc${SUFFIX}/libitm
-#.endif
+ gcc${SUFFIX}/libgomp \
+ gcc${SUFFIX}/libitm \
+ gcc${SUFFIX}/libquadmath
SUB_FILES= pkg-message
SUB_LIST+= TARGLIB=${TARGLIB}
diff --git a/lang/gcc48/files/patch-unwind-ia64.h b/lang/gcc48/files/patch-unwind-ia64.h
deleted file mode 100644
index 82e103a543c5..000000000000
--- a/lang/gcc48/files/patch-unwind-ia64.h
+++ /dev/null
@@ -1,21 +0,0 @@
-2012-12-17 Gerald Pfeifer <gerald@pfeifer.com>
- Anton Shterenlikht <mexas@bristol.ac.uk>
-
- PR target/45650
- * config/ia64/unwind-ia64.h: Do not mark _Unwind_FindTableEntry
- hidden on FreeBSD.
-
---- UTC
-Index: libgcc/config/ia64/unwind-ia64.h
-===================================================================
---- libgcc/config/ia64/unwind-ia64.h
-+++ libgcc/config/ia64/unwind-ia64.h (working copy)
-@@ -49,4 +49,7 @@
- extern struct unw_table_entry *
- _Unwind_FindTableEntry (void *pc, unw_word *segment_base,
- unw_word *gp, struct unw_table_entry *ent)
-- __attribute__ ((__visibility__ ("hidden")));
-+#ifndef __FreeBSD__
-+ __attribute__ ((__visibility__ ("hidden")))
-+#endif
-+ ;