aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2005-09-02 09:31:27 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2005-09-02 09:31:27 +0000
commit28a08b18987dfa3848a777a46a25d5e9266c755b (patch)
treed1260b0a560978b2329424a59a6150838105c5ba /lang/gcc
parent9f3c01ce561c6d654ad0dc5eaf0a781f1938157b (diff)
Reenable the Java frontend and libgcj on i386. All build and installation
problems should be resolved now. Prevent running ranlib during installation to unbreak user mode installations which now install libraries with permissions 444. We now also need the math/mpfr port to build the Fortran frontend.[1] PR: 85495 [1]
Notes
Notes: svn path=/head/; revision=141773
Diffstat (limited to 'lang/gcc')
-rw-r--r--lang/gcc/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index d51a585f28c9..fbe48fe24c4b 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -23,6 +23,7 @@ COMMENT= GNU Compiler Collection 4.1
.if defined(WITH_FORTRAN)
LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
+BUILD_DEPENDS= ${LOCALBASE}/lib/libmpfr.a:${PORTSDIR}/math/mpfr
.endif
CONFLICTS= gcc-3.3.* gcc-3.4.* gcc-4.0.*
@@ -44,7 +45,7 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
-.if ${ARCH} == i386 || ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64
+.if ${ARCH} == amd64 || ${ARCH} == ia64 || ${ARCH} == sparc64
WITHOUT_JAVA= yes
.endif
@@ -65,6 +66,7 @@ CONFIGURE_ARGS+= --disable-nls \
--program-suffix=${SUFFIX} \
--libdir=${TARGLIB} \
--with-gxx-include-dir=${TARGLIB}/include/c++/
+CONFIGURE_ENV= RANLIB=:
.if defined(WITH_JAVA_AWT)
CONFIGURE_ARGS+= --enable-java-awt=xlib,gtk #--enable-gtk-cairo=yes
WANT_SHAREDLIBS=yes # We need this at the moment.