aboutsummaryrefslogtreecommitdiff
path: root/lang/gcc
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-09-12 10:20:45 +0000
committerJohn Marino <marino@FreeBSD.org>2013-09-12 10:20:45 +0000
commit9518965c2157ea68db1e58608deac0c3d7463bbb (patch)
treeb6fffa3aa1ee2f77abdf2d48d58eed882094f1fb /lang/gcc
parentf9930ebbb6d1ae9c5cf31381cd4d62946960c642 (diff)
lang/gcc*: define CONFIGURE_TARGET genericly (8 ports)
Instead of hardcoding the compiler target as FreeBSD, use the OPSYS variable to it. This makes no practical difference for FreeBSD, but it helps DragonFly get properly configured. Approved by: gerald
Notes
Notes: svn path=/head/; revision=327052
Diffstat (limited to 'lang/gcc')
-rw-r--r--lang/gcc/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 67e1d866a8c9..6659120e34f0 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -46,9 +46,9 @@ BOOTSTRAP_DESC= Build using a full bootstrap
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= x86_64-portbld-${OPSYS:L}${OSREL}
.else
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= ${ARCH}-portbld-${OPSYS:L}${OSREL}
.endif
LANGUAGES:= c,c++,objc,fortran