aboutsummaryrefslogtreecommitdiff
path: root/lang/gcl/Makefile
diff options
context:
space:
mode:
authorMark Murray <markm@FreeBSD.org>2004-08-18 18:33:58 +0000
committerMark Murray <markm@FreeBSD.org>2004-08-18 18:33:58 +0000
commita9be257d9ba450f402a60e92a10413c9eb3479e3 (patch)
tree8e2004b31624fb4d5386d51043316a6b81d42cc8 /lang/gcl/Makefile
parent03747ec11bb1a73543383ee66a1991c5cb6be869 (diff)
downloadports-a9be257d9ba450f402a60e92a10413c9eb3479e3.tar.gz
ports-a9be257d9ba450f402a60e92a10413c9eb3479e3.zip
Notes
Diffstat (limited to 'lang/gcl/Makefile')
-rw-r--r--lang/gcl/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/lang/gcl/Makefile b/lang/gcl/Makefile
index 2efcc8d63a77..449082943d23 100644
--- a/lang/gcl/Makefile
+++ b/lang/gcl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gcl
-PORTVERSION= 2.6.3
+PORTVERSION= 2.6.5
CATEGORIES= lang tcl84 tk84
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gcl
@@ -36,9 +36,10 @@ CONFIGURE_ARGS=--prefix=${PREFIX} \
--disable-statsysbfd \
--disable-locbfd \
--enable-custreloc
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" C_INCLUDE_PATH=${PREFIX}/include LIBRARY_PATH=${PREFIX}/lib
MAKEFILE= makefile
-INFO= gcl gcl-si gcl-tk
+INFO= gcl-si gcl-tk
PLIST_SUB= GCL_VER=${PORTVERSION}
@@ -48,7 +49,7 @@ pre-configure:
${RM} -f ${WRKSRC}/configure
${SED} -i '' \
-e 's|@@CFLAGS@@|${CFLAGS} -I${LOCALBASE}/include|' \
- -e 's|@@LOCALLIBS@@|-L${LOCALBASE}/lib -lm -lreadline|' \
+ -e 's|@@LOCALLIBS@@|-L${LOCALBASE}/lib -lgmp -lm -lreadline|' \
${WRKSRC}/h/FreeBSD.defs
.include <bsd.port.post.mk>