aboutsummaryrefslogtreecommitdiff
path: root/lang/gforth
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-05-04 14:13:34 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-05-04 14:13:34 +0000
commit7d121368784ad703288218627e2a1b9f5ab3eed1 (patch)
tree786f202e40037a6fe4639e9bce02d6335a8e9262 /lang/gforth
parent63f76304d6f21c191cb8e08ab49787bcf031fb6d (diff)
downloadports-7d121368784ad703288218627e2a1b9f5ab3eed1.tar.gz
ports-7d121368784ad703288218627e2a1b9f5ab3eed1.zip
Notes
Diffstat (limited to 'lang/gforth')
-rw-r--r--lang/gforth/Makefile28
-rw-r--r--lang/gforth/distinfo4
-rw-r--r--lang/gforth/pkg-plist2
3 files changed, 15 insertions, 19 deletions
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index 5d5556c76a1f..6488c7ff770a 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -1,15 +1,11 @@
-# New ports collection makefile for: gforth
-# Date created: 12 October 2000
-# Whom: Cyrille Lefevre <clefevre@citeweb.net>
-#
+# Created by: Cyrille Lefevre <clefevre@citeweb.net>
# $FreeBSD$
-#
PORTNAME= gforth
-PORTVERSION= 0.7.0
+PORTVERSION= 0.7.2
CATEGORIES= lang
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= gforth
+MASTER_SITES= http://www.complang.tuwien.ac.at/forth/gforth/ \
+ GNU
MAINTAINER= johans@FreeBSD.org
COMMENT= Fast and portable Forth system
@@ -22,6 +18,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -fno-reorder-blocks -fno-inline
USE_GMAKE= yes
+USE_GCC= any
USE_AUTOTOOLS= libtool libltdl
USE_LDCONFIG= ${PREFIX}/lib/gforth/${PORTVERSION}/libcc-named
ALL_TARGET= kernel/version.fs more info
@@ -29,26 +26,25 @@ MAKE_JOBS_UNSAFE=yes
STRIP= #none
-PLIST_SUB= PORTVERSION="${PORTVERSION}" \
+PLIST_SUB= PORTVERSION=${PORTVERSION} \
WORDSIZE=${WORDSIZE} BYTEORDER=${BYTEORDER}
-DOC_FILES= AUTHORS BUGS Benchres COPYING COPYING.DOC \
+PORTDOCS= AUTHORS BUGS Benchres COPYING COPYING.DOC \
INSTALL INSTALL.BINDIST NEWS README \
NEWS.vmgen README.vmgen ToDo
MAN1= gforth.1
INFO= gforth vmgen
-PORTDOCS= *
.include <bsd.port.pre.mk>
-.if ${ARCH} == i386 || ${ARCH} == "powerpc"
+.if ${ARCH} == i386 || ${ARCH} == powerpc
WORDSIZE=32
.else
WORDSIZE=64
.endif
-.if ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+.if ${ARCH} == powerpc || ${ARCH} == sparc64
BYTEORDER=b
.else
BYTEORDER=l
@@ -62,11 +58,11 @@ post-patch:
post-install: install-doc remove-empty-files remove-empty-dirs
install-doc:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
-.for filename in ${DOC_FILES}
+. for filename in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${filename} ${DOCSDIR}
-.endfor
+. endfor
.endif
# Remove unused file
diff --git a/lang/gforth/distinfo b/lang/gforth/distinfo
index 382dc74a02b5..35ffb93bcf7b 100644
--- a/lang/gforth/distinfo
+++ b/lang/gforth/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gforth-0.7.0.tar.gz) = 4841e3d25329d5aa29876a641d1e681809719fa5de3982007ecaf74d8056fffe
-SIZE (gforth-0.7.0.tar.gz) = 2277918
+SHA256 (gforth-0.7.2.tar.gz) = 77db9071c2442da3215da361b71190bccb153f81f4d01e5e8bc2c2cf8ee81b48
+SIZE (gforth-0.7.2.tar.gz) = 2560467
diff --git a/lang/gforth/pkg-plist b/lang/gforth/pkg-plist
index 5cc8c7a44701..3d6b18457bc7 100644
--- a/lang/gforth/pkg-plist
+++ b/lang/gforth/pkg-plist
@@ -1,4 +1,3 @@
-@comment $FreeBSD$
bin/gforth-%%PORTVERSION%%
@exec ln -fs %f %B/gforth
@unexec rm -f %B/gforth
@@ -241,6 +240,7 @@ lib/gforth/%%PORTVERSION%%/libcc-named/fflib.a
%%DATADIR%%/%%PORTVERSION%%/xwords.fs
@exec mkdir -p %D/%%DATADIR%%/site-forth
@dirrm %%DATADIR%%/site-forth
+@dirrmtry %%DATADIR%%/%%PORTVERSION%%/vmgen-ex
@dirrm %%DATADIR%%/%%PORTVERSION%%/unix
@dirrm %%DATADIR%%/%%PORTVERSION%%/test
@dirrm %%DATADIR%%/%%PORTVERSION%%/kernel