aboutsummaryrefslogtreecommitdiff
path: root/lang/gforth
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-10-21 13:08:53 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-10-21 13:08:53 +0000
commitd6c0680bfcf946b8131e01edf8a9685348e3b44d (patch)
tree8d680fdc190dd11c66437dac28b6fa161afc6be0 /lang/gforth
parent090fb2511992f4513eea577f1c1abf28d64295ea (diff)
downloadports-d6c0680bfcf946b8131e01edf8a9685348e3b44d.tar.gz
ports-d6c0680bfcf946b8131e01edf8a9685348e3b44d.zip
Notes
Diffstat (limited to 'lang/gforth')
-rw-r--r--lang/gforth/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index b2a581ccf1f4..f981ed97aed5 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -7,16 +7,18 @@
PORTNAME= gforth
PORTVERSION= 0.6.2
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gforth
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= Fast and portable Forth system
-STRIP= #none
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS=${CFLAGS:N-O*:N-f*}
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
USE_GMAKE= yes
ALL_TARGET= all info
USE_GNOME= gnometarget
@@ -25,6 +27,9 @@ EMACS_PORT_NAME?= emacs22
EMACS_NO_BUILD_DEPENDS= yes
EMACS_NO_RUN_DEPENDS= yes
+CFLAGS+= -fno-reorder-blocks -fno-inline
+STRIP= #none
+
PLIST_SUB= PORTVERSION="${PORTVERSION}" \
EMACS_DIR="${EMACS_SITE_LISPDIR}" \
WORDSIZE=${WORDSIZE} BYTEORDER=${BYTEORDER}
@@ -39,10 +44,6 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-BROKEN= does not build on pointyhat, report if you have similar problems
-.endif
-
.if ${ARCH} == i386
WORDSIZE=32
.else