aboutsummaryrefslogtreecommitdiff
path: root/lang/ghc/Makefile
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2008-02-22 12:00:59 +0000
committerOliver Braun <obraun@FreeBSD.org>2008-02-22 12:00:59 +0000
commita389a0d2e46de9b2a355eea6ff19b11ea9da9b8c (patch)
treec0ef0eceb1713e9ec0cf22c221d9bb714801b691 /lang/ghc/Makefile
parentc45a5502eaedb61eac16d4bce7684812fb00687b (diff)
downloadports-a389a0d2e46de9b2a355eea6ff19b11ea9da9b8c.tar.gz
ports-a389a0d2e46de9b2a355eea6ff19b11ea9da9b8c.zip
Notes
Diffstat (limited to 'lang/ghc/Makefile')
-rw-r--r--lang/ghc/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 3965a9858513..bedc84953cf2 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -16,10 +16,7 @@ DISTFILES= ghc-${PORTVERSION}-src${EXTRACT_SUFX}:source \
MAINTAINER= haskell@FreeBSD.org
COMMENT= A Compiler for the functional language Haskell
-ONLY_FOR_ARCHS= i386
-
-BOOT_DIST6= ghc-${PORTVERSION}-i386-unknown-freebsd6-boot${EXTRACT_SUFX}:boot
-BOOT_DIST7= ghc-${PORTVERSION}-i386-unknown-freebsd7-boot${EXTRACT_SUFX}:boot
+ONLY_FOR_ARCHS= i386 amd64
USE_AUTOTOOLS= autoconf:261:env
USE_BZIP2= yes
@@ -37,13 +34,22 @@ OPTIONS= PROFILE "Compile for profiling as well" on
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
+.if ${ARCH} == "i386"
.if ${OSVERSION} >= 700000
-DISTFILES+= ${BOOT_DIST7}
+DISTFILES+= ghc-${PORTVERSION}-i386-unknown-freebsd7-boot${EXTRACT_SUFX}:boot
.elif ${OSVERSION} >= 600000
-DISTFILES+= ${BOOT_DIST6}
+DISTFILES+= ghc-${PORTVERSION}-i386-unknown-freebsd6-boot${EXTRACT_SUFX}:boot
+.else
+IGNORE= unsupported at the moment
+.endif
+.endif
+
+.if ${ARCH} == "amd64"
+.if ${OSVERSION} >= 700000
+DISTFILES+= ghc-${PORTVERSION}-x86_64-unknown-freebsd7-boot${EXTRACT_SUFX}:boot
.else
IGNORE= unsupported at the moment
-#DISTFILES+= ${BOOT_DIST5}
+.endif
.endif
PLIST_SUB+= GHC_VERSION=${PORTVERSION}