aboutsummaryrefslogtreecommitdiff
path: root/lang/ghc/files
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2013-06-04 18:53:40 +0000
committerGabor Pali <pgj@FreeBSD.org>2013-06-04 18:53:40 +0000
commit109269205e521bb1d2d87678a391e5adefff88d6 (patch)
tree93f1f9278a9a48902904b7ff4a5ce711c10efe08 /lang/ghc/files
parentad7295cafd0e46ece6fcbf594ef39a767c296d0e (diff)
Notes
Diffstat (limited to 'lang/ghc/files')
-rw-r--r--lang/ghc/files/patch-aclocal.m419
-rw-r--r--lang/ghc/files/patch-compiler-main-Dynflags.hs11
-rw-r--r--lang/ghc/files/patch-configure.ac16
-rw-r--r--lang/ghc/files/patch-ghc.mk14
-rw-r--r--lang/ghc/files/patch-libraries-gen_contents_index10
-rw-r--r--lang/ghc/files/patch-libraries__base__GHC__Event__KQueue.hsc18
6 files changed, 54 insertions, 34 deletions
diff --git a/lang/ghc/files/patch-aclocal.m4 b/lang/ghc/files/patch-aclocal.m4
index f288e6b77221..48c040f74504 100644
--- a/lang/ghc/files/patch-aclocal.m4
+++ b/lang/ghc/files/patch-aclocal.m4
@@ -1,5 +1,5 @@
---- aclocal.m4.orig 2012-06-06 19:10:25.000000000 +0200
-+++ aclocal.m4 2013-02-03 01:28:58.024638318 +0100
+--- aclocal.m4.orig 2013-04-18 23:22:46.000000000 +0200
++++ aclocal.m4 2013-04-29 20:32:30.000000000 +0200
@@ -19,6 +19,8 @@
# In bindists, we haven't called AC_CANONICAL_{BUILD,HOST,TARGET}
# so this justs uses $bootstrap_target.
@@ -15,10 +15,10 @@
;;
- x86_64)
+ x86_64|amd64)
- GET_ARM_ISA()
test -z "[$]2" || eval "[$]2=ArchX86_64"
;;
-@@ -186,7 +188,7 @@
+ powerpc)
+@@ -185,7 +187,7 @@
checkVendor() {
case [$]1 in
@@ -27,7 +27,7 @@
;;
*)
echo "Unknown vendor [$]1"
-@@ -1835,7 +1837,7 @@
+@@ -1889,7 +1891,7 @@
vax)
$2="vax"
;;
@@ -36,12 +36,3 @@
$2="x86_64"
;;
*)
-@@ -1875,7 +1877,7 @@
- freebsd|netbsd|openbsd|dragonfly|osf1|osf3|hpux|linuxaout|kfreebsdgnu|freebsd2|solaris2|cygwin32|mingw32|darwin|gnu|nextstep2|nextstep3|sunos4|ultrix|irix|aix|haiku)
- $2="$1"
- ;;
-- freebsd8) # like i686-gentoo-freebsd8
-+ freebsd*) # like i686-gentoo-freebsd8
- $2="freebsd"
- ;;
- *)
diff --git a/lang/ghc/files/patch-compiler-main-Dynflags.hs b/lang/ghc/files/patch-compiler-main-Dynflags.hs
new file mode 100644
index 000000000000..ee76c6da2988
--- /dev/null
+++ b/lang/ghc/files/patch-compiler-main-Dynflags.hs
@@ -0,0 +1,11 @@
+--- compiler/main/DynFlags.hs.orig 2012-06-06 19:10:25.000000000 +0200
++++ compiler/main/DynFlags.hs 2013-02-08 15:23:36.000000000 +0100
+@@ -2390,7 +2390,7 @@
+ flag)
+ return dflags
+ HscLlvm
+- | not ((arch == ArchX86_64) && (os == OSLinux || os == OSDarwin)) &&
++ | not ((arch == ArchX86_64) && (os == OSLinux || os == OSDarwin || os == OSFreeBSD)) &&
+ (not opt_Static || opt_PIC)
+ ->
+ do addWarn ("Ignoring " ++ flag ++ " as it is incompatible with -fPIC and -dynamic on this platform")
diff --git a/lang/ghc/files/patch-configure.ac b/lang/ghc/files/patch-configure.ac
index 11139a3aa71d..e7504949abce 100644
--- a/lang/ghc/files/patch-configure.ac
+++ b/lang/ghc/files/patch-configure.ac
@@ -1,5 +1,5 @@
---- configure.ac.orig 2012-06-06 19:10:25.000000000 +0200
-+++ configure.ac 2013-02-02 17:31:55.193634655 +0100
+--- ./configure.ac.orig 2013-04-19 00:31:00.000000000 +0200
++++ ./configure.ac 2013-04-30 19:30:40.381161098 +0200
@@ -89,6 +89,59 @@
fi
WithGhc="$GHC"])
@@ -60,7 +60,17 @@
dnl ** Tell the make system which OS we are using
dnl $OSTYPE is set by the operating system to "msys" or "cygwin" or something
-@@ -717,7 +770,6 @@
+@@ -379,6 +432,9 @@
+ BuildingCrossCompiler=NO
+ PortingCompiler=NO
+ CrossCompiling=NO
++
++build=`echo $build | sed -e 's/amd64-/x86_64-/g; s/-freebsd.*$/-freebsd/g'`
++
+ # If 'host' and 'target' differ, then this means we are building a cross-compiler.
+ if test "$host" != "$target" ; then
+ BuildingCrossCompiler=YES
+@@ -839,7 +895,6 @@
FP_VISIBILITY_HIDDEN
dnl ** check for librt
diff --git a/lang/ghc/files/patch-ghc.mk b/lang/ghc/files/patch-ghc.mk
index 81f97ee717ea..a8e806b6e47c 100644
--- a/lang/ghc/files/patch-ghc.mk
+++ b/lang/ghc/files/patch-ghc.mk
@@ -1,6 +1,6 @@
---- ghc.mk.orig 2012-06-06 19:10:25.000000000 +0200
-+++ ghc.mk 2013-01-30 16:24:02.000000000 +0100
-@@ -81,6 +81,7 @@
+--- ghc.mk.orig 2013-04-18 23:22:46.000000000 +0200
++++ ghc.mk 2013-04-29 20:42:16.000000000 +0200
+@@ -80,6 +80,7 @@
# Catch make if it runs away into an infinite loop
ifeq "$(MAKE_RESTARTS)" ""
else ifeq "$(MAKE_RESTARTS)" "1"
@@ -8,8 +8,8 @@
else
$(error Make has restarted itself $(MAKE_RESTARTS) times; is there a makefile bug?)
endif
-@@ -574,12 +575,18 @@
- $(GHC_GENPRIMOP_DIR)
+@@ -595,12 +596,18 @@
+ MAYBE_GHCI=driver/ghci
endif
+ifeq "$(UseSystemLibFFI)" "YES"
@@ -20,7 +20,7 @@
+
BUILD_DIRS += \
driver \
- driver/ghci \
+ $(MAYBE_GHCI) \
driver/ghc \
driver/haddock \
- libffi \
@@ -28,7 +28,7 @@
includes \
rts
-@@ -971,6 +978,7 @@
+@@ -1005,6 +1012,7 @@
echo "BUILD_DOCBOOK_PDF = $(BUILD_DOCBOOK_PDF)" >> $(BIN_DIST_MK)
echo "BUILD_MAN = $(BUILD_MAN)" >> $(BIN_DIST_MK)
echo "GHC_CABAL_INPLACE = utils/ghc-cabal/dist-install/build/tmp/ghc-cabal" >> $(BIN_DIST_MK)
diff --git a/lang/ghc/files/patch-libraries-gen_contents_index b/lang/ghc/files/patch-libraries-gen_contents_index
deleted file mode 100644
index a2785da02ed9..000000000000
--- a/lang/ghc/files/patch-libraries-gen_contents_index
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./libraries/gen_contents_index.orig 2012-02-01 19:10:32.000000000 +0100
-+++ ./libraries/gen_contents_index 2012-05-17 02:20:09.000000000 +0200
-@@ -47,7 +47,6 @@
- esac
-
- # Now create the combined contents and index pages
--echo $HADDOCK_ARGS
- $HADDOCK --gen-index --gen-contents -o . \
- -t "Haskell Hierarchical Libraries" \
- -p "prologue.txt" \
diff --git a/lang/ghc/files/patch-libraries__base__GHC__Event__KQueue.hsc b/lang/ghc/files/patch-libraries__base__GHC__Event__KQueue.hsc
new file mode 100644
index 000000000000..ffc1d3df082a
--- /dev/null
+++ b/lang/ghc/files/patch-libraries__base__GHC__Event__KQueue.hsc
@@ -0,0 +1,18 @@
+--- ./libraries/base/GHC/Event/KQueue.hsc.orig 2013-04-18 23:30:14.000000000 +0200
++++ ./libraries/base/GHC/Event/KQueue.hsc 2013-04-30 13:34:11.549185351 +0200
+@@ -235,10 +235,11 @@
+ #endif
+ deriving (Bits, Eq, Num, Show, Storable)
+
+-#{enum Filter, Filter
+- , filterRead = EVFILT_READ
+- , filterWrite = EVFILT_WRITE
+- }
++filterRead :: Filter
++filterRead = Filter (#const EVFILT_READ)
++
++filterWrite :: Filter
++filterWrite = Filter (#const EVFILT_WRITE)
+
+ data TimeSpec = TimeSpec {
+ tv_sec :: {-# UNPACK #-} !CTime