aboutsummaryrefslogtreecommitdiff
path: root/lang/ghc/files
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-06-03 20:52:29 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-06-03 20:52:29 +0000
commit46e9ab0ca5e504d3509678b4d43a41d938650e75 (patch)
treea34afe36b374e7894e236fb8cee020928d36c967 /lang/ghc/files
parentbe44ec14c77de91f8ac86e25372545e0e39e9bcb (diff)
Notes
Diffstat (limited to 'lang/ghc/files')
-rw-r--r--lang/ghc/files/patch-.._ghc-6.10.4-boot_configure23
-rw-r--r--lang/ghc/files/patch-.._ghc-7.4.1-boot_rts_package.conf.in (renamed from lang/ghc/files/patch-.._ghc-6.10.4-boot_rts_package.conf.in)4
-rw-r--r--lang/ghc/files/patch-compiler_ghc.mk13
-rw-r--r--lang/ghc/files/patch-compiler_main_DriverPipeline.hs17
-rw-r--r--lang/ghc/files/patch-configure231
-rw-r--r--lang/ghc/files/patch-libraries-gen_contents_index10
-rw-r--r--lang/ghc/files/patch-libraries_Cabal_Distribution_Simple_Haddock.hs14
-rw-r--r--lang/ghc/files/patch-libraries_Cabal_Distribution_Simple_LocalBuildInfo.hs25
-rw-r--r--lang/ghc/files/patch-mk_config.mk.in12
-rw-r--r--lang/ghc/files/patch-rts_package.conf.in2
10 files changed, 238 insertions, 113 deletions
diff --git a/lang/ghc/files/patch-.._ghc-6.10.4-boot_configure b/lang/ghc/files/patch-.._ghc-6.10.4-boot_configure
deleted file mode 100644
index 2d0ea9a6ad36..000000000000
--- a/lang/ghc/files/patch-.._ghc-6.10.4-boot_configure
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- ../ghc-6.10.4-boot/configure.orig
-+++ ../ghc-6.10.4-boot/configure
-@@ -1942,7 +1942,7 @@
- TargetPlatform=i386-unknown-linux;;
- i[3456]86-*-freebsd2*)
- TargetPlatform=i386-unknown-freebsd2;;
--i[3456]86-*-freebsd[3-9]*)
-+i[3456]86-*-freebsd*)
- TargetPlatform=i386-unknown-freebsd;;
- i[3456]86-*-netbsd*)
- TargetPlatform=i386-unknown-netbsd;;
-@@ -1989,6 +1989,8 @@
- TargetPlatform=x86_64-unknown-linux;;
- x86_64-*-freebsd*)
- TargetPlatform=x86_64-unknown-freebsd;;
-+amd64-*-freebsd*)
-+ TargetPlatform=x86_64-unknown-freebsd;;
- x86_64-*-openbsd*)
- TargetPlatform=x86_64-unknown-openbsd;;
- x86_64-*-netbsd*)
diff --git a/lang/ghc/files/patch-.._ghc-6.10.4-boot_rts_package.conf.in b/lang/ghc/files/patch-.._ghc-7.4.1-boot_rts_package.conf.in
index 428014e57ff5..7976302419f1 100644
--- a/lang/ghc/files/patch-.._ghc-6.10.4-boot_rts_package.conf.in
+++ b/lang/ghc/files/patch-.._ghc-7.4.1-boot_rts_package.conf.in
@@ -1,5 +1,5 @@
---- ../ghc-6.10.4-boot/rts/package.conf.in.orig 2009-07-14 19:10:52.000000000 +0200
-+++ ../ghc-6.10.4-boot/rts/package.conf.in 2009-08-13 22:09:35.000000000 +0200
+--- ../ghc-7.4.1-boot/rts/package.conf.in.orig 2009-07-14 19:10:52.000000000 +0200
++++ ../ghc-7.4.1-boot/rts/package.conf.in 2009-08-13 22:09:35.000000000 +0200
@@ -156,6 +156,8 @@
, "-u", "base_GHCziConc_ensureIOManagerIsRunning_closure"
#endif
diff --git a/lang/ghc/files/patch-compiler_ghc.mk b/lang/ghc/files/patch-compiler_ghc.mk
new file mode 100644
index 000000000000..ebd1dda64453
--- /dev/null
+++ b/lang/ghc/files/patch-compiler_ghc.mk
@@ -0,0 +1,13 @@
+--- ./compiler/ghc.mk.orig 2012-02-01 19:10:32.000000000 +0100
++++ ./compiler/ghc.mk 2012-05-17 11:32:41.868463028 +0200
+@@ -107,6 +107,10 @@
+ @echo 'cRAWCPP_FLAGS = "$(RAWCPP_FLAGS)"' >> $@
+ @echo 'cLdHasNoCompactUnwind :: String' >> $@
+ @echo 'cLdHasNoCompactUnwind = "$(LdHasNoCompactUnwind)"' >> $@
++ @echo 'cLdHashSize31 :: String' >> $@
++ @echo 'cLdHashSize31 = "$(LdHashSize31)"' >> $@
++ @echo 'cLdReduceMemoryOverheads :: String' >> $@
++ @echo 'cLdReduceMemoryOverheads = "$(LdReduceMemoryOverheads)"' >> $@
+ @echo 'cLdIsGNULd :: String' >> $@
+ @echo 'cLdIsGNULd = "$(LdIsGNULd)"' >> $@
+ @echo 'cLdHasBuildId :: String' >> $@
diff --git a/lang/ghc/files/patch-compiler_main_DriverPipeline.hs b/lang/ghc/files/patch-compiler_main_DriverPipeline.hs
new file mode 100644
index 000000000000..e6740df077ae
--- /dev/null
+++ b/lang/ghc/files/patch-compiler_main_DriverPipeline.hs
@@ -0,0 +1,17 @@
+--- ./compiler/main/DriverPipeline.hs.orig 2012-05-17 11:27:22.763461303 +0200
++++ ./compiler/main/DriverPipeline.hs 2012-05-17 11:27:00.427463463 +0200
+@@ -1753,6 +1753,14 @@
+ then ["-Wl,-no_compact_unwind"]
+ else [])
+
++ ++ (if cLdHashSize31 == "YES"
++ then ["-Wl,--hash-size=31"]
++ else [])
++
++ ++ (if cLdReduceMemoryOverheads == "YES"
++ then ["-Wl,--reduce-memory-overheads"]
++ else [])
++
+ -- '-Wl,-read_only_relocs,suppress'
+ -- ld gives loads of warnings like:
+ -- ld: warning: text reloc in _base_GHCziArr_unsafeArray_info to _base_GHCziArr_unsafeArray_closure
diff --git a/lang/ghc/files/patch-configure b/lang/ghc/files/patch-configure
index 18cd7e9742bc..038cefa7a9c9 100644
--- a/lang/ghc/files/patch-configure
+++ b/lang/ghc/files/patch-configure
@@ -1,65 +1,200 @@
-
-$FreeBSD$
-
---- configure.orig
-+++ configure
-@@ -3312,6 +3312,9 @@
+--- ./configure.orig 2012-02-01 19:11:45.000000000 +0100
++++ ./configure 2012-05-18 12:40:29.000000000 +0200
+@@ -608,6 +608,8 @@
+ HavePapiLib
+ GTK_CONFIG
+ LdHasNoCompactUnwind
++LdHashSize31
++LdReduceMemoryOverheads
+ LdHasBuildId
+ LdIsGNULd
+ LdXFlag
+@@ -3372,8 +3374,8 @@
vax)
BuildArch="vax"
;;
-+ amd64)
-+ BuildArch="x86_64"
-+ ;;
- x86_64)
- BuildArch="x86_64"
+- x86_64)
+- BuildArch="x86_64"
++ x86_64|amd64)
++ BuildArch="amd64"
;;
-@@ -3330,7 +3333,7 @@
- BuildOS="linux"
- ;;
- # As far as I'm aware, none of these have relevant variants
-- freebsd|netbsd|openbsd|dragonfly|osf1|osf3|hpux|linuxaout|kfreebsdgnu|freebsd2|solaris2|cygwin32|mingw32|darwin|gnu|nextstep2|nextstep3|sunos4|ultrix|irix|aix|haiku)
-+ freebsd*|netbsd|openbsd|dragonfly|osf1|osf3|hpux|linuxaout|kfreebsdgnu|freebsd2|solaris2|cygwin32|mingw32|darwin|gnu|nextstep2|nextstep3|sunos4|ultrix|irix|aix|haiku)
+ *)
+ echo "Unknown CPU $build_cpu"
+@@ -3404,7 +3406,7 @@
+ freebsd|netbsd|openbsd|dragonfly|osf1|osf3|hpux|linuxaout|kfreebsdgnu|freebsd2|solaris2|cygwin32|mingw32|darwin|gnu|nextstep2|nextstep3|sunos4|ultrix|irix|aix|haiku)
BuildOS="$build_os"
;;
+- freebsd8) # like i686-gentoo-freebsd8
++ freebsd*) # like i686-gentoo-freebsd8
+ BuildOS="freebsd"
+ ;;
*)
-@@ -3560,7 +3563,7 @@
-
- checkArch() {
- case $1 in
-- alpha|arm|hppa|hppa1_1|i386|ia64|m68k|mips|mipseb|mipsel|powerpc|powerpc64|rs6000|s390|sparc|sparc64|vax|x86_64)
-+ alpha|arm|hppa|hppa1_1|i386|ia64|m68k|mips|mipseb|mipsel|powerpc|powerpc64|rs6000|s390|sparc|sparc64|vax|x86_64|amd64)
- ;;
- *)
- echo "Unknown arch $1"
-@@ -3571,7 +3574,7 @@
+@@ -3486,8 +3488,8 @@
+ vax)
+ HostArch="vax"
+ ;;
+- x86_64)
+- HostArch="x86_64"
++ x86_64|amd64)
++ HostArch="amd64"
+ ;;
+ *)
+ echo "Unknown CPU $host_cpu"
+@@ -3600,8 +3602,8 @@
+ vax)
+ TargetArch="vax"
+ ;;
+- x86_64)
+- TargetArch="x86_64"
++ x86_64|amd64)
++ TargetArch="amd64"
+ ;;
+ *)
+ echo "Unknown CPU $target_cpu"
+@@ -3712,6 +3714,9 @@
- checkVendor() {
- case $1 in
-- dec|unknown|hp|apple|next|sun|sgi|ibm)
-+ dec|unknown|hp|apple|next|sun|sgi|ibm|portbld)
- ;;
- *)
- echo "Unknown vendor $1"
-@@ -3582,7 +3585,7 @@
- checkOS() {
- case $1 in
-- linux|freebsd|netbsd|openbsd|dragonfly|osf1|osf3|hpux|linuxaout|kfreebsdgnu|freebsd2|solaris2|cygwin32|mingw32|darwin|gnu|nextstep2|nextstep3|sunos4|ultrix|irix|aix|haiku)
-+ linux|freebsd*|netbsd|openbsd|dragonfly|osf1|osf3|hpux|linuxaout|kfreebsdgnu|freebsd2|solaris2|cygwin32|mingw32|darwin|gnu|nextstep2|nextstep3|sunos4|ultrix|irix|aix|haiku)
- ;;
- *)
- echo "Unknown OS '$1'"
-@@ -3621,6 +3624,9 @@
- checkVendor "$TargetVendor"
- checkOS "$TargetOS"
+bootstrap_target=`echo "$bootstrap_target" |sed -e 's/-unknown-/-portbld-/g' -e 's/x86_64/amd64/g'`
+build=`echo "$build" |sed -e 's/\(freebsd\)[[:digit:].]*$/\1/g'`
+
# Verify that the installed (bootstrap) GHC is capable of generating
# code for the requested build platform.
- if test "$build" != "$bootstrap_target"
-@@ -9533,7 +9539,7 @@
+ if test "$BootingFromHc" = "NO"
+@@ -5313,9 +5318,9 @@
+ echo 'foo() {}' > conftest.c
+ ${CC-cc} -c conftest.c
+ if ${LdCmd} -r --hash-size=31 -o conftest2.o conftest.o > /dev/null 2>&1; then
+- fp_cv_LdHashSize31=--hash-size=31
++ fp_cv_LdHashSize31=YES
+ else
+- fp_cv_LdHashSize31=
++ fp_cv_LdHashSize31=NO
+ fi
+ rm -rf conftest*
+ fi
+@@ -5334,9 +5339,9 @@
+ echo 'foo() {}' > conftest.c
+ ${CC-cc} -c conftest.c
+ if ${LdCmd} -r --reduce-memory-overheads -o conftest2.o conftest.o > /dev/null 2>&1; then
+- fp_cv_LdReduceMemoryOverheads=--reduce-memory-overheads
++ fp_cv_LdReduceMemoryOverheads=YES
+ else
+- fp_cv_LdReduceMemoryOverheads=
++ fp_cv_LdReduceMemoryOverheads=NO
+ fi
+ rm -rf conftest*
+ fi
+@@ -5387,18 +5392,6 @@
+ CFLAGS="$CFLAGS -fno-stack-protector"
+ fi
+
+- # Reduce memory usage when linking. See trac #5240.
+- if test -n "$LdHashSize31"
+- then
+- LDFLAGS="$LDFLAGS -Wl,$LdHashSize31"
+- IGNORE_LINKER_LD_FLAGS="$IGNORE_LINKER_LD_FLAGS $LdHashSize31"
+- fi
+- if test -n "$LdReduceMemoryOverheads"
+- then
+- LDFLAGS="$LDFLAGS -Wl,$LdReduceMemoryOverheads"
+- IGNORE_LINKER_LD_FLAGS="$IGNORE_LINKER_LD_FLAGS $LdReduceMemoryOverheads"
+- fi
+-
+ rm -f conftest.c conftest.o
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: done" >&5
+ $as_echo "done" >&6; }
+@@ -5445,15 +5438,15 @@
+ fi
+
+ # Reduce memory usage when linking. See trac #5240.
+- if test -n "$LdHashSize31"
++ if [ "$LdHashSize31" = "YES" ]
+ then
+- CONF_GCC_LINKER_OPTS_STAGE0="$CONF_GCC_LINKER_OPTS_STAGE0 -Wl,$LdHashSize31"
+- CONF_LD_LINKER_OPTS_STAGE0="$CONF_LD_LINKER_OPTS_STAGE0 $LdHashSize31"
++ CONF_GCC_LINKER_OPTS_STAGE0="$CONF_GCC_LINKER_OPTS_STAGE0 -Wl,--hash-size=31"
++ CONF_LD_LINKER_OPTS_STAGE0="$CONF_LD_LINKER_OPTS_STAGE0 --hash-size=31"
+ fi
+- if test -n "$LdReduceMemoryOverheads"
++ if [ "$LdReduceMemoryOverheads" = "YES" ]
+ then
+- CONF_GCC_LINKER_OPTS_STAGE0="$CONF_GCC_LINKER_OPTS_STAGE0 -Wl,$LdReduceMemoryOverheads"
+- CONF_LD_LINKER_OPTS_STAGE0="$CONF_LD_LINKER_OPTS_STAGE0 $LdReduceMemoryOverheads"
++ CONF_GCC_LINKER_OPTS_STAGE0="$CONF_GCC_LINKER_OPTS_STAGE0 -Wl,--reduce-memory-overheads"
++ CONF_LD_LINKER_OPTS_STAGE0="$CONF_LD_LINKER_OPTS_STAGE0 --reduce-memory-overheads"
+ fi
+
+ rm -f conftest.c conftest.o
+@@ -5502,15 +5495,15 @@
+ fi
+
+ # Reduce memory usage when linking. See trac #5240.
+- if test -n "$LdHashSize31"
++ if [ "$LdHashSize31" = "YES" ]
+ then
+- CONF_GCC_LINKER_OPTS_STAGE1="$CONF_GCC_LINKER_OPTS_STAGE1 -Wl,$LdHashSize31"
+- CONF_LD_LINKER_OPTS_STAGE1="$CONF_LD_LINKER_OPTS_STAGE1 $LdHashSize31"
++ CONF_GCC_LINKER_OPTS_STAGE1="$CONF_GCC_LINKER_OPTS_STAGE1 -Wl,--hash-size=31"
++ CONF_LD_LINKER_OPTS_STAGE1="$CONF_LD_LINKER_OPTS_STAGE1 --hash-size=31"
+ fi
+- if test -n "$LdReduceMemoryOverheads"
++ if [ "$LdReduceMemoryOverheads" = "YES" ]
+ then
+- CONF_GCC_LINKER_OPTS_STAGE1="$CONF_GCC_LINKER_OPTS_STAGE1 -Wl,$LdReduceMemoryOverheads"
+- CONF_LD_LINKER_OPTS_STAGE1="$CONF_LD_LINKER_OPTS_STAGE1 $LdReduceMemoryOverheads"
++ CONF_GCC_LINKER_OPTS_STAGE1="$CONF_GCC_LINKER_OPTS_STAGE1 -Wl,--reduce-memory-overheads"
++ CONF_LD_LINKER_OPTS_STAGE1="$CONF_LD_LINKER_OPTS_STAGE1 --reduce-memory-overheads"
+ fi
+
+ rm -f conftest.c conftest.o
+@@ -5559,18 +5552,6 @@
+ CONF_CC_OPTS_STAGE2="$CONF_CC_OPTS_STAGE2 -fno-stack-protector"
+ fi
+
+- # Reduce memory usage when linking. See trac #5240.
+- if test -n "$LdHashSize31"
+- then
+- CONF_GCC_LINKER_OPTS_STAGE2="$CONF_GCC_LINKER_OPTS_STAGE2 -Wl,$LdHashSize31"
+- CONF_LD_LINKER_OPTS_STAGE2="$CONF_LD_LINKER_OPTS_STAGE2 $LdHashSize31"
+- fi
+- if test -n "$LdReduceMemoryOverheads"
+- then
+- CONF_GCC_LINKER_OPTS_STAGE2="$CONF_GCC_LINKER_OPTS_STAGE2 -Wl,$LdReduceMemoryOverheads"
+- CONF_LD_LINKER_OPTS_STAGE2="$CONF_LD_LINKER_OPTS_STAGE2 $LdReduceMemoryOverheads"
+- fi
+-
+ rm -f conftest.c conftest.o
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: done" >&5
+ $as_echo "done" >&6; }
+@@ -5772,7 +5753,7 @@
+ i386)
+ test -z "$2" || eval "$2=ArchX86"
+ ;;
+- x86_64)
++ x86_64|amd64)
+
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+@@ -5953,7 +5934,7 @@
+
+ checkVendor() {
+ case $1 in
+- dec|unknown|hp|apple|next|sun|sgi|ibm)
++ dec|unknown|hp|apple|next|sun|sgi|ibm|portbld)
+ ;;
+ *)
+ echo "Unknown vendor $1"
+@@ -5976,7 +5957,7 @@
+ mingw32)
+ test -z "$2" || eval "$2=OSMinGW32"
+ ;;
+- freebsd)
++ freebsd*)
+ test -z "$2" || eval "$2=OSFreeBSD"
+ ;;
+ kfreebsdgnu)
+@@ -9987,7 +9968,7 @@
$as_echo_n "(cached) " >&6
else
ac_check_lib_save_LIBS=$LIBS
@@ -68,7 +203,7 @@ $FreeBSD$
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-@@ -9564,11 +9570,7 @@
+@@ -10018,11 +9999,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_rt_clock_gettime" >&5
$as_echo "$ac_cv_lib_rt_clock_gettime" >&6; }
if test "x$ac_cv_lib_rt_clock_gettime" = x""yes; then :
diff --git a/lang/ghc/files/patch-libraries-gen_contents_index b/lang/ghc/files/patch-libraries-gen_contents_index
new file mode 100644
index 000000000000..a2785da02ed9
--- /dev/null
+++ b/lang/ghc/files/patch-libraries-gen_contents_index
@@ -0,0 +1,10 @@
+--- ./libraries/gen_contents_index.orig 2012-02-01 19:10:32.000000000 +0100
++++ ./libraries/gen_contents_index 2012-05-17 02:20:09.000000000 +0200
+@@ -47,7 +47,6 @@
+ esac
+
+ # Now create the combined contents and index pages
+-echo $HADDOCK_ARGS
+ $HADDOCK --gen-index --gen-contents -o . \
+ -t "Haskell Hierarchical Libraries" \
+ -p "prologue.txt" \
diff --git a/lang/ghc/files/patch-libraries_Cabal_Distribution_Simple_Haddock.hs b/lang/ghc/files/patch-libraries_Cabal_Distribution_Simple_Haddock.hs
deleted file mode 100644
index c8a4d6a29e90..000000000000
--- a/lang/ghc/files/patch-libraries_Cabal_Distribution_Simple_Haddock.hs
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./libraries/Cabal/Distribution/Simple/Haddock.hs.orig 2011-06-13 19:10:10.000000000 +0200
-+++ ./libraries/Cabal/Distribution/Simple/Haddock.hs 2012-01-25 07:33:27.000000000 +0100
-@@ -440,8 +440,9 @@
- let allPkgs = installedPkgs lbi
- directDeps = map fst (externalPackageDeps lbi)
- transitiveDeps <- case dependencyClosure allPkgs directDeps of
-- Left x -> return x
-- Right _ -> die "Can't find transitive deps for haddock"
-+ Left x -> return x
-+ Right inf -> die $ "internal error when calculating transative "
-+ ++ "package dependencies.\nDebug info: " ++ show inf
- interfaces <- sequence
- [ case interfaceAndHtmlPath ipkg of
- Nothing -> return (Left (packageId ipkg))
diff --git a/lang/ghc/files/patch-libraries_Cabal_Distribution_Simple_LocalBuildInfo.hs b/lang/ghc/files/patch-libraries_Cabal_Distribution_Simple_LocalBuildInfo.hs
deleted file mode 100644
index f656c59d64cd..000000000000
--- a/lang/ghc/files/patch-libraries_Cabal_Distribution_Simple_LocalBuildInfo.hs
+++ /dev/null
@@ -1,25 +0,0 @@
---- ./libraries/Cabal/Distribution/Simple/LocalBuildInfo.hs.orig 2011-06-13 19:10:10.000000000 +0200
-+++ ./libraries/Cabal/Distribution/Simple/LocalBuildInfo.hs 2012-01-25 07:33:27.000000000 +0100
-@@ -136,13 +136,17 @@
- }
- deriving (Read, Show)
-
---- | External package dependencies for the package as a whole, the union of the
---- individual 'targetPackageDeps'.
-+-- | External package dependencies for the package as a whole. This is the
-+-- union of the individual 'componentPackageDeps', less any internal deps.
- externalPackageDeps :: LocalBuildInfo -> [(InstalledPackageId, PackageId)]
--externalPackageDeps lbi = nub $
-+externalPackageDeps lbi = filter (not . internal . snd) $ nub $
- -- TODO: what about non-buildable components?
-- maybe [] componentPackageDeps (libraryConfig lbi)
-- ++ concatMap (componentPackageDeps . snd) (executableConfigs lbi)
-+ maybe [] componentPackageDeps (libraryConfig lbi)
-+ ++ concatMap (componentPackageDeps . snd) (executableConfigs lbi)
-+ where
-+ -- True if this dependency is an internal one (depends on the library
-+ -- defined in the same package).
-+ internal pkgid = pkgid == packageId (localPkgDescr lbi)
-
- -- | The installed package Id we use for local packages registered in the local
- -- package db. This is what is used for intra-package deps between components.
diff --git a/lang/ghc/files/patch-mk_config.mk.in b/lang/ghc/files/patch-mk_config.mk.in
new file mode 100644
index 000000000000..091c2aadddb3
--- /dev/null
+++ b/lang/ghc/files/patch-mk_config.mk.in
@@ -0,0 +1,12 @@
+--- ./mk/config.mk.in.orig 2012-02-01 19:10:32.000000000 +0100
++++ ./mk/config.mk.in 2012-05-17 11:30:15.271461640 +0200
+@@ -699,6 +699,9 @@
+ # and compiler/main/DriverPipeline.hs.
+ LdHasNoCompactUnwind = @LdHasNoCompactUnwind@
+
++LdHashSize31 = @LdHashSize31@
++LdReduceMemoryOverheads = @LdReduceMemoryOverheads@
++
+ # On MSYS, building with SplitObjs=YES fails with
+ # ar: Bad file number
+ # see #3201. We need to specify a smaller max command-line size
diff --git a/lang/ghc/files/patch-rts_package.conf.in b/lang/ghc/files/patch-rts_package.conf.in
index 4732ffc6ebe9..e3f4f73239ea 100644
--- a/lang/ghc/files/patch-rts_package.conf.in
+++ b/lang/ghc/files/patch-rts_package.conf.in
@@ -17,7 +17,7 @@ $FreeBSD$
, "-u", "base_GHCziConc_runSparks_closure"
, "-u", "base_GHCziConc_runHandlers_closure"
#endif
-+ , "-L/usr/local/lib"
++ , "-L%%LOCALBASE%%/lib"
/* Pick up static libraries in preference over dynamic if in earlier search
* path. This is important to use the static gmp in preference on Mac OS.