aboutsummaryrefslogtreecommitdiff
path: root/lang/ghc5-doc/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2002-07-26 13:38:27 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2002-07-26 13:38:27 +0000
commitfb48e4903183a8adca98b9344c89e4f567be0214 (patch)
treefbecff40be671fea2e0520a1e24f8652267c45f5 /lang/ghc5-doc/Makefile
parent5ee4f82222d510126f16f3377d45efc12733c048 (diff)
downloadports-fb48e4903183a8adca98b9344c89e4f567be0214.tar.gz
ports-fb48e4903183a8adca98b9344c89e4f567be0214.zip
Notes
Diffstat (limited to 'lang/ghc5-doc/Makefile')
-rw-r--r--lang/ghc5-doc/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/lang/ghc5-doc/Makefile b/lang/ghc5-doc/Makefile
new file mode 100644
index 000000000000..a9df3ad288fd
--- /dev/null
+++ b/lang/ghc5-doc/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: ghc-doc
+# Date created: 26 Jul 2002
+# Whom: olgeni@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= ghc-doc
+PORTVERSION= 5.04
+CATEGORIES= lang
+MASTER_SITES= http://www.haskell.org/ghc/docs/${PORTVERSION}/ \
+ http://www.haskell.org/ghc/docs/${PORTVERSION}/html/
+DISTFILES= building.html.tar.gz building.ps hslibs.html.tar.gz \
+ hslibs.ps libraries.html.tar.gz users_guide.html.tar.gz \
+ users_guide.ps index.html
+DIST_SUBDIR= ghc
+EXTRACT_ONLY=
+
+MAINTAINER= olgeni@FreeBSD.org
+
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${LOCALBASE}/share/doc/ghc
+.for FILE in building.ps hslibs.ps users_guide.ps index.html
+ @${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${FILE} \
+ ${LOCALBASE}/share/doc/ghc
+.endfor
+.for FILE in building.html.tar.gz hslibs.html.tar.gz \
+ libraries.html.tar.gz users_guide.html.tar.gz
+ @${TAR} xfz ${DISTDIR}/${DIST_SUBDIR}/${FILE} \
+ -C ${LOCALBASE}/share/doc/ghc
+.endfor
+
+.include <bsd.port.mk>