aboutsummaryrefslogtreecommitdiff
path: root/lang/ghc
diff options
context:
space:
mode:
authorOliver Braun <obraun@FreeBSD.org>2004-10-17 09:25:00 +0000
committerOliver Braun <obraun@FreeBSD.org>2004-10-17 09:25:00 +0000
commitf7ef84c5840921882677749ecca2c3c4cb0251ab (patch)
treef217a324849aa7467520d308c19b0aafdc52aa84 /lang/ghc
parent86ed6bbde9fdb1758566c9315a18efb224fb8a04 (diff)
downloadports-f7ef84c5840921882677749ecca2c3c4cb0251ab.tar.gz
ports-f7ef84c5840921882677749ecca2c3c4cb0251ab.zip
Notes
Diffstat (limited to 'lang/ghc')
-rw-r--r--lang/ghc/Makefile18
-rw-r--r--lang/ghc/distinfo12
2 files changed, 13 insertions, 17 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index bf3154cb2ba5..ed7bb07f3ea0 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= ghc
-PORTVERSION= 6.2.1
+PORTVERSION= 6.2.2
CATEGORIES= lang haskell
MASTER_SITES= http://www.haskell.org/ghc/dist/${PORTVERSION}/:source \
http://www.haskell.org/ghc/dist/${PORTVERSION}/FreeBSD/:boot
@@ -19,10 +19,6 @@ BOOT_DIST5= ghc-${PORTVERSION}-i386-unknown-freebsd5-boot${EXTRACT_SUFX}:boot
USE_BZIP2= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
DISTFILES= ${SRC_DIST}
.if ${OSVERSION} < 500000
@@ -41,7 +37,7 @@ USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-PLIST_SUB= GHC_VERSION=${PORTVERSION}
+PLIST_SUB= GHC_VERSION=${PORTVERSION}
.if defined(WITHOUT_PROFILE)
PLIST_SUB+= PROFILE="@comment "
.else
@@ -53,7 +49,7 @@ PLIST_SUB+= PROFILE=""
BOOT_DIR= ${WRKDIR}/ghc-${PORTVERSION}-boot
BOOT_GHC= ${BOOT_DIR}/bin/i386-unknown-freebsd/ghc-${PORTVERSION}
-CONFIGURE_ARGS= --with-ghc=${BOOT_GHC} --with-gcc=${CC}
+CONFIGURE_ARGS= --with-ghc=${BOOT_GHC} --with-gcc=${CC}
# specifying CONFIGURE_TARGET doesn't work for some reason.
CONFIGURE_TARGET=
# libgmp:
@@ -61,18 +57,18 @@ CONFIGURE_ENV+= CFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
# override TMPDIR because /tmp often doesn't have enough space
# to build some of the larger libraries.
-TMPDIR = ${WRKSRC}/tmp
-MAKE_ENV += TMPDIR=${TMPDIR}
+TMPDIR= ${WRKSRC}/tmp
+MAKE_ENV+= TMPDIR=${TMPDIR}
# Just do a stage1 build
-ALL_TARGET = stage1
+ALL_TARGET= stage1
MAKE_ENV += stage=1
pre-everything::
.if !defined(WITHOUT_PROFILE)
@${ECHO_CMD} "To build GHC without profiling libraries,"
@${ECHO_CMD} "hit Ctrl-C now and restart with 'make"
- @$(ECHO_CMD) "WITHOUT_PROFILE=YES'."
+ @${ECHO_CMD} "WITHOUT_PROFILE=YES'."
.else
@${ECHO_CMD} "Building GHC without profiling libraries."
.endif
diff --git a/lang/ghc/distinfo b/lang/ghc/distinfo
index 0357e7809c21..560799430b38 100644
--- a/lang/ghc/distinfo
+++ b/lang/ghc/distinfo
@@ -1,6 +1,6 @@
-MD5 (ghc-6.2.1-src.tar.bz2) = fa9f90fd6b8852679c5fc16509e94d7a
-SIZE (ghc-6.2.1-src.tar.bz2) = 5367409
-MD5 (ghc-6.2.1-i386-unknown-freebsd-boot.tar.bz2) = 8414f11ac59c2b8b4bd19c363a5f6f41
-SIZE (ghc-6.2.1-i386-unknown-freebsd-boot.tar.bz2) = 5647007
-MD5 (ghc-6.2.1-i386-unknown-freebsd5-boot.tar.bz2) = dc3538e580c08a0b3619a18e1f146a71
-SIZE (ghc-6.2.1-i386-unknown-freebsd5-boot.tar.bz2) = 5690738
+MD5 (ghc-6.2.2-src.tar.bz2) = 8dc5ab2137ef9593f52180b0b2423d7f
+SIZE (ghc-6.2.2-src.tar.bz2) = 5407409
+MD5 (ghc-6.2.2-i386-unknown-freebsd-boot.tar.bz2) = e9a83bc75c946d3d03f508a5cb972bee
+SIZE (ghc-6.2.2-i386-unknown-freebsd-boot.tar.bz2) = 5655704
+MD5 (ghc-6.2.2-i386-unknown-freebsd5-boot.tar.bz2) = ce8c37454fe298b2a1da89093302521e
+SIZE (ghc-6.2.2-i386-unknown-freebsd5-boot.tar.bz2) = 5627556