aboutsummaryrefslogtreecommitdiff
path: root/lang/ghc
diff options
context:
space:
mode:
authorGleb Popov <arrowd@FreeBSD.org>2020-05-26 20:18:41 +0000
committerGleb Popov <arrowd@FreeBSD.org>2020-05-26 20:18:41 +0000
commit03d81dda1cc3118c2d6a97f319097ba3e3bda300 (patch)
treeeaf6fd99287f2dbe9d681ea086de224457afe51b /lang/ghc
parentd2ad0f05150edad075b678ba746dd60c83b01c1f (diff)
downloadports-03d81dda1cc3118c2d6a97f319097ba3e3bda300.tar.gz
ports-03d81dda1cc3118c2d6a97f319097ba3e3bda300.zip
lang/ghc: Add patch for timer machinery.
PR: 241849 Submitted by: Kevin Zheng <kevinz5000@gmail.com>
Notes
Notes: svn path=/head/; revision=536651
Diffstat (limited to 'lang/ghc')
-rw-r--r--lang/ghc/Makefile1
-rw-r--r--lang/ghc/files/patch-rts_posix_Itimer.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index ff989c064293..36ef1a510ad9 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ghc
PORTVERSION= ${GHC_VERSION}
+PORTREVISION= 1
CATEGORIES= lang haskell
MASTER_SITES= https://www.haskell.org/ghc/dist/${PORTVERSION}/:source \
LOCAL/arrowd/:boot \
diff --git a/lang/ghc/files/patch-rts_posix_Itimer.c b/lang/ghc/files/patch-rts_posix_Itimer.c
new file mode 100644
index 000000000000..a6d2574ebde8
--- /dev/null
+++ b/lang/ghc/files/patch-rts_posix_Itimer.c
@@ -0,0 +1,11 @@
+--- rts/posix/Itimer.c.orig 2020-02-24 23:55:56 UTC
++++ rts/posix/Itimer.c
+@@ -48,7 +48,7 @@
+ #define USE_PTHREAD_FOR_ITIMER
+ #endif
+
+-#if defined(freebsd_HOST_OS) && defined(THREADED_RTS)
++#if defined(freebsd_HOST_OS)
+ #define USE_PTHREAD_FOR_ITIMER
+ #endif
+